Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Alan Williams 3 posts 103 karma points
    Jan 13, 2016 @ 17:55
    Alan Williams
    0

    Umbraco Manual Install

    I have a fresh Windows Server 2012R2 web server, with IIS working. I have followed these instructions 2 different times with the same result, "500 - Internal server error".

    I have placed the Umbraco root files in the wwwroot and given the IIS_USRS modify permissions to that folder.

    Frustrated...

  • Alan Williams 3 posts 103 karma points
    Jan 13, 2016 @ 18:02
    Alan Williams
    0

    Update, I tried to move the Umbraco extraceted directory and mapped a new site in IIS with these results:

    HTTP Error 500.19 - Internal Server Error

    The requested page cannot be accessed because the related configuration data for the page is invalid.

    Detailed Error Information:

    Module IIS Web Core

    Notification BeginRequest

    Handler Not yet determined

    Error Code 0x80070021

    Config Error This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".

    Config File \?\C:\inetpub\wwwroot\UmbracoCms.7.3.4\web.config

    Requested URL http://localhost:80/

    Physical Path C:\inetpub\wwwroot\UmbracoCms.7.3.4

    Logon Method Not yet determined

    Logon User Not yet determined

    Config Source: 182: 183:

  • Jason 113 posts 628 karma points
    Jan 13, 2016 @ 18:28
    Jason
    0

    I think your IIS install may not be correct. I googled your error and it seems to be related to a bad configuration of IIS.

    Also check that your app pool is setup correctly.

    http://stackoverflow.com/questions/2138285/asp-net-iis-web-config-internal-server-error

  • Alan Williams 3 posts 103 karma points
    Jan 13, 2016 @ 20:37
    Alan Williams
    100

    So, I enabled all of the ASP.NET 4.5 Features and it worked...

  • Daniel 29 posts 142 karma points
    Sep 27, 2017 @ 18:41
    Daniel
    0

    Just to clarify - how to enable all of the ASP.NET 4.5 Features :

    I found this at http://www.jammer.biz/enable-asp-net-on-windows-10/

    In PowerShell, as administrator, run dism /online /enable-feature /all /featurename:IIS-ASPNET45

    This did the trick for me.

Please Sign in or register to post replies

Write your reply to:

Draft