Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Miguel Arcilla 4 posts 84 karma points
    Feb 09, 2016 @ 06:15
    Miguel Arcilla
    0

    Umbraco install page doesn't load, redirects to itself

    I recently successfully installed Umbraco to an SQL Server Express database instance. I accidentally deleted the local database after installation, and attempted to reinstall with the same connection string. However, instead of being taken to the same install page, it seems to redirect onto itself. The page that is shown is the "install in progress" page, but without any indicator of an install going on. The database is not updated either. The URL looks like the ff.:

    http://localhost:18032/install/?redir=true&url=http%3a%2f%2flocalhost%3a18032%2f#?redir=true&url=http:%2F%2Flocalhost:18032%2F

    Is there any way I can rectify this issue and get taken back to the standard install page? The database is completely blank at the moment.

    I am installing Umbraco from Visual Studio 2015 and running it locally via IISExpress.

  • Jan Skovgaard 11247 posts 23464 karma points MVP 7x admin c-trib
    Feb 09, 2016 @ 20:49
    Jan Skovgaard
    0

    Hi Miguel and welcome to our :)

    That sounds like a weird issue - Do you only have this local instance or did you deploy the site to a server afterwards before things got messed up?

    Did you delete the entire database? If so you'll probably need to recreate the database before the connection string will work if you have not done so already? If the DB does not exist then Umbraco can of course not install.

    If the DB has been recreated already can you then see any error messages in the console log of your browser?

    /Jan

  • Miguel Arcilla 4 posts 84 karma points
    Feb 10, 2016 @ 02:15
    Miguel Arcilla
    0

    Thank you for the welcome Jan, I'm happy to be here! :)

    This is currently a local issue (SQL Express), I have not yet tried deploying to an actual SQL Server instance.

    I deleted the .mdf and .ldf files, and recreated them from the SQL Server Object Explorer tab of Visual Studio.

    I just checked the install files and saw the ff. error:

    GET http://localhost:18032/install/api/GetSetup 500 (Internal Server Error)

    It occurs in line 106 of angular.min.js. However, I cannot find the actual file to debug... Would this be solvable by simply uninstalling and reinstalling Umbraco via NuGet? I have not made any changes to the system yet, so it wouldn't be the end of the world, but I am not sure how clean a process that is.

    Thank you so much for your help!

  • Jan Skovgaard 11247 posts 23464 karma points MVP 7x admin c-trib
    Feb 10, 2016 @ 06:34
    Jan Skovgaard
    100

    Hi Miguel

    Ah ok - then I actually think that it's better if you just try starting over from scratch setting up a new installation :)

    /Jan

  • Miguel Arcilla 4 posts 84 karma points
    Mar 13, 2016 @ 14:59
    Miguel Arcilla
    0

    Hi Jan,

    I'd like to thank you for your help and speedy replies :)

    I tried simply wiping out all my code and starting fresh with a totally new database, and that seemed to do the trick.

    However, when I tried to move into more of a "live environment", the same error occurs.

    I am running a clean Umbraco website on Azure deployed from Visual Studio, and using an empty SQL Azure database configured in my Web.config.

    When I navigate to the link to go through the installation process, though, I get the same install redirect loop with no content.

    I can provide the link, now, which is here.

    The error occurs when making a call to /install/api/GetSetup.

    Any idea where I can find the missing files for this, if any?

    Thanks, Miguel

  • Jan Skovgaard 11247 posts 23464 karma points MVP 7x admin c-trib
    Mar 15, 2016 @ 06:54
    Jan Skovgaard
    0

    Hi Miguel

    Seems to me like the setup has succeeded? I get a login-screen when I visit the link provided - Do you still get the loop? If so then perhaps try using another browser - If that works then it might be some weird caching stuff in your primary browser perhaps?

    /Jan

  • Miguel Arcilla 4 posts 84 karma points
    Mar 15, 2016 @ 15:19
    Miguel Arcilla
    0

    I'm sorry for not getting back to this! I was able to get it to work just yesterday :)

    I actually found the answer here, in a thread that you were also a part of! My issue was that I was setting my connection string in Visual Studio and deploying without debugging, which is what was causing the getsetup API error. I ran the site in debug mode to do the initial install, and then published the site with the generated connection string, and everything worked perfectly!

    Thanks again for all your help Jan :)

  • Jan Skovgaard 11247 posts 23464 karma points MVP 7x admin c-trib
    Mar 15, 2016 @ 20:28
    Jan Skovgaard
    0

    Hi Miguel

    Ok, good to hear you got it sorted out - Haha, I sometimes find posts where I have made the answer with the solution when I run into issues and thinking..."aaah yes, now I remember" :D

    /Jan

  • Marcio Goularte 354 posts 1240 karma points
    Jan 28, 2017 @ 01:57
    Marcio Goularte
    0

    Hello everybody. I went through this with Azure. I created an application with a linked database. When I tried to install it always gave these error: 500 Internal Server error /install/api/GetSetup. Analyzing the log I discovered that the installation tried to connect to the database, even though it was a new installation. The log had this error: Invalid object name 'umbracoUser'. I then updated the azure database and unlinked it from the web application and returned to normal.

  • Stefan Kolbe 2 posts 71 karma points
    Oct 30, 2019 @ 04:30
    Stefan Kolbe
    0

    Hi, just noting that I encountered the same issue when trying to recreate the database on a new server during a deployment.

    It seems the issue is that I had the connection string configured in the web.config (pointing to the new server) to an empty database.

    Once I commented out the connection string, the installation proceeded as expected.

Please Sign in or register to post replies

Write your reply to:

Draft