Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Muhammad Adeel 19 posts 109 karma points
    Feb 16, 2016 @ 12:13
    Muhammad Adeel
    0

    Upgrading umbraco 4.7.1 to 7.4.0

    On you web portal you say that we need to go step by step to upgrade umbraco. But in your releases the oldest is 4.11.8 . How and from where i can download the previous releases(binaries with /umbraco /umbraco-client etc folders).for example the first step in this link (in my case) is to update 4.7.1 to 4.7.2. but from where i can download that 4.7.2 binaries . Help please !!!

    Also how to download latest Ucomponent to live site?

    Also it is stated that after merging WEB.CONFIG "copy back the version number, and the connection string as they were". what does this mean ? what version number i should put if i am upgrading 4.7.1 to 4.7.2 ?

    Thank you in advance.

  • Jan Skovgaard 11255 posts 23494 karma points MVP 7x admin c-trib
    Feb 17, 2016 @ 18:53
    Jan Skovgaard
    0

    Hi Muhammad and welcome to our :)

    Fortunately Lee Kelleher has an unofficial stash of retired Umbraco releases here http://code.leekelleher.com/umbraco/archive/

    Be aware that depending on what version of Umbraco you're using you may not want to upgrade to the latest version since it may not be compatible - You can see a chart of compatibility here http://ucomponents.org/compatibility/ and you can download the different version from the package repository here on our or from nuget, which is also described on the linked page.

    Make sure to follow the upgrade instructions very carefully and keep a backup of the site (both the database and the files before progressing) - Depending on what 3rd party packages etc. you're using it may be a bumpy road to go down since you'll need to have an idea about how to map the stored data to another format using another property in Umbraco perhaps.

    A lot of things have obviously changed in the latest release of Umbraco compared to the old version that you're currently using. For instance uComponents does not exist for v7 and the datatypes are now based on angularjs powered property editors so many of the packages that worked for v4 and 6 may not work anymore.

    So perhaps it's a good idea to consider if migration from the old solution to a fresh install of 7.4 is more feasible instead?

    You should be able to go from 4.7 to 6.2.x I think but the underlying API's have changed between 4.7 and 6 and some things may break between these versions as well.

    Hope this helps though!

    /Jan

Please Sign in or register to post replies

Write your reply to:

Draft