Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Geoff Baldwin 80 posts 100 karma points
    Sep 27, 2010 @ 13:28
    Geoff Baldwin

    CSS not being applied correctly on new install

    I am trying to install a Runway installation with Runway Gallery, Runway Dropdown navigation and Runway Contact Form into c:\inetpub\wwwroot\JRBP1

    Apologies for the length of the post - just trying to provide as much info as possible.

    I set up and configured an SQL database JRBP1
    I added a site (JRBP1) to IIS 7:
        Gave it a host name
        Port 80
        IP address *
        All other bindings as per the Default web site
    I added
    to my hosts file

    Ran WPI 3.0 to install latest Umbraco into JRBP1
    All went well and I launched Umbraco -- no problems were apparent

    When I previewed the site none of the formatting seemed to be applied.

    In the Runway Master Template I changed
    <link rel="stylesheet" type="text/css" href="/css/runway.css" />
    <link rel="stylesheet" type="text/css" href="~/css/runway.css" />

    The basic formatting then appeared correctly for all pages
    But the drop down navigation menu was
        a) not drop down!
        b) Didn't take me anywhere

    Assuming that the issue with the style of the menu was similar to the above I made the following changes:

    Runway dropdownNavigation.xslt
    added the ~ in front the /scripts
            <xsl:value-of select="umbraco.library:RegisterJavaScriptFile('droppyJs', '~/scripts/droppy.js')"/>
            <xsl:value-of select="umbraco.library:RegisterStyleSheetFile('droppyCss', ~/css/dropdownnavigation.css')"/>

    aded the # infront of the /scripts
            <xsl:value-of select="umbraco.library:RegisterStyleSheetFile('RunwayGallery', '~/css/RunwayGallery.css')"/>

    added the ~ in front of of the /scripts
            <xsl:value-of select="umbraco.library:RegisterJavaScriptFile('jQueryLightbox', '~/scripts/jquery.lightbox-0.5.min.js')"/>
            <xsl:value-of select="umbraco.library:RegisterJavaScriptFile('runwayGallery', ~/scripts/')"/>
            <xsl:value-of select="umbraco.library:RegisterStyleSheetFile('jQueryLightboxCss', '~/css/jQueryLightbox.css')"/>
            <xsl:value-of select="umbraco.library:RegisterStyleSheetFile('runwayGalleryCss', '~/css/RunwayGallery.css')"/>

    $(function() {
                $('.nitroGallery a:rel:lightbox').lightBox({
                imageLoading: '~/css/jQueryLightboxImages/loading.gif',
                imageBlank: '~/css/jQueryLightboxImages/blank.gif',
                imageBtnClose: '~/css/jQueryLightboxImages/close.gif',
                imageBtnPrev: '~/css/jQueryLightboxImages/prev.gif',
                imageBtnNext: '~/css/jQueryLightboxImages/next.gif'

    In web.config I have
        <add key="umbracoDbDSN" value="server=.\sqlexpress;database=JRBP1;user id=umbracouser;password=umbraco" />
        <add key="umbracoConfigurationStatus" value="4.5.2" />
        <add key="umbracoReservedUrls" value="~/config/splashes/booting.aspx,~/install/default.aspx,~/config/splashes/noNodes.aspx" />
        <add key="umbracoReservedPaths" value="~/umbraco,~/install/" />
        <add key="umbracoContentXML" value="~/App_Data/umbraco.config" />
        <add key="umbracoStorageDirectory" value="~/App_Data" />
        <add key="umbracoPath" value="~/umbraco" />
        <add key="umbracoEnableStat" value="false" />
        <add key="umbracoHideTopLevelNodeFromPath" value="true" />
        <add key="umbracoEditXhtmlMode" value="true" />
        <add key="umbracoUseDirectoryUrls" value="false" />
        <add key="umbracoDebugMode" value="true" />
        <add key="umbracoTimeOutInMinutes" value="20" />
        <add key="umbracoVersionCheckPeriod" value="7" />
        <add key="umbracoDisableXsltExtensions" value="true" />
        <add key="umbracoDefaultUILanguage" value="en" />
        <add key="umbracoProfileUrl" value="profiler" />
        <add key="umbracoUseSSL" value="false" />
        <add key="umbracoUseMediumTrust" value="false" />
            Set this to true to enable storing the xml cache locally to the IIS server even if the app files are stored centrally on a SAN/NAS
            Alex Norcliffe 2010 02 for 4.1-->
        <add key="umbracoContentXMLUseLocalTemp" value="false" />

    None of this had any effect - so I'm still missing something. But What?

    Also, There seems to be an issue with installing the gallery into a sub folder of wwwroot (is this a 'Virtual Directory'? - excuse the possibly dumb question but I am very new to this)

    In the properties tab of the photos in the content section the photos are linked to
    /JRBP1/gallery/codegarden-2008/name of photo.aspx
    The Gallery folder does not exist in JRBP1.
    Neither does gallery.aspx which is linked to by the Gallery Page
    Do I have to install these manually if I am not installing into wwwroot?

  • Geoff Baldwin 80 posts 100 karma points
    Sep 27, 2010 @ 15:06
    Geoff Baldwin

    OK --- my apologies. Basically an error born out of not knowing what the heck I am playing with :(

    During the Umbraco install I was leaving he selection on 'Default Web Site' instead of selecting the website I had set up in ISS.

    When I did that all worked perfectly!!

    How do I mark the question as solved????

Please Sign in or register to post replies

Write your reply to: