Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Andy Moore 7 posts 30 karma points
    Feb 03, 2011 @ 23:12
    Andy Moore
    0

    Runway blog comments not saving

    All,

    I've installed v4.6.1 with the Business Starter Kit and included in the starter kit is the new Runway.Blog package.

    When I create new post and attempt to add a comment, the form hangs at "Your comment is being submitted, please wait". In following the underlying javascript, the page is attempting an ajax post to /base/RunwayBlog/CreateComment/1075.aspx. Navigating directly to this page returns an error "Extension not found or permission denied"

    I've done some searching through the forum and found this post which relates to the exact error, but is using the Blog4Umbraco package. I've checked the restExtensions.config file, and it appears to have the correct setting:

    <ext assembly="Runway.Blog" type="Runway.Blog.Library.Base" alias="umbBlog">
        <permission method="CreateComment" returnXml="false" allowAll="true" />
        <permission method="GetGravatarImage" returnXml="false" allowAll="true" />
      </ext>

    Does anyone have an idea of how to resolve this permission issue? I'd like to continue using the Runway package as I've already reconfigured the templates and doctypes, but not sure how to resolve this comment problem.

    Thanks,

    Andy

  • Jan Skovgaard 11258 posts 23498 karma points MVP 7x admin c-trib
    Feb 03, 2011 @ 23:28
    Jan Skovgaard
    0

    Hi Andy

    This is a longshot but I'm thinking that this could maybe have something to do with, what permissions have been set for network service or the iusr? Are they given proper permissions on the umbraco root folder?

    /Jan

  • Andy Moore 7 posts 30 karma points
    Feb 04, 2011 @ 00:10
    Andy Moore
    0

    Hi Jan,

    I've run the standard permission set, assigning to the correct app pool:

    icacls . /grant "IIS APPPOOL\Umbraco":(OI)(CI)M
    icacls app_code /grant "IIS APPPOOL\Umbraco":(OI)(CI)RX
    icacls app_browsers /grant "IIS APPPOOL\Umbraco":(OI)(CI)RX
    icacls app_data /grant "IIS APPPOOL\Umbraco":(OI)(CI)M
    icacls bin /grant "IIS APPPOOL\Umbraco":(OI)(CI)R
    icacls config /grant "IIS APPPOOL\Umbraco":(OI)(CI)M
    icacls css /grant "IIS APPPOOL\Umbraco":(OI)(CI)M
    icacls data /grant "IIS APPPOOL\Umbraco":(OI)(CI)M
    icacls masterpages /grant "IIS APPPOOL\Umbraco":(OI)(CI)M
    icacls media /grant "IIS APPPOOL\Umbraco":(OI)(CI)M
    icacls python /grant "IIS APPPOOL\Umbraco":(OI)(CI)M
    icacls scripts /grant "IIS APPPOOL\Umbraco":(OI)(CI)M
    icacls umbraco /grant "IIS APPPOOL\Umbraco":(OI)(CI)R
    icacls usercontrols /grant "IIS APPPOOL\Umbraco":(OI)(CI)R
    icacls xslt /grant "IIS APPPOOL\Umbraco":(OI)(CI)M
    icacls web.config /grant "IIS APPPOOL\Umbraco":(OI)(CI)M

    and have confirmed directly on the directories and files that the permissions are correct.

    I'm going to attempt a fresh installation again and see if I run into the same problem. I'll follow up with a post noting success or not.

    Thanks,
    Andy

  • Andy Moore 7 posts 30 karma points
    Feb 04, 2011 @ 00:45
    Andy Moore
    0

    Okay,

    So if I do a fresh install of the Personal Blog starter kit, the comment post works correctly. However, if I do a fresh install of the Business Website starter kit they do not. I've got them both running locally in seperate sites, so now I'm going to start comparing to see if I can find a difference between the two.

    Thanks
    Andy

  • Andy Moore 7 posts 30 karma points
    Feb 05, 2011 @ 02:01
    Andy Moore
    2

    Figured it out!

    When the starter kit installs, it also updates the restExtensions.config file. However, the ext information is wrong. In the install, it updates with:

    <ext assembly="Runway.Blog" type="Runway.Blog.Library.Base" alias="umbBlog">
        <permission method="CreateComment" returnXml="false" allowAll="true" />
        <permission method="GetGravatarImage" returnXml="false" allowAll="true" />
    </ext>

    which seems to match the Blog4Umbraco package. But, in looking at the AjaxCommentForm.aspx it is posting to /base/RunwayBlog/CreateComment/xxx.aspx (as noted in my initial post). Therefore, the restExtensions section alias attibute should be RunwayBlog:

      <ext assembly="Runway.Blog" type="Runway.Blog.Library.Base" alias="RunwayBlog">
        <permission method="CreateComment" returnXml="false" allowAll="true" />
        <permission method="GetGravatarImage" returnXml="false" allowAll="true" />
      </ext>

    Once I updated the alias and recycled the site the commenting now works!

  • sarbjit 1 post 71 karma points
    Jan 10, 2016 @ 07:26
    sarbjit
    0

    thanks andy its working on in umbraco 6.1.6 and let me know how to add comments in spam for approve

  • Andy Moore 7 posts 30 karma points
    Feb 05, 2011 @ 02:20
    Andy Moore
    0

    On a side note, could someone please mark this as answered as I cannot seem to be able to do so!

    Thanks,
    Andy

  • Simon Kibsgård 62 posts 73 karma points
    Jun 09, 2011 @ 08:55
    Simon Kibsgård
    0

    So cool Andy.

    Thank you, I had the same problem and you really saved me some time.

    Your post is the solution, but I cannot seem to mark it either :-(

    Best regards, Simon K

  • Robert Watson 1 post 21 karma points
    Jun 17, 2011 @ 19:19
    Robert Watson
    0

    Thanks for this - wish I would have found this post about thirty minutes ago! Has this bug been reported or anything?

  • Lee 5 posts 25 karma points
    Aug 31, 2011 @ 16:05
    Lee
    0

    Hi Andy,

    Thank you shar your idea.I face the same issue.And I spend a lot of time to find the source code of "Runway.Blog", then I search in Umbraco form. You help me.

  • Johan Roug 97 posts 153 karma points
    Sep 06, 2011 @ 22:23
    Johan Roug
    0

    Thanks Andy.... You rock.. 

  • tarekahf 215 posts 153 karma points
    Oct 05, 2011 @ 14:36
    tarekahf
    0

    Thanks Andy .. I think your solution will help me.

    But what do you mean by "recycled the site" ? Do you mean restart IIS ?

    Tarek.

  • Andy Moore 7 posts 30 karma points
    Oct 05, 2011 @ 15:02
    Andy Moore
    0

    Tarek,

    Yes, I just recycled the App Pool but you can do the same by altering the web.config file of the site (add a new line, etc and save).

    Thanks,
    Andy

  • Lincoln Vu 8 posts 29 karma points
    Apr 18, 2012 @ 20:12
    Lincoln Vu
    1

    Thank Andy, I should have looked up this earlier to save 1 of my day. Also I notice that in my installation jquery.validate.min.js is included inside Setttings>Templates>StarterMasterKit>Blogpost and results in this error when click Submit:

    Uncaught TypeError: Object #

    So my fix is to move

    <script type="text/javascript" src="/scripts/jquery.validate.min.js">script>

    to StarterMasterKit file. Albeit it might be redundant for pages with no forms, it gets rid of the error for me.

    (Also instead of changing the config file like you did, an alternative is to change "RunwayBlog" to the original "umbBlog" in

    WebMatrix: Files: usercontrols>Blog>AjaxCommentForm.ascx:

    var url = "/base/umbBlog/CreateComment/.aspx";

    )

    Hope that helps someone.

     

  • lu408 16 posts 21 karma points
    Feb 25, 2013 @ 17:33
    lu408
    0

    This issue is still not fixed in Version 6 + Business start kit, your solution works fine (by making the AJAX logic and base/ url match)
    can only say thanks here, as my KARMA is not enough to vote you up 

Please Sign in or register to post replies

Write your reply to:

Draft