Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Charles Williams 3 posts 54 karma points
    Dec 08, 2014 @ 22:23
    Charles Williams
    0

    Absolute URL's in the FeedViewer Module

    I am new to developing with Umbraco.  I have read pieces of the documentation, but I am having a hard-time finding information on how Umbraco handles relative and absolute URL's when you edit content.  I already changed the configuration in the TinyMCEconfig file to allow absolute URL's, but it seems to only work with URL's that do not contain www.  I am using the FeedViewer module and Umbraco v6.1.6.  In the FeedViewer macro, it only excepts URL's that have http:// in the URL, however the feed I am trying to post is in a different sub directory but within the same base address as the website and you have to use www because of the way the domain is setup in the network on the domain controller.

    When I save the homepage, the feedviewer macro defaults back to the relative URL.  How can I stop it from doing this?

  • Jan Skovgaard 11258 posts 23498 karma points MVP 7x admin c-trib
    Dec 09, 2014 @ 05:58
    Jan Skovgaard
    0

    Hi Charles and welcome to our :)

    Is this the Feed viewer you're writing about above?

    When you use a different sub-directory is that then on the disk? What does the code for generating the feed look like?

    And have you setup a hostname for your website? If not that maye be the reason why you're not getting the absolute path since I can imagine the feed viewer is using the umbraco.library:NiceUrl() extension to generate the URL by an id. But if there has not been added a hostname to the root node the domain won't be a part of the path.

    Looking forward to hearing from you.

    /Jan

  • Charles Williams 3 posts 54 karma points
    Dec 09, 2014 @ 15:01
    Charles Williams
    0

    Yes, that is the Feed Viewer I was talking about.  It works great by the way.  Easy to style.  

    And that is what I am more familiar with is front-end development, so I am still learning to develop and use the back-end of Umbraco.  

    Yes, the sub-directory is on the same disk, in the same folder, just set-up as a separate asp application, but the URL is still www.mysite.com/app/lib/eventsxml.asp?.......

    Now I did have this working before I moved the website, because it was pulling data from the old site during production.  Once I moved everything and put everything in the same URL location, then of course the first time the homepage was saved it changed all absolute URL's to relative ones.  So I changed the TinyMCE configuration not to convert the URL's, but now any URL with www still gets converted. 

    Yes, I do have the hostnames setup as www.mysite.com and http://www.mysite.com.  Unfortunately the domain controller has the same domain name as the website URL, so I have to use www, or I would leave out the www to get around this issue.  

    I am also having issues with the website being accessed locally. When you go to www.mysite.com, it doesn't always redirect to www.mysite.com/home.aspx.  Sometimes you just get a 404 page instead.  I am not really sure what this issue is either.  It seems to block home.aspx for about 10 minutes at a time, and then the redirection to home.aspx will work again for about 5 our 10 minutes.  I am not sure sure why this happens internally on the network.  Works fine externally.  I have checked all my settings in IIS, but I don't see anything that would keep it from redirecting to the homepage.

  • Charles Williams 3 posts 54 karma points
    Dec 15, 2014 @ 15:40
    Charles Williams
    101

    I finally figured out how to do this in the Feed Viewer module, just in case anyone ever wants to know.  I added this to the FeedViewer.xslt file:

    <xsl:param name="url" select="'http://www.mysite.com'" /> 
    <xsl:variable name="feedRelUrl" select="/macro/feedUrl" />
    <xsl:variable name="feed" select="concat($url, $feedRelUrl)" />
Please Sign in or register to post replies

Write your reply to:

Draft