Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Patrick McAndrew 48 posts 163 karma points
    Aug 31, 2010 @ 11:38
    Patrick McAndrew
    0

    Cache not updating

    umbraco v 4.5.2 (Assembly version: 1.0.3891.20719)

    I have a true/false property on a content node.  When I update the value and save/publish, the updated value is not detected in the xslt.  I've tried republishing the entire site and it still doesn't update, but if I recycle the app pool in IIS, then the new value is detected.  I'm using 4.5.2 with the UseLegacyXmlSchema=true.

    Any ideas of a better workaround?

  • Ismail Mayat 4285 posts 9244 karma points MVP 2x admin c-trib
    Aug 31, 2010 @ 12:37
    Ismail Mayat
    0

    Patrick,

    Is it just that field that is not updating or all fields. Can you check your folder permissions as publish issues are usually permissions related.

    Regards

    Ismail

  • Patrick McAndrew 48 posts 163 karma points
    Aug 31, 2010 @ 14:03
    Patrick McAndrew
    0

    Hi Ismail,

    It appears to be all fields.  I've given the IUSR modify rights to the data folder, with no success, then tried giving everyone full control to the root without success either.  Also, its interesting that new nodes do not show up either until the app pool is recycled.

     

    Thanks,

    Patrick

  • Patrick McAndrew 48 posts 163 karma points
    Sep 01, 2010 @ 16:40
    Patrick McAndrew
    0

    So the App_Data\umbraco.config cache data file is updated properly.  The xslt is just not seeing the updated data.  I've tried creating a usercontrol which calls umbraco.cms.businesslogic.cache.Cache.ClearAllCache();.  After running that, the problem still occurs.  The macro cache time is set to 1 second.  I've tried turning off XmlCacheEnabled and ContinouslyUpdateXmlDiskCache to no avail. 

     

    Can anyone give any pointers on what is going on in the xslt?  Is it pre-compiled somewhere?  Is it perhaps loading the umbraco.config file in memory and not refreshing?

  • Patrick McAndrew 48 posts 163 karma points
    Sep 02, 2010 @ 14:35
    Patrick McAndrew
    0

    Finally found http://our.umbraco.org/wiki/reference/api-cheatsheet/publishing-and-republishing - when I use the suggested http;//YOURDOMAIN/Umbraco/dialogs/republish.aspx?refreshNodes=1234 it resolves the problem.  I guess I will hook into the publishing api to run those commands which will hopefully resolve the issue.  Still looks like a bug to me though...

  • Patrick McAndrew 48 posts 163 karma points
    Sep 02, 2010 @ 16:22
    Patrick McAndrew
    0

    Finally tracked it out.

    We have 2 domains in the Umbraco instance: site a & site b.  I was updating the site b whilst logged into the site a\umbraco.  The data was updated, but for some reason, the cache was not being refreshed.  Once I login to the site b\umbraco and publish, everything works fine. Perhaps this was a design issue?  But if so, there should be a warning when you publish on site b if you're logged into site a.

     

     

  • Christopher Pascual 23 posts 270 karma points
    Oct 12, 2015 @ 13:55
    Christopher Pascual
    0

    5 Years Later ... Encountered the bug and this saved me

    What happened :

    Our client had an old website that has 2 languages , english and danish. Lets say myclientsite.com and myclientsite.biz

    I thought the cache was not updating but upon examining the .config the changes are published , however the in memory does not get updated

    I suspect this due to the hosting's config of the iis , instead of multiple binding , it is binded as 2 site instance.

    e.g.

    IIS ->myclientsite.com (own app pool) ->myclientsite.biz (own app pool)

    instead of like this

    IIS ->myclientsite ( 1 app pool )

    And so we advised the client to separately publish his changes on

    myclientsite.com/umbraco myclientsite.biz/umbraco

    since the client does not want to upgrade.

  • Niels Lynggaard 172 posts 469 karma points
    Aug 18, 2017 @ 13:03
    Niels Lynggaard
    0

    AND 2 years later, I run into this... Same problem, 2 different sites, same Umbraco 4 installation..

    We recently moved a client from another hosting to our provider, and suddenly the client has to log into every domain to publish.. He's not very happy about that. I checked with hosting, the two sites that we are currently looking at are running under the same app-pool, but yet, site b isn't updated when site a is published and vice-versa.

    Any idea on what to tell the hosting to do to fix it? I tried writing an eventhandler that flushes the cache, but that doesn't help (It may be just flushing under the same domain).

    I tried updating umbracosettings.config with a few lines that supposedly should flush the cache when the xml-cache changes, but no luck still.

    As a quickfix, I created a dashboard-tab under content with a button that just updates a line in the web.config, wich solves the problem (soft reset). I don't want to do this in my eventhandler, though, since I don't know how this will behave/perform on bulk-publishing..

    But my solution really isn't a great fix, since it will still not work on scheduled publishing. (So, I have to get up at 6 on monday, log in and click the damn button..)

    Any suggestions on what may be causing this on the server-setup?

    Cheeers, Niels

  • Niclas Lindqvist 46 posts 115 karma points
    Oct 07, 2010 @ 15:59
    Niclas Lindqvist
    0

    Hi,

    I'm having this exact issue on our install of Umbraco 4.5.2, but we're not running multiple websites on our install. However we are running on in a shared hosting environment (Binero.se, ASP 4.0)

    When publishing the changes show up on the live site when viewing the site from the same computer (actually on all computers on the same network(!)) but when viewing it from a different computer/network the page is unchanged. Restarting the app pool usually solves this temporarily. But the next time we publish we're back on square one with no publications shown on other networks.

    We've been trying with XmlCacheEnabled true/false, ContinouslyUpdateXmlDiskCache true/false and also umbracoContentXMLUseLocalTemp true/false. Nothing seems to make a change.

    Has anybody had these experiences on a single site installation? Any help is greatly appreciated!

Please Sign in or register to post replies

Write your reply to:

Draft