Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Dave Forster 28 posts 74 karma points
    Sep 14, 2010 @ 11:54
    Dave Forster

    ASP.NET4.0 / Umbraco 4.5.2 : Setting clientIDMode="Static" in web.config breaks admin features

    If you explicity set the clientIDMode property in the web.config to "Static" certain admin features are broken. I believe this is to do with the way jquery in umbraco_client is selecting elements (perhaps there are some hardcoded id's)... i have also seen script errors on IE that specific target jquery as the source.

    Setting a static client id in 4 has the effect of removing the container id's from page elements that would normally occur in previous versions of e.g.

    "ctl100_myContainer_txtFirstName" becomes "txtFirstName" allowing easier access to elements client side.

    This is set in the <pages> section of the web.config : e.g.

    <pages enableEventValidation="false" clientIDMode="Static">

    My current work around is to explicity set the clientIDMode on page controls themselves rather than globally in the web.config. However, I feel this should be addressed in furture iterations of umbraco so that it can be said if fully supports .net 4.0

    Also logged on codeplex... with screenshot

    hope this helps anyone else who has been scratching the head for 2+ days! :)

    Search Tags (based upon what i was searching for) :

    clientIDMode, System.Reflection.TargetInvocationException, web.config, umbraco.uicontrols.PropertyPanel.Render, Input parameter 'controlId' cannot be an empty string, System.Web.UI.ScriptManager.RegisterExpandoAttribute, Document Types, Media Types


  • Pat O'Callaghan 34 posts 56 karma points
    Nov 08, 2010 @ 22:56
    Pat O'Callaghan

    Thanks for this response. I had the same problem today!

  • Matthew J Cowan 2 posts 22 karma points
    Jan 03, 2012 @ 01:40
    Matthew J Cowan

    Yep, and not fixed in 4.7.1 ...

    But, you can add a location tag at the end of the config file to keep the admin section working as designed.

      <location path="umbraco" allowOverride="true">
          <pages clientIDMode="AutoID" />

    At least this has worked for me.

Please Sign in or register to post replies

Write your reply to: