Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Carlos 338 posts 472 karma points
    Dec 06, 2010 @ 21:34
    Carlos
    0

    "Remove at" and "publish at" not working 4.5.2

    We are having an issue with the "Remove at" and the "Publish at" functionality.  The functionality works on our local computers, but no on our production servers. We have various patches and rules on our servers and we are not sure if this is an issue with certain permissions, patches or anything else that we may have that is stopping our production servers from using the Remove at and the Publish at options.

    Is there anything we need to look for on our production servers that may be blocking or causing this functionality from not working on our production servers.

    Manual publishing and unpublishing seems to be working fine, but the auto publishing and unpublishing are not working at all.

    Please advise. We have inquiried about this once before.  Is there a solution?

  • Sascha Wolter 615 posts 1101 karma points
    Dec 07, 2010 @ 00:40
    Sascha Wolter
    0

    Hi Carlos,

    I had the same issue not long ago, the problem was really simple in that case: the server time wasn't correct, it was 15 minutes in advance. Don't know if that is your problem here as well but worth checking out.

    Sascha

  • Sebastiaan Janssen 4993 posts 15138 karma points MVP admin hq
    Dec 07, 2010 @ 12:14
    Sebastiaan Janssen
    0

    Doesn't seem to work for me on localhost either.. haven't tried on remote server. No errors in the log and no publish attempt for this node at the "Publish at" time.

  • Carlos 338 posts 472 karma points
    Dec 07, 2010 @ 17:09
    Carlos
    0

    I got it to work on localhost.  Umbraco, from my understanding, is set to refresh in 10 minute intervals. I had to wait a bit to get it to work on localhost.  
    Our live server has the issue. We have published sites to other host companies and have not and much of an issue. BUT our in-house servers are having issue with this. Everything else is working just fine. Like I said before, manual publishing and unpublishing are working fine, but the auto-unpublish/"Remove at" are not working at all.  This is why we are wondering if this is an issue with the way our server is set up. Are there permissions that need to be set?  Are there patches for the server that may stop this functionality from working? 

    There is not much on this forum at the moment for fixes, or settings that need for features of Umbraco to work. We will keep digging, if anyone else finds something, please post it ASAP. 

    Thanks,

  • RuneO 36 posts 116 karma points
    Dec 09, 2010 @ 13:09
    RuneO
    0

    Hmm, an editor at a client of ours has a couple of times complained about the exact problem you all mention. Each time I've logged into the backend and tested the remote at/publish at function myself. Then I've found that the functionality works as it should, and done nothing more about it.

    But maybe it's not a problem that occurs everytime you use it - only periodically or in certain conditions.

    The Umbraco site is a v4.5.2. As I recall it they've changed the date picker in this version. In this version you choose both date and time - didn't you just choose the date in older versions? If this is correct, has anyone tested trying to insert dates in the old format and see if it works?

    /Rune

  • RuneO 36 posts 116 karma points
    Jan 18, 2016 @ 16:08
    RuneO
    0

    Just found that I never got to close this thread 5 years ago. In case anyone finds this old thread, here's how we ended up solving the issue.

    The issue turned out to be race condition related. On the production servers the solution was set up as several different IIS websites pointing to the same Umbraco database. When using "Remove at" or "Publish at" you couldn't predict which site picked up the event - and distributed calls wasn't setup correctly.

    /Rune

Please Sign in or register to post replies

Write your reply to:

Draft