Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • patrick iversen 15 posts 40 karma points
    Jan 07, 2011 @ 14:51
    patrick iversen

    Missing Lucene.Net assembly

    Hi there,

    I have a umbraco 4.5 with .net 3.5 and recently upgraded the server to .net 4, and the site worked great until now. The site is very slow to load and then finally stops, displaying the 503 error and has stopped the application pool. If I restart the application it starts again but the outcome is the same.  If I check the event log in IIS 7 the only entry is "Message: Unable to find assembly 'Lucene.Net, Version=, Culture=neutral, PublicKeyToken=null'.  I've checked the installation and the dll is present along with the correct version, and the site ran fine until this error came along.  Has anyone experienced this behavior before and maybe fixed it in some way? 

  • Ismail Mayat 4511 posts 10062 karma points MVP 2x admin c-trib
    Jan 07, 2011 @ 17:01
    Ismail Mayat

    Patrick can you double check your permissions.



  • patrick iversen 15 posts 40 karma points
    Jan 10, 2011 @ 10:16
    patrick iversen

    Hi Ismail,

    Permissions seems to be set. Network service has r/w to all the folders and files Umbraco requires.

  • Jan Skovgaard 11264 posts 23592 karma points MVP 9x admin c-trib
    Jan 10, 2011 @ 10:31
    Jan Skovgaard

    Hi Patrick

    What happens if you set the "modfiy" permission as well?


  • patrick iversen 15 posts 40 karma points
    Jan 10, 2011 @ 10:41
    patrick iversen

    Hi Jan,

    Jep modify and execute and everything but "special permissions".

  • Claus Witt 1 post 21 karma points
    Jan 14, 2011 @ 15:17
    Claus Witt


    Just saw a link to this issue from ... 

    It reminds me of an error in an old .net application I used to develop and maintain. Application pools - back then - would fail when having applications/libraries compiled with different versions of the .net framework. This sounds to me to be the same issue - but since I have not worked professionally with .net solutions in a couple of years now, I am not sure. But it might be something to look into. 


  • patrick iversen 15 posts 40 karma points
    Jan 14, 2011 @ 15:59
    patrick iversen

    Hey guys, thanks for the solutions. Due to time constraint I ended up doing a reinstall with .net 4 version of umbraco and copied the files I needed, and now it's back up and running. Sure was a weird issue,  but probably had to do with compiled version, that broke when the server got .net 4 and still used the .net 2 pool setting.  I've used the same umbraco installation for a lot of other sites with the same configuration and have never had any issues like this before.

    Anyway, thanks for the many suggestions :).


  • Greg Berlin 818 posts 634 karma points
    Sep 18, 2011 @ 06:11
    Greg Berlin

    Same issue here.. works perfectly on my local dev box, but on the server it keeps crashing the app pool.

    Has anybody resolved this issue?  It's happening on a 4.7.0 umbraco site running on windows 2008 iis 7 (integrated and classic mode).

    very frustrating :|

  • Scott 69 posts 146 karma points
    Mar 14, 2012 @ 19:37

    Did anyone ever come up with a resolution for this? I am have the exact same error on 1 of about 10 umbraco 4.7 sites that I have. Its very slow to load, often failing because the app pool stops. And in my application event log I see the same 2 errors over and over:

    An unhandled exception occurred and the process was terminated.
    Application ID: DefaultDomain
    Process ID: 9024
    Exception: System.Runtime.Serialization.SerializationException
    Message: Unable to find assembly 'Lucene.Net, Version=, Culture=neutral, PublicKeyToken=null'.
    and then
    Application: w3wp.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: Lucene.Net.Index.MergePolicy+MergeException

  • Scott 69 posts 146 karma points
    Mar 14, 2012 @ 20:28

    I ended up resolving my own problem.

    I removed App_Data/temp/ExamineIndexes and it rebuilt it and my problem was resolved.

  • Jon Dunfee 199 posts 468 karma points
    Jun 12, 2012 @ 20:13
    Jon Dunfee

    Just went through a migration from one location to another.  I removed the contents of App_Data/TEMP/ExamineIndexes and after a minute or so of watching the browser spinner (while the Lucene cache was being rebuilt) the site came up.

  • Carsten Johannesen 35 posts 55 karma points
    Jun 19, 2012 @ 15:03
    Carsten Johannesen

    Had the same problem and ended up resolving the issue by removing just one of my five indexes from app_Data/ExamineIndexes (or rather renaming it to xxxx.old). (after having read among others Scooters reply above)

    This enabled the IIS to restart the site without errors. And the index is just rebuilding.

    Maybe the Lucene/Examine code needs to be able to fail more gracefully instead of taking the entire site with it...?? That would be nice :-(

  • changlinn 16 posts 25 karma points
    Nov 10, 2012 @ 00:25

    Thanks scooter, was out of ideas found your post on deleting App_Data/temp/ExamineIndexes and it fixed it.

  • Scott 69 posts 146 karma points
    Jun 04, 2015 @ 17:51

    I have to laugh at this. Three years later. Same web site. Same error. Google search brought me here. And my own fix worked for me again. I probably documented it somewhere the first time but its been so long ago I couldn't find it.

  • Herman van der Blom 10 posts 83 karma points
    Apr 26, 2017 @ 15:50
    Herman van der Blom

    Thats what you get when working with Open Source. The top of the Iceberg is free, the rest? Well what rest, we find that out later :-)

Please Sign in or register to post replies

Write your reply to: