Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Samuel Hamer 44 posts 66 karma points
    Jan 19, 2011 @ 17:33
    Samuel Hamer
    0

    Pasting from word (tinymce3) not working correctly in version 4.6.1

    Hello, first time poster.

    Is anyone else having problems with the latest build when it comes to pasting content from word?

    The paste from word form opens and allows me to copy (or type) into it but when I ask it to post it returns to the RT box without taking any content in.  Firebug didnt find any JS errors and doing the same with different browsers (and through desperation O.S') seems to have no affect.  As a last resort I created two new vanila builds, one with the 'basic' starter kit and one with no starter kit, both are on different locations (one on a server, one on my local machine) and both have exactly the same problem.

    Most odd... any ideas?

  • Jan Skovgaard 11230 posts 23313 karma points MVP 6x admin c-trib
    Jan 19, 2011 @ 21:55
    Jan Skovgaard
    0

    Hi Samuel

    I have never really experienced the paste from word functionality to be working stable in any version. Don't know if it has been working properly with 4.5 release since I tend to copy content into notepad (both from word or the web etc.) and then into Umbraco or whatever CMS I'm working with. (I have tried on a couple of other CMS'es that provided this functionality as well that did not work stable either). Therefore I'm using this approach.

    I know that it does not directly answer your question but I hope it can be used as a workaround.

    /Jan

  • Doug Mackay 56 posts 155 karma points
    Jan 19, 2011 @ 23:17
    Doug Mackay
    4

    Seems to be bug in the paste plugin in 4.6.1

    Edit 'umbraco_client\tinymce3\plugins\paste\editor_plugin_src.js' change line 319

    var umbracoAllowedStyles = this.editor.getParam('theme_umbraco_styles');

    to

    var umbracoAllowedStyles = ed.getParam('theme_umbraco_styles');

    Edit: Looks like this has been fixed in Change Set 232536a1e45c on codeplex.

  • Samuel Hamer 44 posts 66 karma points
    Jan 19, 2011 @ 23:59
    Samuel Hamer
    0

    Thank you both, that did work Doug.  Suprised that didn't flag an error to be caught by firebug.  All gravy now though.

  • Doug Mackay 56 posts 155 karma points
    Jan 20, 2011 @ 00:18
    Doug Mackay
    0

    It got flagged for me as an error for me in firebug. Think it was listed as 'this.editor is not defined' in the firebug console.

  • Dan Diplo 1457 posts 5606 karma points MVP 3x c-trib
    Jan 21, 2011 @ 15:19
    Dan Diplo
    0

    Thank you, Doug, you just saved my bacon!

  • Jennifer Killingsworth 189 posts 245 karma points
    Feb 15, 2011 @ 19:34
    Jennifer Killingsworth
    0

    I'm having the same problem, but when I tried this solution it didn't resolve the problem.

    I edited the web.config as well as recycling the application pool ... no dice.

    .......

    Ok, now it mysteriously started working.

     

     

  • Dan Diplo 1457 posts 5606 karma points MVP 3x c-trib
    Feb 16, 2011 @ 13:25
    Dan Diplo
    0

    Jennifer, the javascript gets cached by your browser, so changes don't always take place until your browser cache is refreshed. Same happened to me until I forced a refresh.

  • Greg Berlin 818 posts 633 karma points
    Feb 19, 2011 @ 08:36
    Greg Berlin
    0

    Thanks Doug, that fixed it for me... both pasting into the word popup, and into the RTE itself :)

  • Rich Green 2245 posts 3893 karma points
    Feb 28, 2011 @ 18:43
    Rich Green
    0

    Thanks, sorted this for me too, hope this gets into 4.7

  • Doug Mackay 56 posts 155 karma points
    Feb 28, 2011 @ 19:18
    Doug Mackay
    0

    It's been fixed on codeplex so it will be included in 4.7

  • Stig Kulvedrøsten 48 posts 69 karma points
    Jan 10, 2012 @ 14:46
    Stig Kulvedrøsten
    0

    I'm having the same problem on a 4.5.2 installation but can't find the 'var umbracoAllowedStyles =this.editor.getParam('theme_umbraco_styles');'

    Any suggestions?

    Stig

  • Sumesh KP 24 posts 93 karma points
    Mar 21, 2016 @ 03:14
    Sumesh KP
    0

    Thanks Doug, This is work for me.

Please Sign in or register to post replies

Write your reply to:

Draft