Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Jesper Hauge 298 posts 486 karma points c-trib
    Oct 24, 2011 @ 09:59
    Jesper Hauge
    0

    Dictionary item saved on every keypress

    We have an Umbraco 4.7.1 installation where the Umbraco backend saves every dictionary item on every keypress. It looks like every keypress triggers the jquery/javascript code near the bottom of /umbraco/settings/editDictionaryItem.aspx

    <script type="text/javascript">

    jQuery(document).ready(function () {
    UmbClientMgr.appActions().bindSaveShortCut();
    });
    </script>


    <script type="text/javascript">
    //<![CDATA[
    UmbClientMgr.mainTree().setActiveTreeType('dictionary');UmbClientMgr.mainTree().syncTree('78', false);jQuery(document).ready(function() {jQuery(window).load(function(){ resizePanel('body_Panel1', true,true); }) });//]]>
    </script>

    Both the bindSaveShortCut() and the line starting with UmbClientMgr, runs on every keystroke, and somewhere along the way in the javascript code coming from the DependencyHandler the dictionary item is saved and the bubble message is displayed, ignoring the keystroke in the textbox on the way. The save takes place because the javascript posts the editdictionaryitem.aspx form. But oddly enough it is not performed by the __doPostBack() function coming from the asp.net code generating the form.

    We see this in the latest versions of IE, Firefox and Chrome, so it's not a browser specifik issue. 

    Weve tried nuking the /umbraco and /umbraco_client folders and bin folders, then copying from a fresh download  and restarting the site in IIS, but no dice.

    Also we've tried downloading a copy of the site to a local machine and running it from there, but the problem only exists on the production server.

    Any ideas

    Regards
    Jesper Hauge

  • Jesper Hauge 298 posts 486 karma points c-trib
    Oct 28, 2011 @ 12:51
    Jesper Hauge
    1

    We finally solved this problem ourselves. Here's what happened, and what we had to do to solve the problem:

    We did an upgrade on the site from to the latest version of Umbraco by copying over new versions of /umbraco /umbraco_client and /bin folders, and started using the site. What we didn't do was clean out the temp folders below /App_Data/temp. One of the folders below this folder contains the cached versions of the scripts the Client Dependency framework pushes out. When we deleted these folders everyting started working again.

    My guess is that some changes has been made to some of the javascript and html output and that the upgrade caused our installation to start sending out upgraded html, but the old cached versions of the javascript, and that this situation caused the problems we were seeing.

    .Jesper

  • Jose Blanco 12 posts 32 karma points
    Jun 07, 2012 @ 17:38
    Jose Blanco
    0

    Good day, 

    I have a similar problem. 

    I am getting the following error: 

    UmbClientMgr.appActions().bindSaveShortCut is not a function
     
     
    UmbClientMgr.appActions().bindSaveShortCut();
    I deleted the the temp but does not work. Did you do something else?
    My problemn is with the div resize, when I try to open a macro, xslt or a stylesheet.
  • Wouter 49 posts 76 karma points
    Jul 13, 2012 @ 14:00
    Wouter
    0

    I cleaned up all the temp files but this does not help. Whenever I try to change for example the Alias of one of my Document Types the page reloads en tell's me it's saved...

Please Sign in or register to post replies

Write your reply to:

Draft