Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Aristotelis Pitaridis 82 posts 400 karma points
    Jun 06, 2015 @ 13:17
    Aristotelis Pitaridis
    0

    Nodes disappear from the site

    I have a major problem with an Umbraco site and I do not know if I do something wrong or if there is a problem with the Umbraco installation. For some reason some of the nodes that I have created in the site disappear after certain things that I do. The first time that this happened was when I tried to delete a Document Type property that I did not use in my site. I had a backup of the site and I restored it and I tried it again and the same thing happened so I restored the project again and I decided to leave the property there. I could live with this unused property. I started adding articles again and one of the times that I tried to save an article, I had an internet disconnection and when the internet came back the nodes had disappeared again. In all cases the nodes from a specific date or later disappear. My database was SQL CE so I tried to convert the database to SQL server so the site worked as it was supposed to work and I tried to delete the property so that I will find out if the problem was because of SQL CE but again the articles after the same date disappeared from the site.

    Some information about the site which may help someone to understand what the problem is are listed below:

    • The site is localized with two languages and the urls have format /en/technology/category/article.
    • In order to have an article with different types of information the contents of the article are child nodes which contain information like code, text, picture and when I want to display an article I read all the child nodes and display the result on the screen.
    • I have a class which extends the ApplicationEventHandler so that when an information like text, code, image added or changed I use the Published event so that I will add the information in a custom field of the article so that I will be able to implement the search. This was required because the actual information was not in the article but in a child node. I removed the class but the problem remains.

    My last attempt was to upgrade using nugget the project and have an earlier version. I upgraded version 7.2.5 to 7.2.6. Everything was supposed to be ok because a successful message appeared on the screen about the upgrade but again I noticed that the same nodes have been removed from the site after the upgrade.

    I would appreciate any help about my problem.

    Thanks in advance,

    Aristotelis

Please Sign in or register to post replies

Write your reply to:

Draft