Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Fengelz 106 posts 221 karma points
    Jun 14, 2010 @ 16:00
    Fengelz
    0

    No macro content available for WYSIWYG editing.

    Hi

    I think some of us has experienced what could be a possible bug in the newest build.

    When inserting a macro in the Rich Text Editor, a "No macro content available for WYSIWYG editing" is displayed, but the macro renders fine on the homepage after save and publish.

    It appears to work fine in all our solutions running umbraco 4.0.3 but not the one we upgraded to 4.0.4.

    More info is found here: http://our.umbraco.org/forum/using/ui-questions/9787-Macro-wont-render-in-RTE

     

    best regards

    - Sune

  • Stephen 767 posts 2266 karma points c-trib
    Jul 06, 2010 @ 16:22
    Stephen
    1

    There is a bug in macro.cs, method MacroContentByHttp, still in 4.5.

    The macro rendering is done by invoking an ASPX page through an HttpWebRequest, on the current server, then parsing the result.
    Why it can't be rendered directly is beyond my comprehension at the moment.

    Anyway, the ASPX page (macroResultWrapper) inherits from UmbracoEnsuredPage so it wants credentials, which are missing.

    Patch: (around line 1467)

    HttpWebRequest myHttpWebRequest = (HttpWebRequest)WebRequest.Create(url);
    HttpCookie inCookie = HttpContext.Current.Request.Cookies["UserContext"];
    string domain = HttpContext.Current.Request.ServerVariables["SERVER_ NAME"];
    Cookie cookie = new Cookie(inCookie.Name, inCookie.Value, inCookie.Path, domain);
    myHttpWebRequest.CookieContainer = new CookieContainer();
    myHttpWebRequest.CookieContainer.Add(cookie);
    // Assign the .....

    It works, should be submitted as a patch, but I don't have time at the moment.

    Stephen

  • Stephen 767 posts 2266 karma points c-trib
    Jul 06, 2010 @ 16:28
    Stephen
    0

    uploaded patch no 6267 in codeplex... hopefully it will be merged in the next release...

  • Åke Järvklo 23 posts 69 karma points
    Aug 10, 2010 @ 11:19
    Åke Järvklo
    0

    Any news on the progress of this issue, and how the evaluation of the submitted patch is going?

  • Niels Hartvig 1951 posts 2390 karma points admin hq c-trib
    Aug 11, 2010 @ 09:38
    Niels Hartvig
    1

    I'll take a look for 4.5.2 - this one slipped under my radar :-O

  • Fredrik Esseen 590 posts 806 karma points
    Sep 01, 2010 @ 14:06
    Fredrik Esseen
    0

    Im running 4.5.2 and this bug is still there. Or am I wrong?

  • Lefteris 89 posts 42 karma points
    Sep 01, 2010 @ 15:32
    Lefteris
    0

    OMG this bug is still there - 4.5.2

  • trfletch 595 posts 571 karma points
    Sep 20, 2010 @ 13:11
    trfletch
    0

    Hi,

    I too have this problem, I have downloaded the patch but I am not sure how I use it. Where do I put the macro.cs file to resolve the issue?

  • Tom Fulton 2030 posts 4990 karma points c-trib
    Sep 21, 2010 @ 17:21
    Tom Fulton
    1

    Not sure but I think you would have to recompile the Umbraco source with the file to use it...

    Hope this gets fixed soon :)

  • trfletch 595 posts 571 karma points
    Sep 27, 2010 @ 17:33
    trfletch
    0

    Thanks Tom, I did indeed have to find the source code and recompile it to fix the problem.

  • Åke Järvklo 23 posts 69 karma points
    Sep 28, 2010 @ 09:35
    Åke Järvklo
    0

    Niels - how is your evaluation going? Is there a chance to get this fixed in production code for the next release ?

  • Niels Hartvig 1951 posts 2390 karma points admin hq c-trib
    Sep 28, 2010 @ 09:41
    Niels Hartvig
    0

    Thanks for the heads up - I'll add it for 4.6 alpha today!

  • Shannon Deminick 1504 posts 5153 karma points hq
    Oct 20, 2010 @ 13:50
    Shannon Deminick
    0

     I will look at applying this right now! :)

  • Shannon Deminick 1504 posts 5153 karma points hq
    Oct 20, 2010 @ 14:15
    Shannon Deminick
    0

    Yup, Niels beat me to it... its fixed now :)

  • Fredrik Esseen 590 posts 806 karma points
    Nov 17, 2010 @ 09:06
    Fredrik Esseen
    0

    Do someone have a compiled version with this bug fixed?

  • MA 5 posts 25 karma points
    Nov 26, 2010 @ 12:15
    MA
    0

    Get this error in v.4.5.2 (contact form within the Runway module)

  • Jon Dunfee 199 posts 468 karma points
    Jan 30, 2011 @ 07:33
    Jon Dunfee
    0

    I made the change uploaded the compiled files. I made a change to the web.config hoping it would restart the app and load the new files.  It's not happening for me.  What can I do to get this working?  I have to use 4.5.2 until 4.6 is offered in dotnet 3.5 [or my host provides 4.0 which is not likely anytime soon].

  • Jon Dunfee 199 posts 468 karma points
    Jan 31, 2011 @ 06:25
    Jon Dunfee
    0

    Uh oh!  I think the server finally refreshed and accepted the change and it didn't like it.  My macro is producing the following error when I insert in the editor:

    Server Error in '/' Application.
    The parameter '{0}' cannot be an empty string.
    Parameter name: cookie.Domain
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.ArgumentException: The parameter '{0}' cannot be an empty string.
    Parameter name: cookie.Domain

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [ArgumentException: The parameter '{0}' cannot be an empty string.
    Parameter name: cookie.Domain]
    System.Net.CookieContainer.Add(Cookie cookie) +1569788
    umbraco.macro.MacroContentByHttp(Int32 PageID, Guid PageVersion, Hashtable attributes) +1842
    umbraco.presentation.tinymce3.insertMacro.renderMacro_Click(Object sender, EventArgs e) +1652
    umbraco.presentation.tinymce3.insertMacro.Page_Load(Object sender, EventArgs e) +1213
    System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +14
    System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +35
    System.Web.UI.Control.OnLoad(EventArgs e) +99
    umbraco.BasePages.BasePage.OnLoad(EventArgs e) +49
    System.Web.UI.Control.LoadRecursive() +50
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +627


    Version Information: Microsoft .NET Framework Version:2.0.50727.3615; ASP.NET Version:2.0.50727.3618

  • Jon Dunfee 199 posts 468 karma points
    Jan 31, 2011 @ 06:37
    Jon Dunfee
    0

    Good grief. Why didn't I see that before. Don't do an exact copy/paste of above's code without looking it over first.  Do you see something wrong with this line?

    string domain = HttpContext.Current.Request.ServerVariables["SERVER_ NAME"]; 

    I made the following correction and in the process of uploading now:

     string domain = HttpContext.Current.Request.ServerVariables["SERVER_NAME"];

     

  • Kims 25 posts 34 karma points
    Feb 01, 2011 @ 04:52
    Kims
    0

    Hi,

    I upgraded from Umbraco 3.6 to 4.0.4 and I got the same error. The flag is ticked to show Render in Editor.

    I was then told by someone to upgrade to at least 4.5.2 which I did and I'm still having the same problem.

    How did you fix this? Did you have to upgrade to 4.6? Is there a patch which can be applied to 4.5.2? I don't want to have to go there just for this as I'm trying to deploy it on 4.5.2.

    Cheers

    Kim

  • Jon Dunfee 199 posts 468 karma points
    Feb 01, 2011 @ 06:42
    Jon Dunfee
    1

    1) Download the source code for current version of 4.5.2: http://umbraco.codeplex.com/SourceControl/changeset/view/ffc34b23e1a0 (Download button is upper right, green)

    2) Extract and open the solution in Visual Studio. (I opened it in VS 2010)  It may cause VS to hang for a few while it attempts to connect to TFS after it fails just hit ok to continue - we don't want to connect anyway.

    3) Once the solution is open, locate macro.cs in the umbraco.presentation project and make the change as stated in the earlier post.  Be sure to make the correction to the fix by removing that space in the "SERVER_NAME"

    4) Right click on umbraco.presentation and publish site to some location on your hard drive.  At a minimum you should be able to locate the umbraco.dll in the bin and replace yours - that should be it.

    5) Make a change to your web.config (Add a space or something just to cause the last modified date of your file to change) for a quick refresh and it should take.

    If you need further help you can do a google search on my name and find me pretty easily. :-)

  • Kims 25 posts 34 karma points
    Feb 02, 2011 @ 05:48
    Kims
    0

    Hi Jon

    Wow thanks for all the info.You are so kind!

    Does the same thing apply to 4.0.4? I'm thinking of rolling back to that because my Doc2Forms stopped working in 4.5.2.

    Appreciate your help!

    Cheers

    Kim

  • Profiterole 232 posts 264 karma points
    Feb 27, 2011 @ 20:45
    Profiterole
    0

    Hi, I have the same problem, but I don't have Visual studio to fix it. Is there a way to download the umbraco.dll file with the patch in it? For 4.5.2.

  • Kims 25 posts 34 karma points
    Feb 28, 2011 @ 00:04
    Kims
    0

    I've asked Umbraco Support and they are saying that you need to upgrade to 4.6 for the bug to be fixed.

    So I'm living with it until I get a chance to upgrade again. You can upgrade directly from 4.5.2 but for me it would be two more :(

    I tried the visual studio option but there were already too many errors in the package, even before i made those changes which are not completely accurate I found.

     

  • Jon Dunfee 199 posts 468 karma points
    Feb 28, 2011 @ 05:27
    Jon Dunfee
    0

    Find me and I'll send it to you, one file to replace.

  • Profiterole 232 posts 264 karma points
    Mar 01, 2011 @ 14:19
    Profiterole
    0

    Jon, I emailed you.

  • Jon Dunfee 199 posts 468 karma points
    Mar 01, 2011 @ 14:44
    Jon Dunfee
    1

    Check your inbox. :-)

  • Gary Hayes 4 posts 24 karma points
    May 27, 2011 @ 09:45
    Gary Hayes
    0

    Hello there,

    Is this issue fixed in 4.7? I have installed a clean 4.7 (on Azure).

    I have tried with both a Razor and an Xslt Macro containing nothing but the word "test" (and I did check Render content in editor).

    I still recieve the "No macro content available for WYSIWYG editing" message 

  • Åke Järvklo 23 posts 69 karma points
    May 27, 2011 @ 10:41
    Åke Järvklo
    0

    It is fixed, but not entirely stable...

    Some days I get "no content available" like you - others I see the content just fine while editing.

    I'm still trying to figure out if there's a method to the intermittent madness somewhere, or if it is just me (but your comment suggests that it might be worthwhile to keep observing this)...

    Oh - and I run a 4.7 in full trust on shared hosting (i.e. virtualized at my web host)

     

  • Gary Hayes 4 posts 24 karma points
    May 27, 2011 @ 10:51
    Gary Hayes
    0

    Very strange, I guess that means lots of extra templates instead.. sigh

  • Chris Koiak 700 posts 2626 karma points
    Nov 24, 2011 @ 18:36
    Chris Koiak
    0

    I had the same problem and thought I'd share the solution in case it helps.

    In my local environment the macros were rendering correctly, push it up to the server and not macros would render in the editor.

    The staging environment did not have anonymous access enabled for the website (it was behind an AD login). Switching on Anonymous Access in IIS solved the problem for me.

  • Jon Dunfee 199 posts 468 karma points
    May 14, 2012 @ 23:05
    Jon Dunfee
    0

    It would appear this issue has cropped back up in 4.7.2 for me.  Macros have stopped rendering. :-(

  • Niels Hartvig 1951 posts 2390 karma points admin hq c-trib
    May 15, 2012 @ 07:56
    Niels Hartvig
    0

    Hi Jon!

    Any chance you can provide steps to reproduce?

  • Jon Dunfee 199 posts 468 karma points
    May 15, 2012 @ 09:15
    Jon Dunfee
    0

    I apologize for not providing more details; I got busy and looked for a delete post option till I could get back to it.

    I'm using stripped 2008 R2 Standard; for features, I have App Server & IIS with dotnet 4 installed.  I set the permissions to (M) for IIS_IURS on the webroot.  Using 4.7.2 with CE db.  Everything has been pretty smooth except the macro rendering.  The previous fix earlier in the thread is in the macro.cs, so I know that wasn't lost in the version.

  • Jonny Irwin 91 posts 153 karma points
    May 18, 2012 @ 14:30
    Jonny Irwin
    0

    Macro rendering isn't workng for me either in 4.7.2.  I created a new cshtml file like so:

    <h1>Test</h1>
    <h2>@DateTime.Now</h2>

    I creaetd a macro, assigned it to my cshtml file, checked "Use in Editor" and "Render content in editor".  I then added this macro to a RTE on a content page.  I get the standard:

    Test
    No macro content available for WYSIWYG editing

    I'm using SQL Server 2008R2, Windows Server 2008R2

  • Jon Dunfee 199 posts 468 karma points
    May 24, 2012 @ 17:17
    Jon Dunfee
    0

    Just wanted to add, Contour forms produce the same message.

    I have reason to believe it's no doubt a permissions issue.  What would someone suggest I set on the directory(s), now? Or, IIS instance?

  • Jon Dunfee 199 posts 468 karma points
    May 27, 2012 @ 06:52
    Jon Dunfee
    0

    I spent many hours trying different things and I simply can't get it to "kick in" and start working.  To try something I had the app pool run a local admin account, site was using the local admin for physical credentials and made sure the local admin account had full control of the webroot (I double checked child permissions by applying to all folders & items, etc...), and I even turned off UAC.  NO GO!  I put everything back to normal with the app pool running ApplicationPoolIdentity and IIS instance back to pass-through authentication on physical.  I left UAC off for now.  I set full control to the inetpub directly this time for iis_iusrs and still nothing.

    So I'm not going completely nuts, I zipped up the whole directory and setup a local iis instance on my laptop and it runs fine.  Ok, so I remote into the webserver and run the site localhost and it works fine.  Arrrrrgh!!  Anyone have an idea what settings, permissions I need to set to get macros to render when accessing the site via the web??  The server is a plain Jane 2008R2 with basic IIS features.  I did attempt to get WebMatrix publishing but failed at that as well; just letting you know all the necessary features were installed for it in addition to IIS.  (I believe my issue is firewall related - didn't spend time on that since I need Umbraco to work right before WebMatrix).

Please Sign in or register to post replies

Write your reply to:

Draft