Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Michael 125 posts 409 karma points
    Nov 01, 2016 @ 10:20
    Michael
    0

    Umbraco open page instead of 404.

    Hi all,

    My problem is:

    I have page terms: sitename.com/terms which has doctype terms and template terms.cshtml

    I also have hostname sitename.com/de, but I don't have page terms like sitename.com/de/terms. I would like to receive 404 page on this page for de region but I can browse terms page.

    Why I get this?

    Thanks, Mike

  • Alex Skrypnyk 6060 posts 23282 karma points MVP 6x admin c-trib
    Nov 01, 2016 @ 10:28
    Alex Skrypnyk
    0

    Hi Michael,

    Is sitename.com another language?

  • Michael 125 posts 409 karma points
    Nov 01, 2016 @ 10:34
    Michael
    0

    Yes, sitename.com is en-GB, sitename.com/de has de-DE

  • Dennis Adolfi 1075 posts 6433 karma points MVP 4x c-trib
    Nov 01, 2016 @ 10:42
    Dennis Adolfi
    0

    Hi Michael.

    We had a similar issue like this a while back, and from what i remembered, the solution was to Sort your root websites so that the /de site comes before the / site in the root site structure.

    Try it, maybe works for you too. :)

  • Michael 125 posts 409 karma points
    Nov 01, 2016 @ 10:47
    Michael
    0

    Hi Dennis,

    Not works for me. Also not works for new and clean instance.

    Thanks, Mike

  • Dennis Adolfi 1075 posts 6433 karma points MVP 4x c-trib
    Nov 01, 2016 @ 10:51
    Dennis Adolfi
    0

    Ah, to bad. :( Sounded a lot like the same issue. Hope it works out for you!

  • Michael 125 posts 409 karma points
    Nov 01, 2016 @ 10:43
    Michael
    0

    Hi Alex,

    I've tried to reproduce this with clean Umbraco.

    1. fresh install.

    2. create doctype terms with template terms

    3. create de site and assign hostname localhost:32113/de with de-DE language

    4. http://prntscr.com/d1mbjy

    if I set Umbraco.ModelsBuilder.Enable to false I receive: http://prntscr.com/d1mc1r

    Thanks, Mike

Please Sign in or register to post replies

Write your reply to:

Draft