Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Luke Geddes 5 posts 105 karma points
    Aug 23, 2017 @ 16:22
    Luke Geddes
    0

    The images in my site have stopped displaying for those that are set using the Media picker property. These has been working, and no direct code was changed involving the part of the site that was using the images.

    The problem is happening for image properties set on the document, and on macro properties. In both instances, from debugging locally, I can get the IPublishedContent object for media item and the Media object, however the URL property is empty (all other properties are set, such as name, id etc).

    I have tried using both the MediaService, UmbracoHelper, and the strongly typed property from of the document that the property is on, and each time the URL is empty.

    enter image description here

    Does anyone have any ideas on what might have caused this?

  • Ismail Mayat 4332 posts 9337 karma points MVP 2x admin c-trib
    Aug 24, 2017 @ 11:07
    Ismail Mayat
    0

    Luke,

    what version of umbraco are you using? I have seen this before and rebuilding external and internal indexes fixes the problem.

  • Luke Geddes 5 posts 105 karma points
    Aug 24, 2017 @ 11:39
    Luke Geddes
    0

    Hi Ismail,

    We're on version 7.6.3. This might ocnfuse matters but it was occurring on 7.6.1, and we upgraded to 7.6.3 to try and fix this. It was temporarily working after the upgrade when adding new images in, but has since stopped again.

    We have tried rebuilding the indexes, but again, the issue still persists.

  • Edgar Rasquin 114 posts 342 karma points
    Aug 05, 2019 @ 07:13
    Edgar Rasquin
    0

    Hi Luke,

    I am strugling with exactly the same problem. Did you find out in the end what caused the problem and did you manage to fix it?

    Thanks

Please Sign in or register to post replies

Write your reply to:

Draft