Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Ilya Golets 2 posts 82 karma points
    Mar 07, 2018 @ 09:54
    Ilya Golets
    0

    Could not task for operation Create for node type xslt

    I've installed Umbraco version 7.8.1 from scratch.

    1. Open Developer section
    2. Click on "..." near XSLT files, get create XSLT fpom.
    3. Enter new name ("asd", but get same result with any name)
    4. Choose "Clean" snippet (reproduce with all other snippets in fact), uncheck "Create macro". Click "Create"
    5. Always get an error

    ======== >8 ===============

    Server Error in '/' Application.
    
    Could not task for operation Create for node type xslt 
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 
    
    Exception Details: System.InvalidOperationException: Could not task for operation Create for node type xslt
    
    Source Error: 
    
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. 
    
    Stack Trace: 
    
    
    [InvalidOperationException: Could not task for operation Create for node type xslt]
       Umbraco.Web.UI.LegacyDialogHandler.Create(HttpContextBase httpContext, User umbracoUser, String nodeType, Int32 nodeId, String text, Int32 typeId) +285
       umbraco.presentation.create.xslt.sbmt_Click(Object sender, EventArgs e) +391
       System.Web.UI.WebControls.Button.OnClick(EventArgs e) +11764877
       System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument) +150
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1665
    
    
    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.7.2558.0 
    

    ======== >8 ===============

    XSLT file not created on a disk, When I refresh Developer section, there will be no XSLT files. If I check "Create macro", I get same error and macro is not created.

    I can add XSLT file manually to XSLT folder on a disk, In this case I'll see XSLT in Developer section of Umbraco admin, can edit it, can save and can create macro. The problem is onmy with creating new file from admin UI.

  • Bruno Olsen 75 posts 316 karma points
    Mar 19, 2018 @ 11:32
    Bruno Olsen
    0

    I'm having the same problem with a fresh 7.9.2 install

  • Dave Woestenborghs 3504 posts 12133 karma points MVP 8x admin c-trib
    Apr 06, 2018 @ 06:18
    Dave Woestenborghs
    101

    Hi Guys,

    I created a PR to fix this issue. To solve this just look at the steps in the comments of this issue : http://issues.umbraco.org/issue/U4-11149

    Dae

Please Sign in or register to post replies

Write your reply to:

Draft