Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Jason Denousse 23 posts 92 karma points
    May 28, 2019 @ 08:49
    Jason Denousse
    0

    Remove sign in box when launching web page

    When the public access my created umbraco page, a sign in box appears. Obviously this is not needed for members of the public to view my site, so how do I remove this dialog?

  • Michaël Vanbrabandt 863 posts 3345 karma points c-trib
    May 28, 2019 @ 09:26
    Michaël Vanbrabandt
    0

    Hi Jason,

    did you set Public access on that node in the backend? So that it can only be accessed by a Member group and therefore need to be logged in?

    Can you show us some screenshots about the issue?

    Have a nice day!

    /Michaël

  • Jason Denousse 23 posts 92 karma points
    May 28, 2019 @ 09:35
    Jason Denousse
    0

    Thank you for responding Michael.

    When I right click and select 'Public Access' on a node, it asks to change from single user protection or to role based protection.

    When I select role based I then have the below option.

    I want all of my nodes accessible to the public. How do I set this up?

    roel based public access

  • Michaël Vanbrabandt 863 posts 3345 karma points c-trib
    May 28, 2019 @ 09:56
    Michaël Vanbrabandt
    0

    Hi Jason,

    It has nothing to do with Public Access I see now. What I can see is you have manu root nodes. Normally you have one root node called Home or Site and then you have child nodes.

    Refer to the following in the docs with a nice preview example of a well structured content tree:

    https://our.umbraco.com/documentation/Getting-Started/Backoffice/#tree

    What happens if you go to the Center Media Area page in your front end? Can you see that without problems?

    Hope this helps.

    /Michaël

  • Jason Denousse 23 posts 92 karma points
    May 28, 2019 @ 10:11
    Jason Denousse
    0

    Oh Ok i should create one overall node. It's because my website is created externally and i have used umbraco to generate some pages that are editable. The entire website is developed away from umbraco.

    I shall try that now

  • Jason Denousse 23 posts 92 karma points
    May 28, 2019 @ 10:45
    Jason Denousse
    0

    Now that I have moved everything under one 'Home' node, how do i remove the sign in box? This still appears when loading my content

  • Laura Weatherhead 25 posts 153 karma points MVP 3x c-trib
    May 28, 2019 @ 12:13
    Laura Weatherhead
    0

    Hey Jason!

    I'm just catching up with this thread :-)

    So, do you have any role-based permissions on your home node now? I take it that you want this page to be publicly available to anyone that visits the site?

    Thanks,

    Laura

  • Jason Denousse 23 posts 92 karma points
    May 28, 2019 @ 12:23
    Jason Denousse
    0

    Hi Laura

    No I haven't set up any role based permissions. Should I have?

    Yes that's exactly right, everything withing my home node I would like to be accessed. Some of the umbraco links are embedded content within my external website.

  • Laura Weatherhead 25 posts 153 karma points MVP 3x c-trib
    May 28, 2019 @ 12:29
    Laura Weatherhead
    0

    Okay great :-)

    Could you possibly post a wee screenshot of what the sign-in box looks like for you?

    It's possible that in your web.config you might have some auth config in place. Might just be worth checking your authorization node config resembles the below?

    <authorization>
          <allow users="*" />
    </authorization>
    

    Thanks,

    Laura

  • Jason Denousse 23 posts 92 karma points
    May 28, 2019 @ 12:32
    Jason Denousse
    0

    i'm using the cloud version 7 umbraco so don't think I have access to the web config.

    You can test this url https://rochester-21st.s1.umbraco.io/center-media-area/

    When going to this or any other url from umbraco on another device i get the below screenenter image description here

  • Laura Weatherhead 25 posts 153 karma points MVP 3x c-trib
    May 28, 2019 @ 12:51
    Laura Weatherhead
    0

    Hmm, that's interesting! But it does look like it might be a config issues.

    So in order to check you can access to the web.config a couple of ways:

    But then you should be able to check what's in the authorization and authentication web.config nodes :-)

    Cheers,

    Laura

  • Jason Denousse 23 posts 92 karma points
    May 28, 2019 @ 13:19
    Jason Denousse
    0

    Thanks for your help.

    Should it not already be a default setting that if no authorisation is set, then anyone with the url should be able to load the content?

    Where can I access the web config in kudu?

    Does it not defeat the purpose of web content?

  • Laura Weatherhead 25 posts 153 karma points MVP 3x c-trib
    May 28, 2019 @ 13:32
    Laura Weatherhead
    0

    Before we delve in Kudu (which is always fun) could you just check the Public Access settings on your cloud installation?

    Public Access Screenshot

    They have a little blurb there about why it might be on, and if it is on then please try toggling off and reloading the site in incognito mode/flushing the browser

    Cheers,

    Laura

  • Jason Denousse 23 posts 92 karma points
    May 28, 2019 @ 13:34
    Jason Denousse
    0

    Ah thanks Laura I've cracked it....I'm still in Trial mode, once I upgrade I can make accessible to public.

    Thank you for your help.

  • Laura Weatherhead 25 posts 153 karma points MVP 3x c-trib
    May 28, 2019 @ 13:37
    Laura Weatherhead
    0

    Wonderful :-) Glad you got to the bottom of it!

Please Sign in or register to post replies

Write your reply to:

Draft