Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Stuart Paterson 15 posts 125 karma points
    Jun 25, 2019 @ 09:33
    Stuart Paterson
    0

    Macro Partial Cache - clarify options

    Hi all,

    Hoping someone can help on an issue I'm seeing with caching options for macro's.

    I have tried to set a 'Cache Period' of 31 days (in seconds) and also selected 'Cache By Page' which yielded a strange result. Any macro's which had background images were no longer displaying the image? If I removed only the Cache Period value then the images return.

    My understanding is that if I had not checked the Cache By Page option and then first visited a page which used the same Macro (without a background) then this would have caused the backgrounds to be removed on subsequent pages using that macro but this wasn't the case.

    I'd like to get the caching working properly as I think this will help to reduce the list of items we're being advised to leverage browser caching on.

    v. 7.10.5

    Thanks Stuart

  • Stuart Paterson 15 posts 125 karma points
    Jul 10, 2019 @ 08:58
    Stuart Paterson
    0

    Hey folks,

    Unusual not to have heard from someone on this as the community is normally pretty responsive and keen to help/advise. Makes me think it's either coming across as a stupid question or nobody really knows/uses this?

    It's a genuine issue, the content on my macro's isn't being cached properly and it's affecting my overall site performance as the macro's are being re-used site wide. Unsure if it's a bug or not so don't want to waste anyone's time report it as one for now.

    Thanks Stuart

Please Sign in or register to post replies

Write your reply to:

Draft