Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • sd75 31 posts 144 karma points
    Mar 13, 2013 @ 12:23
    sd75
    1

    Help with error - The template with Id .... does not exist, the page cannot render

    Newbe here

    Getting the error 'The template with Id .... does not exist, the page cannot render' when viewing a published page in the remote dev site.

    When I preview the same page through umbraco backoffice it works fine.

    The page in question has an appropriate doc type & that doc type has the appropriate default template.

    (When creating the doc types I allowed the matching templates to be created but re-created nested templates in the templates tree)

    Any help much appreciated

     

    Cheers

  • Jeroen Breuer 4902 posts 12234 karma points MVP 3x admin c-trib
    Mar 13, 2013 @ 19:54
    Jeroen Breuer
    1

    What is the structure of your Umbraco backoffice? Maybe you have 2 nodes with the same url and one of those doesn't have a template. 

    Jeroen

  • Charles Afford 1163 posts 1709 karma points
    Mar 13, 2013 @ 21:53
    Charles Afford
    0

    Do you have the template in your masterpages folder in your dir?  Not just in the umbraco backoffice?

    Charlie :)

  • sd75 31 posts 144 karma points
    Mar 15, 2013 @ 10:13
    sd75
    0

    Content - Internal Communications has a doc type of 'Comms Portal Master' & template of 'Comms Portal Master'

    Content - Home Page has a doc type of 'Home Page' & template 'Home Page' 

    I've checked that the relevant templates are definately on the server at in wwwroot/masterpages (I de-selected the allowed template 'Home Page' from the Home Page doc type - deleted Home Page template then deleted the HomePage.master on the server and re-created them from scratch - get the same error except it's for a different template id this time!)

    The home page now throws the same error 'template with id 1163 does not exist....' (except for id 1163 & not 1153 originally) in preview mode now.

    What am I doing wrong?

    I've checked that there are no 2 nodes with the same url too.

    Do I need to delete the doc type & re-create it?

    Many Thanks

    sd

  • Charles Afford 1163 posts 1709 karma points
    Mar 16, 2013 @ 10:54
    Charles Afford
    0

    The problem is that it cannot find the template, so either you have not named the two templates correctly in Umbraco and your WWW root or there is a permissions issue that is not allowing that template to be rendered.  

    Does the node have any permissions on it?

    Do other templates work / other pages?

    Wont be anything to do with the document type i dont think you would get a diffrent error releating to the cms, rather than the site. :).  Charlie.

    What does your template look like as well, has it got the correct markup?

  • sd75 31 posts 144 karma points
    Mar 29, 2013 @ 12:50
    sd75
    1

    weirdly - when I re-published the page that should have been displayed - no error & page working fine!

  • Fabio Milheiro 74 posts 136 karma points
    Sep 03, 2014 @ 00:16
    Fabio Milheiro
    0

    I got this problem because I downloaded the database from live to my dev. Since new ids had been created in live that matched other items in my dev that had been created in the meantime (although the site structures were almost the same).

    I compared the file /App_Data/umbraco.config between dev and live and found out that they were very different - obviously - so I just copied that file from live to dev in order to match the data I had now in the dev database.

    Problem solved.

Please Sign in or register to post replies

Write your reply to:

Draft