Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Zakhar 171 posts 397 karma points
    May 02, 2013 @ 13:44

    Duplicated Template - can't edit and delete, how to fix it?

    Hey guys,

    Something went wrong with a package installation and I ended up with duplicated template.

    I can not edit or delete them now, getting these errors:

    Saving: "Template not saved
    Please make sure that you do not have 2 templates with the same alias"

    Deleting: "Error handling action
    Item has already been added. Key in dictionary: 'dampsample' Key being added: 'dampsample'"

    I saw similar question from 2009, but there is no sulution there. Reinstalling Umbraco is out of question.

    How can I fix that. There should be a way to edit it manually. I deleted duplicated entry form cmsTemplate table, but it doesn't help. I tried  deleting and renaming the file from masterpages folder, doesn't help at all.

    What can be done there?

    Thank you.



  • Chris Gaskell 59 posts 142 karma points
    May 02, 2013 @ 16:03
    Chris Gaskell

    There's a few tables you may want to take a look at, you'll have to poke around in the database. Back it up first!

    Here's my list to get you going, this was built as of version 4.9, there are some differences with V6. Hopefully it may help as you look round....


    -- Relates content nodeIds to contenttypeIds (doctypes) (So tells each content item to which doctype they belong) Since both Documents and DocumentTypes exist within umbracoNode, this table enables an association between them.

    -- Lists a version of each contentId and a versionId (guid) and the date it was created. On dev these can be cleared down.

    -- The table contains the value of every property of each version of each content node. The editors data is saved in one of dataint, dataDate, dataNVarchar or dataNText depending on the field editor type.

    -- Stores the heirarchy of DocumentTypes, MediaTypes, Documents and Templates

    -- Contains the configuration for the document tabs shown to the content editor

    -- Contains a DB reference to the on disk template/layout (also the contents of that template / view which isnt used at runtime)

    -- Defines the Templates that can be used for each DocumentType.

    -- A list of the content types (doctypes), their alias, icon and master doctype

    -- A 1 <-> 1 list of content type ids (doctypes). To determine what type can be created under which parent type

    -- Defines an Umbraco macro

    -- List of properties on macros

    -- For properties on macros this defnes the data type for the property

    -- Contains a list of properties for each ContentTypeId (doctype). Includes helptext, description, alias etc

    -- Contains a list of host headers and the link to the starting nodeId

    -- Contains the active language

    -- Contains the lists of datatypes

    -- Contains prevalues for the datatypes (i.e MNTP definition)


  • Zakhar 171 posts 397 karma points
    May 02, 2013 @ 17:01

    Thanks Chris, I went through the db again, but couldn't find any problems there. The only two tables which mention templates are [cmsTemplate] and [cmsDocumentType], and they look fine now, there are no duplicated keys or something.

    This is at least 4 years old issue and it's very frustrating to realise that it's not fixed yet and there is no known workaround for it. Can someone at least hint where I can look for that misterious dictionary? Please?

  • Scott Robinson 54 posts 75 karma points
    Jul 23, 2013 @ 18:01
    Scott Robinson

    Did this issue get solved. I have the same problem. I have an item that doesn't exist in my "views" folder in the template within umbraco. It chaims that there is a duplicate template but I can't find it.

Please Sign in or register to post replies

Write your reply to: