Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Henrik Ladefoged 30 posts 100 karma points
    Mar 25, 2014 @ 16:20
    Henrik Ladefoged
    0

    Umbraco v6.1.2: InvalidOperationException: Sequence contains more than one matching element

    I added a new property (true/false) to an exsisting doc type and then this error occured.

    [InvalidOperationException: Sequence contains more than one matching element]
       System.Linq.Enumerable.SingleOrDefault(IEnumerable`1 source, Func`2 predicate) +4473620
       umbraco.controls.ContentTypeControlNew.BindDataGenericProperties(Boolean refresh) +1275
       umbraco.controls.ContentTypeControlNew.OnInit(EventArgs e) +152
       System.Web.UI.Control.InitRecursive(Control namingContainer) +133
       System.Web.UI.Control.InitRecursive(Control namingContainer) +421
       System.Web.UI.Control.InitRecursive(Control namingContainer) +421
       System.Web.UI.Control.InitRecursive(Control namingContainer) +421
       System.Web.UI.Control.InitRecursive(Control namingContainer) +421
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1970
    

    The new property appears when editing the content though. I just can't edit the doc type any more without receiving the error. Tried touching the web.config.

    It didn't happen in my test environment and now my clients live environment is screwed.

    Any advice?

  • Jan Skovgaard 11264 posts 23592 karma points MVP 8x admin c-trib
    Mar 25, 2014 @ 16:42
    Jan Skovgaard
    0

    Hi Henrik

    Is this a clean installation of 6.1.2 or has it been upgraded from any previous versions? And are you certain about the version number? It's not 6.0.2?

    By googling the exception I found this old blogpost about a bug in 6.0.1, which should be fixed in 6.0.2 - Have not read it all though but perhaps you can find some usefull information in it? Perhaps in the comment - Here it is http://umbraco.com/follow-us/blog-archive/2013/3/4/umbraco-602-released.aspx

    The property you added...is the alias duplicated? If for instance there is a master document type containing the same alias and you add it on a child document type then it can get messy if Umbraco does not throw a warning about this...(Can't remember if it does)...but then having a peek at the database and changing the alias could perhaps fix it.

    Hope this helps.

    /Jan

  • Henrik Ladefoged 30 posts 100 karma points
    Mar 26, 2014 @ 09:13
    Henrik Ladefoged
    0

    Hi Jan

    Yes i just verified that the version is 6.1.2 and it's not an upgrade. I am 100% sure that it's not a duplicate.

  • James Wilkinson 15 posts 72 karma points c-trib
    Apr 24, 2014 @ 16:39
    James Wilkinson
    0

    Hi All,

    I have also just encountered this issue on Umbraco v6.1.6. I added a new property to a tab on the Home page Document Type and when I clicked Save, I got the yellow screen of death with the above error in the log file. There is no duplicate alias (I have checked in the [cmsPropertyType] table to be sure). Logging out and back in again and restarting the IIS site hasn't helped either.

    The site was a v6.1.4 install that was upgraded to v6.1.6 as v6.1.6 would not complete the install; hanging at 5% in all browsers.

    Does anyone have any ideas?

    Thanks,

    James.

  • Emil Christiansen 66 posts 148 karma points
    Mar 22, 2016 @ 10:42
    Emil Christiansen
    0

    Was this ever solved?

    Having the exact same problem on a customer now...

  • Mark Bowser 268 posts 855 karma points c-trib
    Mar 22, 2016 @ 15:55
    Mark Bowser
    102

    Hmmmm. Maybe you have two document types with the same alias? I'd check on that as well. Here's what I'd try as a next step:

    1. Install the uSync package on both your dev and the production site.
    2. Make sure uSync is configured to "write" on both sites using the /config/uSyncSettings.config file.
    3. Recycle the app pool for both sites. This should generate an xml representation of both of the document type structures.
    4. Use Beyond Compare to see if you can find out what the difference is between your functioning dev site and the broken production site.

    uSync is a neat package that you can use to write document types and data types out as xml. Then (if you want) you can use uSync to read the document type and data type changes in on another site. For your case, you just need it to write out the xml for you.

    As a disclaimer, we use uSync for both read and write in a lot of cases. It is really useful, but it can occasionally cause problems with MNTP prevalues. If you move on from using uSync to debug and start using it to deploy doc type / data type changes, proceed with caution. uSync gets better as the versions increase, but any tool that makes automated changes to the database should be handled with care.

Please Sign in or register to post replies

Write your reply to:

Draft