Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Robert Dyson 50 posts 147 karma points c-trib
    Feb 13, 2014 @ 09:24
    Robert Dyson
    0

    Umbraco 7.0.3 Media Library not working

    When I try to click to upload an image I am experiencing a couple of problems.

    Firstly, the area on which you have to click seems to alter in size and doesn't fille the upload box.

    Secondly, once a file is selected nothing happens, but I receive a JQuery javascript error from the following call

    http://superbodies/umbraco/backoffice/UmbracoApi/Media/PostAddFile

    Failed to load resource: the server responded with a status of 500 (Internal Server Error) 

    jquery-2.0.3.min.js:14

    This is preventing me uploading any media images. I'm not sure how to get around this should I try to use a different version of JQuery or Umbraco? Or can this be solved somehow..?

    Please help!

     

  • Jeroen Breuer 4860 posts 12121 karma points MVP 3x admin c-trib
    Feb 13, 2014 @ 12:08
    Jeroen Breuer
    0

    Hello,

    You can report bugs here: http://issues.umbraco.org/dashboard#newissue=yes

    Jeroen

  • Pedro Adão 41 posts 78 karma points
    Feb 17, 2014 @ 11:16
    Pedro Adão
    0

    I'm gettin the same error.

    When uploading multiple images in the umbraco bo this error apears in the console log

    1.     Request URL: http://localhost:62940/umbraco/backoffice/UmbracoApi/Media/PostAddFile

    2.     Request Method: POST

    3.     Status Code: 500 Internal Server Error

     

    )]}',

     

    {"Message":"An error has occurred.","ExceptionMessage":"The process cannot access the file 'C:\\development\\TempoDeAventura\\TempoDeAventura\\TempoDeAventura.Frontend\\App_Data\\TEMP\\FileUploads\\BodyPart_8bc8eee1-4497-4bf6-bd25-e9ab44da9312' because it is being used by another process.","ExceptionType":"System.IO.IOException","StackTrace":"   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)\r\n   at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)\r\n   at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)\r\n   at System.IO.File.OpenRead(String path)\r\n   at Umbraco.Web.Editors.MediaController.<PostAddFile>d__a.MoveNext()"}

     

    Is there any fix?

  • Adrian 10 posts 40 karma points
    Jun 28, 2014 @ 06:09
    Adrian
    0

    Im getting the same error too - was there any fix for this??

    posted my problem here:

    http://our.umbraco.org/forum/ourumb-dev-forum/bugs/54046-Error-when-uploading-file-on-v-714 ;

    no problems on localhost - only when deployed to the staging server - win2012 std / sql 2012 / dedicated virtual running on vmware

    problems on both 7.1.4 and 7.1.1

    have tested uploading to media on v6 - no problems exist.

    any help would be much appreciated

    thx

  • Karl Kopp 121 posts 226 karma points
    Dec 22, 2014 @ 01:04
    Karl Kopp
    0

    Did anyone get to the bottom of this? Happening to me as well?

  • Craig100 972 posts 2094 karma points c-trib
    Feb 26, 2015 @ 12:42
    Craig100
    0

    Still happening to me after an upgrade from 7.2.1 to 7.2.2. Thought it was supposed to be fixed. Is there anything special we need to do when performing an upgrade, as the Media folder is excluded when upgrading via Nuget.

     /umbraco/backoffice/UmbracoApi/Media/PostAddFile?origin=blueimp returns a 404 when trying to upload an image and the upload fails.

    Craig

  • Patrik Nydén 1 post 21 karma points
    Mar 06, 2015 @ 16:41
    Patrik Nydén
    0

    One thing i did to break mediaupload was to make changes (by misstake) to the "Label (Umbraco.NoEdit)" datatype.

    That sure did fck up things.

  • patrick iversen 14 posts 36 karma points
    Jul 03, 2015 @ 11:25
    patrick iversen
    0

    I had the same issue with a png image from a customer.But I could preview it but not upload umbraco or open it in photoshop. Turns out the file was a .psd renamed to .png so renaming it back to psd and saving it as a png solved it.

  • Henry 21 posts 141 karma points
    Aug 25, 2015 @ 10:35
    Henry
    0

    Was getting this error, just migrated to a new server, so thought it was a file permissions issue. Turns out it was a corrupt image file!

Please Sign in or register to post replies

Write your reply to:

Draft