Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Adrian 38 posts 117 karma points
    Mar 27, 2014 @ 12:01
    Adrian
    0

    HTTPS and BackOffice logging in.

    Hi,

    (U7.0.1)

    I've set up a new site using HTTPS/SSL and MS Identity providing SSO.

    Which works fine for the site, but when I try to go to the back office via /umbraco

    I get the login page, I can enter my user name and password, but I just get a blank page.

    I use Chrome Dev Tools, I can see:

    Failed to load resource: the server responded with a status of 400 (Bad Request) https://*****/umbraco/backoffice/UmbracoApi/Authentication/IsAuthenticated
    
    Failed to load resource: the server responded with a status of 401 (You must login to view this resource.) https://*****/umbraco/ServerVariables
    
    No url found for api name legacyTreeJs
    

    Using the network tab, it looks like IsAuthenicated fails before entering the uname and pass, and the ServerVariables 401 is after.

    And in the UmbracoTraceLog.txt we see that(emphasis mine!):

    2014-03-27 10:47:35,205 [6] INFO umbraco.BusinessLogic.Log - [Thread 23] Redirected log call (please use Umbraco.Core.Logging.LogHelper instead of umbraco.BusinessLogic.Log) | Type: Login | User: 0 | NodeId: -1 | Comment: User adrian has logged in

    2014-03-27 10:47:35,205 [6] INFO Umbraco.Web.Security.WebSecurity - [Thread 21] User Id: 0 logged in

    Is there some config or way to fix this? I've had a look through the code WebSecurity.cs on GitHub and notice it doesent change between version 7.0.1 and 7.0.4, whilst it does change quite a bit in 7.1.0....

  • organic 108 posts 157 karma points
    Jun 25, 2014 @ 23:42
    organic
    0

    Did you solve?

    I am having the same problem when setting up a site to run in a virtualized, load balanced environment.  Though I think I get the error even when installing on just one box.  The site folder has IIS APPPOOL\{app pool name} typical Umbraco permissions.

  • Rick Mason 38 posts 169 karma points
    Jul 30, 2014 @ 12:48
    Rick Mason
    2

    I had the same problem on a test site and fixed it. It was because the authentication cookie wasn't being written, which in turn was because my site was running over http but I had httpCookies requireSSL="true" in web.config. Switching to https solved the problem (or removing requireSSL="true", but only on your localhost test site).

  • Dhanushka Kodituwakku 3 posts 73 karma points
    Oct 13, 2016 @ 05:07
    Dhanushka Kodituwakku
    0

    Yup it was the requireSSL set to true

  • Glenn 28 posts 101 karma points
    Jan 29, 2015 @ 01:22
    Glenn
    0

    So I am having a similar issue. 

     

    What is weird it that on my staging Machine it works just fine. This issue is occuring on my local machine only. 

    Both sites on not running secure and they both have the same web.config?

     

     

  • Glenn 28 posts 101 karma points
    Feb 02, 2015 @ 03:08
    Glenn
    0

    I must have been having a bad day, but it does lead me to believe what the problem may be something related to your session timeout settings or similar if are getting this issue. 


    I had changed the following AppSetting in web.config, thinking that it would set the timout to infinate. I was wrong, it set the timeout to 0.

    Changing this back to the default of 20, resolved. 



     

  • Jeroen Breuer 4908 posts 12265 karma points MVP 4x admin c-trib
    Mar 26, 2015 @ 09:59
    Jeroen Breuer
    0

    I'm having the same issue. It works local, but not on staging. When debug=true in the web.config it works and with debug=false it doesn't. Upgraded from Umbraco 7.2.2. to 7.2.4.

    I'm not on https and umbracoUseSSL is set to false in the web.config. umbracoTimeOutInMinutes is set to 60.

    Jeroen

  • Jeroen Breuer 4908 posts 12265 karma points MVP 4x admin c-trib
    Mar 26, 2015 @ 10:22
    Jeroen Breuer
    0

    Added a screenshot:

    Jeroen

  • Jeroen Breuer 4908 posts 12265 karma points MVP 4x admin c-trib
    Mar 26, 2015 @ 12:58
    Jeroen Breuer
    0

    After setting <customErrors mode="Off" /> I got some more info.

    After going to the url of the first error I got this:

    So it seems to be related to the YouTube package. After uninstalling the package the error was gone.

    Jeroen

  • Phil 54 posts 139 karma points
    Mar 26, 2015 @ 15:45
    Phil
    0

    I get the same problem when trying to run my site with Windows Authentication - don't know if this is relevant in your situation but could hopefully help someone else!

  • Jeavon Leopold 3072 posts 13628 karma points MVP 10x admin c-trib
    Mar 26, 2015 @ 20:33
    Jeavon Leopold
    0

    Hello,

    I have added a fix to the YouTube package for this, but I'm pretty sure this must be a bug in the Umbraco Core, has it been reported?

    If you want to try a updated YouTube package you can get it from MyGet for a NuGet package or AppVeyor for the zip Umbraco package.

    Jeavon

  • Jeavon Leopold 3072 posts 13628 karma points MVP 10x admin c-trib
    Mar 26, 2015 @ 20:39
    Jeavon Leopold
    0

    The fix was to add a check for the key before adding:

    if (!e.ContainsKey("YouTube"))
                    e.Add("YouTube", new Dictionary<string, object>
                    {
                        //Then child item of uTube - Add Base Url to controller - minus the method name
                        {"ApiUrl", urlHelper.GetUmbracoApiServiceBaseUrl<YouTubeApiController>(controller => controller.VideosForChannel(null))},
                    });
    

    The if (!e.ContainsKey("YouTube")) was not required before v7.2.3/v7.2.4

  • Shannon Deminick 1524 posts 5269 karma points MVP 2x
    Mar 26, 2015 @ 23:11
    Shannon Deminick
    1

    Unfortunately it's due to a change that was made regarding how they are cached. Before server vars were output cached which was not the correct way of caching an authenticated resource.

    So it is a 'breaking' / 'unbreaking' change if you look at it one way, but if you look at it another way this logic should have always been required in previous versions.

    When do you ever add something to a dictionary that you have not created yourself without first checking if the key is already there? ... if you didn't make the dictionary you should always check that. Otherwise you can always do the shorthand syntax:

    e["YouTube"] = "blah"

    which adds or updates automatically.

  • Jeavon Leopold 3072 posts 13628 karma points MVP 10x admin c-trib
    Mar 27, 2015 @ 00:47
    Jeavon Leopold
    0

    Unbreaking is much better than unintentional :)

    I'll add a comment to Warrens blog post about adding this check which I think he wrote whilst developing the YouTube package.

    Thanks Shannon.

  • Tim 168 posts 372 karma points
    Mar 28, 2015 @ 09:36
    Tim
    0

    Is there a (simple) way to identify which package is causing this, we don't have the YouTube package installed but also have this issue. Definitely a breaking change people need to know about :)

  • Tim 168 posts 372 karma points
    Mar 28, 2015 @ 09:52
    Tim
    0

    I think we may have found the package causing our issue -it looks as though it was Architype which has been updated to accommodate this change.

    Update: I spoke too soon, looks like something else is causing the issue

  • Jeavon Leopold 3072 posts 13628 karma points MVP 10x admin c-trib
    Mar 28, 2015 @ 10:32
    Jeavon Leopold
    0

    Hi Tim,

    What packages do you have installed?

    Jeavon

  • Tim 168 posts 372 karma points
    Mar 28, 2015 @ 11:23
    Tim
    0
    • AngularGoogleMaps
    • Archetype
    • Articulate
    • CmsImport
    • RJP.MultiUrlPicker

    I've looked through the source of the Maps and MultiUrlPicker and it doesn't look like it's those.

    Swapping over to debug mode=true does work around it for the time being thankfully while packages are updated.

  • Jeavon Leopold 3072 posts 13628 karma points MVP 10x admin c-trib
    Mar 28, 2015 @ 13:56
    Jeavon Leopold
    0

    Not obvious candidate, if you read Warrens blog post here there is section about using the Chrome console to get all the current variables, that should tell you what's in there and hopefully which package.

  • Jeavon Leopold 3072 posts 13628 karma points MVP 10x admin c-trib
    Mar 28, 2015 @ 22:15
    Jeavon Leopold
    0

    Yes, if you open the Javascript console while logged into Umbraco (in debug) and type "Umbraco.Sys.ServerVariables" it will return all the variables.

  • Saulo Tsuchida Cruz 1 post 21 karma points
    Apr 01, 2015 @ 16:32
    Saulo Tsuchida Cruz
    0

    I have the same issue. Im working with a fresh install of umbraco.

    In Dev server the site is working fine, but on Prod server i have this error http://screencast.com/t/Emyn98IKpu.

    Maybe is an issue with the framework, in dev i have version 4.5.2 and on prod the 4.5.1.

  • Jeavon Leopold 3072 posts 13628 karma points MVP 10x admin c-trib
    Apr 25, 2015 @ 22:46
    Jeavon Leopold
    1

    For anyone finding this thread, the YouTube package is fixed in the v1.0.3 release

  • Shannon Deminick 1524 posts 5269 karma points MVP 2x
    Apr 27, 2015 @ 00:30
    Shannon Deminick
    2

    I'm going to fix this in the core in 7.2.5: http://issues.umbraco.org/issue/U4-6559

    So that packages affected by this do not error, though packages devs should always check for existence of keys in foreign dictionaries (note to self... since Articulate is affected too :P )

  • Edivan Teixeira 3 posts 43 karma points
    May 29, 2015 @ 20:33
    Edivan Teixeira
    0

    someone consegiu solve? I have the same problem, but my case is a clean and do not need https installation.

     

  • Mykhaylo Katruk 1 post 21 karma points
    May 16, 2016 @ 08:33
    Mykhaylo Katruk
    0

    Hi,

    I had exactly the same issue appearing from time to time. In my case, the cause of the issue was some Chrome/FireFox plugin.

    Using clean/private browser or IE works fine.

    Hope this helps.

  • Biagio Paruolo 1593 posts 1824 karma points c-trib
    Sep 14, 2016 @ 10:23
    Biagio Paruolo
    0

    I've the same problem.

  • Peter 27 posts 192 karma points
    Oct 10, 2016 @ 13:23
    Peter
    1

    Hello,

    Just a few days ago I had the exact same issue on my Windows 10 pc in both Chrome and Firefox .

    None of the above mentioned solutions did it for me, but eventually I found this article and solved the issue going by "Method 2".

    The article is written for Windows XP but that does not seem to matter. I went through all the steps (except step 1 about "DisableStrictNameChecking") and it works like a charm :]

    Remember to restart your machine though.

  • Ali Sheikh Taheri 470 posts 1648 karma points c-trib
    Nov 11, 2016 @ 16:49
    Ali Sheikh Taheri
    0

    Thanks Peter, I had the same problem and managed to fix it by using the method 2 of the same article : https://support.microsoft.com/en-us/kb/896861

    Cheers Ali

  • Kenneth Jakobsen 67 posts 203 karma points hq
    Oct 10, 2016 @ 13:46
    Kenneth Jakobsen
    0

    I hade the same problem (the problem was for me using Asp.Net Identity) I installed the UmbracoIdentity package from nuget and all my troubles went away (i am also using SSL).

  • K Jansen 2 posts 72 karma points
    Oct 25, 2016 @ 07:07
    K Jansen
    0

    Yesterday I installed the latest Umbraco. After checking things in to source control (Visual Studio) the backoffice got the same error as listed above.

    For some reason the folders were readonly (and Umbraco wants rights for some folders, especially the 'bin' folder).

    All I had to do to make it work again was selecting those folders and add check 'readonly' for all folders and subfolders, hit apply, then uncheck 'readonly' and apply.

    Everything is running again. Hopefully this will help some of you guys.

  • Cristovao 12 posts 33 karma points
    Oct 31, 2016 @ 18:38
    Cristovao
    0

    Hi all,

    Same problem (without HTTPS). The key here is check the umbraco log file (Appdata\Logs). This is mostly cause by write permission on Appdata\TEMP\ folder.

  • Julio M. Vivas 57 posts 107 karma points
    Nov 15, 2016 @ 12:17
    Julio M. Vivas
    0

    I have an interesting variation on the same issue: something went wrong on a windows update and the server clock jumped 3 days into the future. We fixed it within 5 minutes but after that the Umbraco CMS screen refuses to load with a blank screen and a similar 404 notfound error on /umbraco/ServerVariables?umbrnd=5d96879f&umbrnd=7.5.3.1293792560 and another error for "No url found for api name legacyTreeJs"

    Umbraco loads fine on IE and Edge.

    Tried all the fixes suggested above but no joy. Wonder if there is something on the database with the wrong settings causing this?

  • Biagio Paruolo 1593 posts 1824 karma points c-trib
    Nov 15, 2016 @ 13:13
    Biagio Paruolo
    1

    See here https://our.umbraco.org/forum/using-umbraco-and-getting-started/80597-user-password-doesnt-work-after-last-login-a-week-ago#comment-257695

    For me, the issue was caused by the date and time changed on the host server after login. So, I changed the datetime and cleared Umbraco cache and tmp files.

  • Bendik Engebretsen 105 posts 202 karma points
    Feb 08, 2017 @ 20:55
    Bendik Engebretsen
    0

    Clearing the cache and TEMP is what fixed it for me.

  • Julio M. Vivas 57 posts 107 karma points
    Nov 15, 2016 @ 13:45
    Julio M. Vivas
    0

    Hi Biagio

    Thanks for looking into this. Unfortunately after wiping out the whole AppData\TEMP and AppData\cache folders the issue persists on Chrome/Firefox. Also hard refresh and trying to login from incognito windows shows the same blank screen,

    Time was fixed on the host server straight away and it still seems to be fine.

    At this stage we have no choice but to fix a couple of Edge issues with Angular file uploads so the client can keep updating the site until we find a solution.

    I suspect there are some permissions on scripts which are falling foul of Chrome validation but can't quite pinpoint what it might be. It only works on IE/Edge and Safari

  • Julio M. Vivas 57 posts 107 karma points
    Nov 15, 2016 @ 14:07
    Julio M. Vivas
    0

    Even tried changing the version on clientDependency.config but it's still a dead Umbraco on Chrome

  • Julio M. Vivas 57 posts 107 karma points
    Nov 15, 2016 @ 14:46
    Julio M. Vivas
    0

    One thing I noticed is that Umbraco resources, e.g. umbraco/backoffice/UmbracoApi/Entity/GetAncestors come up with a date on the response headers that is set to the "future" wrong date that originated the whole mess. So it seems like there is only one thing left to do: restart the server.

  • Julio M. Vivas 57 posts 107 karma points
    Nov 15, 2016 @ 16:23
    Julio M. Vivas
    0

    Final update from my end (fingers crossed): server restart fixed the issue. I guess the way dependencies are generated is very sensitive, like pretty much anything else in Umbraco.

  • Bendik Engebretsen 105 posts 202 karma points
    Feb 09, 2017 @ 14:30
    Bendik Engebretsen
    0

    Just wanted to hear if you have managed to find a better fix/workaround than rebooting the server? This is really getting on my nerves now and has become a huge time consumer. Chrome is practically useless for testing and debugging on my development machine now:-(

  • Julio M. Vivas 57 posts 107 karma points
    Feb 09, 2017 @ 16:00
    Julio M. Vivas
    0

    Hi Bendik

    We are moving everything to Azure so we haven't experienced this issue again (fingers crossed). To really dig down into what was affected in our scenario I think there's no other choice than forcing the date change on a dev server and then running a profiler to see what is exactly breaking down.

    Now, in your case can you confirm there are no issues with the system date on your dev box? Also look for HTTPS settings, installed packages, debug and so on as discussed on this thread to make sure nothing else is playing up with your site.

    Finally, if you install a "vanilla" U 7.5.9 on the same server, does it work correctly? I think there are some underlying issues with 7.5.3 like this one which might be involved.

    Let me know how it goes and share anything you see on the Umbraco Logs or Application Logs that might be relevant.

  • Bendik Engebretsen 105 posts 202 karma points
    Feb 10, 2017 @ 09:14
    Bendik Engebretsen
    0

    I just upgraded the site to 7.5.9 and so far, the problem seems to be gone:-) Fingers crossed!!

  • Bendik Engebretsen 105 posts 202 karma points
    Feb 12, 2017 @ 11:12
    Bendik Engebretsen
    0

    After a couple of days, the problem came back. Very frustrating. Here are three lines from the Umbraco log that seems to be related to the login:

    2017-02-12 12:06:17,864 [P10860/D2/T12] WARN  Umbraco.Web.UmbracoModule - Status code is 404 yet TrySkipIisCustomErrors is false - IIS will take over.
    2017-02-12 12:06:43,529 [P10860/D2/T15] INFO  Umbraco.Core.Security.BackOfficeSignInManager - Event Id: 0, state: Login attempt succeeded for username Bendik from IP address ::1
    2017-02-12 12:06:43,529 [P10860/D2/T15] INFO  Umbraco.Core.Security.BackOfficeSignInManager - Event Id: 0, state: User: Bendik logged in from IP address ::1
    

    Apart from the 404 it seems the login is OK.

  • Bendik Engebretsen 105 posts 202 karma points
    Feb 08, 2017 @ 20:53
    Bendik Engebretsen
    0

    I'm having the same problem: blank Umbraco backoffice in Chrome not in IE. And the funny error message in the Chrome DevTools: "No url found for api name legacyTreeJs". I'm running Umbraco 7.5.3 in Visual Studio 2015.

    For me rebooting the machine was the only thing that helped, until I just discovered clearing the Umbraco App_Data/cache and /TEMP also does:-) - Which is more convenient of course...

    Edit: Too quick jumping into conclusion. The ghost is back and clearing cache and TEMP didn't scare it off this time. But reboot did, and I've resorted to the method 2 in https://support.microsoft.com/en-us/kb/896861 to see if that yields a more permanent solution. Will let you know how it goes...

    Edit 2: Nope. Method 2 is worthless. Rebooting seems to be the only weapon that kills it. Sad, because I will be spending most of my time rebooting while testing my latest piece of Umbraco AngularJS code...

  • Roberto Bianchi 137 posts 446 karma points c-trib
    Aug 02, 2017 @ 10:05
    Roberto Bianchi
    1

    Try changing the umbracoTimeOutInMinutes key in Web.config to 4880 value.

    For me, this was the solution to the problem ;)

Please Sign in or register to post replies

Write your reply to:

Draft