Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Peter Bardenhagen 1 post 21 karma points
    Apr 02, 2014 @ 07:58
    Peter Bardenhagen
    0

    Forced_Root_Block editor settings in Umbraco 7

    I have tried adding the following settings to Config/tinyMceConfig.config which have no effect on the editor:

    <config key="force_p_newlines">false</config>
    <config key="force_br_newlines">true</config>
    <config key="forced_root_block">false</config>

    The purpose is to avoid wrapping text and marcos in <p> tags.

    Has anyone been able to achieve this in the latest version of Umbraco? I am using 7.0.3.

  • Arjan Woldring 118 posts 225 karma points
    Apr 02, 2014 @ 08:54
    Arjan Woldring
    1

    Hi,

    This should be fixed in 7.1 which probably would be released the end of this week.

    This is the related issue: http://issues.umbraco.org/issue/U4-4031

  • Rizwan ahmed Butt 5 posts 25 karma points
    Mar 09, 2015 @ 08:59
    Rizwan ahmed Butt
    0

    Hi,

    I'm using Umbraco 7.2 (latest one) but getting the same issue. Would you please help me to fix this?

    /Rizwan 

  • Søren Chr. 10 posts 100 karma points
    Sep 06, 2015 @ 21:37
    Søren Chr.
    0

    Same problem here.

    Anyone got this to work?

    Thanks

  • vcamargo 27 posts 98 karma points
    Dec 09, 2015 @ 17:04
    vcamargo
    0

    same here :-/

  • Simon Dingley 1412 posts 3287 karma points c-trib
    Jan 13, 2016 @ 17:28
    Simon Dingley
    0

    Have you tried adding this to your config:

    <config key="forced_root_block">''</config>
    

    I don't know why but at the moment seems to be working for me and also seems to be still creating paragraphs on enter which according to TinyMce docs perhaps shouldn't but is what we wanted.

    https://www.tinymce.com/docs/configure/content-filtering/#forcedrootblock

  • Thomas Hansen 174 posts 401 karma points
    Sep 28, 2017 @ 12:32
    Thomas Hansen
    0

    7.7.1

    still not working ??

  • vcamargo 27 posts 98 karma points
    Sep 28, 2017 @ 13:25
    vcamargo
    1

    Not sure, mate. I've given up after trying for a few weeks, I decided that the CMS was an overkill for my project. Good luck!

  • Eric Wilkinson 13 posts 83 karma points
    Dec 18, 2017 @ 19:05
    Eric Wilkinson
    0

    I found that including force_p_newlines, even if set to false would cause the root block to be a <p>.

    Remove the force_p_newlines setting completely, and then the rest of the settings seem to work as intended.

    I had success with the following:

    <config key="forced_root_block">div</config>
    <config key="convert_newlines_to_brs">true</config>
    <config key="force_br_newlines">true</config>
    

    but you could also leave the two br-related config rules out and just use

    <config key="forced_root_block">div</config>
    
Please Sign in or register to post replies

Write your reply to:

Draft