Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Damian Green 452 posts 1433 karma points
    May 08, 2014 @ 13:56
    Damian Green

    Backend node editing caching


    • 2 dev environments pointing to same DB

    • Load balancing is enabled in umbraco settings and pointing to each site (this is just the edit to the umbracosettings file so no DFS or anything taking place)


    If i edit a node and publish on one of the sites the website page is updated on both to show the new value (even though i cant see anything happen in fiddler so no idea how this happens)


    The umbraco backend still shows the old value on the environment that wasn't edited.

    Possible Solutions

    Is there a way to force this to clear or prevent the caching? Where is the backend taking its data from? A memory cache?

    Looking at the DB profiler it seems to be that umbraco is pointing to the old revision.

    Reason for doing this

    Utimately I am trying to setup a dev environment for a few devs all working on the same site but the caching issue is worrying as it is unpredictable.

    What is the defacto way of setting up an environment where several developers can work on the site - content and document types and also editing templates etc... The templates will be source controlled so a get latest will control templates.

  • Damian Green 452 posts 1433 karma points
    May 08, 2014 @ 16:15
    Damian Green

    Another point -

    After i have made the change to one site and both front ends are showing the new values correctly, but the backends are different...

    The umbraco.config cache file is showing the new values on both sites!

    if i restart the site on the one that hasn't updated the new values are pulled in - so its definitely looking like a cache issue.

    I have tried doing a republish entire site but no avail.

    If i just publish on the one where the backend hasn't changed then the old values overwrite the values entered on the other server.

  • Damian Green 452 posts 1433 karma points
    May 08, 2014 @ 17:05
    Damian Green

    Right I have found a way to make this update the backend but its not ideal and could cause problems going forward with sessions etc...

    By setting the recycle time on the app pool to 2 mins it will keep reloading the cache and the backend comes back into sync.

    This is on a dev server so ok at the moment... and ive done it more to prove a point that the data is there - its just a cache that is getting in the way.

    Is there a way to force the backend to reload its cache - perhaps maybe on a change in the umbraco.config file?

    I have tried the cache settings in umbraco.settings and these don't seem to do anything on the backend caching.

    Thanks Damian

  • Damian Green 452 posts 1433 karma points
    May 09, 2014 @ 11:17
    Damian Green

    Still got this issue even after trying the latest nighlties as suggested by Per so I have created an issue here:

  • Tobias Lopez 64 posts 210 karma points
    Oct 09, 2014 @ 11:11
    Tobias Lopez


    I have the same issue on my local instance.
    Have you found any solution?


  • Zac 223 posts 575 karma points
    Oct 13, 2014 @ 17:41

    I somehow only just noticed this.

    I'm fairly sure all previous versions of Umbraco didn't have this backend-cache in place, right?

  • Damian Green 452 posts 1433 karma points
    Oct 13, 2014 @ 17:55
    Damian Green


    The root of my problem (from memory) was it was basically in load balancing mode.

    If you have this scenario you should do all your updates in one place (one main server). In dev env i always make my changes on the one main server (normall the live test server) and a rebuild on my local app triggered an app recycle.

    In my build system (where i was getting the issue) i triggered an app pool recycle on the target server after deploying to another server.

    Cheers, Damian

  • Damian Green 452 posts 1433 karma points
    Oct 13, 2014 @ 17:57
    Damian Green

    And not sure on the previous versions caching but this may be down to Angular and how it was used for Umbraco 7.

Please Sign in or register to post replies

Write your reply to: