Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Marty 7 posts 52 karma points
    Aug 19, 2014 @ 17:50
    Marty
    2

    User Permissions not behaving as expected

    I've been using Umbraco as a web developer for at least 3 years now (starting with 4.7) and have recently started using v7. I've built a few sites with it already but I've encountered the same issue with each one:

    Each user I create should have base permissions of 'Browse', 'Publish' and 'Update' (No deleting core pages such as the Home Page or Contact Page), with 'Create' permissions on specific nodes such as 'News'.

    Now when I set up all of this, the user can reach the create page, but there is no 'Save and Publish' button, preventing the user from actually creating the page. I'm using the latest release of Umbraco 7 (7.1.4), and the same thing happens on a local build via Visual Studio, as well as in a live environment. I've tried using both SQL Server Compact and SQL Server 2012 but the issue still persists.

    Below are the steps to re-create the issue:

     

    • Right click users, click create.
    • Enter a Login Name (for this example let's name him Bob), and e-mail (bob@example.com) then click 'Create' (Edit User tab is displayed)
    • Click 'Change Your Password' and enter the a password into both fields (for this example, I used 'password')
    • Change the 'User Type' to 'Editor'
    • Check 'Content' and 'Media' under 'Sections'
    • Click the 'Save' button at the top right of the page.

     

    The user 'Bob' has now been created

     

    • Next, expand the 'User Types' section in the Users tree and click 'Editor' to edit the default permissions.
    • Un-check everything except 'Browse Node', 'Publish' and 'Update' - we want Bob to be able to edit existing content nodes, but not delete them. 
    • Click the Save button at the top of the top right of the page.

     

    So far, so good. If Bob was to log in now, he would be able to browse, update and publish all existing content nodes. However, we want Bob to be able to create and publish News articles so we need to give him the permissions to do so.

     

    • Back in the Users section, expand the 'User Permissions' section and click on 'Bob'.
    • Expand the tree and click on the 'News' page to modify its permissions.
    • Check the 'Create' box and click the 'Save' button at the top right of the page.

     

    Now, I would expect at this point Bob should be able to log in, create a News Item and Save and Publish it to make it visible on the website. But when the following actions are performed:

    • Log in as Bob
    • In the content tree, Right click the 'News' node.
    • Click the 'Create' item in the pop-up menu and select the News Item document type.

    On the create page, there is no 'Save and Publish' button and it is at this point I am well and truly stuck. On Umbraco 4 and 6, this worked fine. Is this a bug? As there is are buttons, there is no way to save the content that is created. Has anyone else encountered this issue?

  • Amalie Wowern 113 posts 220 karma points
    Aug 20, 2014 @ 14:10
    Amalie Wowern
    0

    CTRL + S is the solution i can come up with

  • Marty 7 posts 52 karma points
    Sep 01, 2014 @ 11:07
    Marty
    0

    That won't work on mobile devices, but when I try on desktop the following error that pops up in a red box, where the green 'Content published' notification appears:

    Authorization error: Unauthorized access to URL: 

    /umbraco/backoffice/UmbracoApi/Content/PostSave

    with data: 

    {"key":"contentItem","value":{"id":0,"properties":[{"id":0,"alias":"title","value":""},{"id":0,"alias":"featuredPage","value":"0"},{"id":0,"alias":"image","value":""},{"id":0,"alias":"bodyText","value":null},{"id":0,"alias":"umbracoNaviHide","value":"0"}],"name":"","contentTypeAlias":"umbTextPage","parentId":1068,"action":"saveNew","expireDate":null,"releaseDate":null,"templateAlias":"umbTextPage"}}

    Contact your administrator for information.

     

  • Marty 7 posts 52 karma points
    Sep 09, 2014 @ 11:10
    Marty
    0

    I've logged this as a bug in the tracker but I've not received any responses. Is this issue exclusive to my set up or is it able to be reproduced? It's currently causing a few headaches for me and any help would be greatly appreciated.

    Link to issue in tracker:http://issues.umbraco.org/issue/U4-5433

     

     

     

     

     

     

  • Ben 103 posts 369 karma points
    Oct 31, 2014 @ 21:37
    Ben
    0

    I get the same thing after a user has been to a content page they didn't have access to, and then I give them access to it.  They have access to the parent page and I had to delete the child page they didn't have access to.  Then I had the user create a new page.  They didn't have a Green save button, but the preview button was on the new page.  Once they clicked that then it saved and everything worked for them.

    I have this particular user set to the following permissions:

    • Audit Trail
    • Browse Node
    • Copy
    • Delete
    • Move
    • Create
    • Rollback
    • Sort
    • Send To Publish
    • Update
  • Chris Wilson 100 posts 377 karma points
    May 21, 2015 @ 13:43
    Chris Wilson
    0

    I have the same issue:

    My News section is organised as follows; News -> News Category -> News Article

    My editors have default permissions of at least create/delete/update/publish, they have also been given the ability to update/publish the Categories and need to be able to add/remove/update/publish Articles.

    If I create a new Article, it receives all the permissions of the parent (Category); meaning once the user has created the Article, they cannot delete it.

    It would be handy if I could say that for any given Article Document Type, Editors should have the control level specified.

    Is this possible?

    Regards, Chris

  • Neil Gaietto 13 posts 72 karma points c-trib
    Jul 07, 2015 @ 16:44
    Neil Gaietto
    0

    Has anyone found a solution to this issue? This is still a problem in 7.2.4. Users cannot create content when only granted permissions to a single node directory because the "Save and publish" buttons are missing.

  • Gordon Saxby 1345 posts 1606 karma points
    Jul 30, 2015 @ 09:12
    Gordon Saxby
    0

    Seem to have the same problem (Umbraco 7.2.1). Created a new User Type and gave it Browse only.

    Created a new user and granted extra permissions on specific nodes (Browse, Create, Publish, Rollback, Update).

    The user can edit / publish existing nodes (that they have been given permissions for). New nodes can be created but neither the "Preview" nor the "Save and Publish" buttons appear.

  • Gordon Saxby 1345 posts 1606 karma points
    Aug 20, 2015 @ 07:35
    Gordon Saxby
    0

    Still need to fix / get round this problem somehow!

    I just tried Ctrl+S but it gave this error

    Authorization error: Unauthorized access to URL: /umbraco/backoffice/UmbracoApi/Content/PostSave with data: {"key":"contentItem","value":{"id":18803,"properties":[{"id":2059177,"alias":"umbracoUrlName","value":"childrenandfamilies"}],"name":"Families","contentTypeAlias":"HoldingPage","parentId":1709,"action":"saveNew","expireDate":"2015-12-11 14:49:58","releaseDate":null,"templateAlias":"HoldingPage"}} Contact your administrator for information.

    I was thinking that I could maybe override or set permissions in the "Creating" event, but this page https://our.umbraco.org/documentation/Reference/Events-v6/ContentService-Events says the event is obsoleted!?

    Is there any way to fix this ... other than fixing the Umbraco core itself?

  • Robert Martine-McEvoy 24 posts 109 karma points
    Aug 25, 2015 @ 19:25
    Robert Martine-McEvoy
    0

    Marty,

    I think I experienced something similar when changing permissions via the API. Mine is a little different since yours is related to "Create" though.

    On a content save event, I give additional publish permission on that content node to 'User A' who does not have publish by default.

    When I log back in as 'User A' they do not have the save and publish button available in the Content Editor.

    However, 'User A' does have these permissions available in the Context Menu and Actions Menu. This is where my example differs from your example, because you don't have either of those available when you are first Creating a Node.

    [EDITED]

    The only way I was able to make the the Save and Publish button show up in the Content Editor for 'User A' was by Restarting the site in IIS.

    Previously I tried Republish Entire Site and deleting umbraco.config but neither worked.

    Have you tried this for your user 'Bob'? I realize this is not a viable solution, but it might point us in the right direction.

  • Daniel 44 posts 187 karma points
    Sep 09, 2015 @ 18:47
    Daniel
    0

    I had the same issue. I solved it by changing user type from "Writer" to "Editor"

  • Suhasini 3 posts 73 karma points
    1 week ago
    Suhasini
    0

    This saved my day ! Thanks

  • Gordon Saxby 1345 posts 1606 karma points
    Sep 14, 2015 @ 08:48
    Gordon Saxby
    2

    In case anyone else comes across this issue - the bug has been fixed and will be released with 7.3.0

    http://issues.umbraco.org/issue/U4-6973

    I believe the fix is also in the current 7.3.0 RC

    https://our.umbraco.org/contribute/releases/730

  • qrayg 24 posts 92 karma points
    Apr 20, 2016 @ 19:38
    qrayg
    0

    I'm having some issues as well. My user needs access to specific pages nested deep into the nav. Their user type has NO access to anything. I give them specific permissions just to the nested pages they need.

    I have to give them Browse access to the path down to the pages but those pages that they only have Browse access to also allows them to save and publish which is undesired. They should not be able to edit the home page but they can even though the permissions are set to only Browse.

    I'm using 7.3.7.

Please Sign in or register to post replies

Write your reply to:

Draft