Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Chris Van Oort 110 posts 370 karma points
    Oct 07, 2014 @ 05:51
    Chris Van Oort

    Failed to retrieve data for empty member item type

    I have just one member type with many properties and I upgraded from Umbraco 6.2.1 to 7.1.6.

    When I right click and go to create a new Member of "Dealer Login User" I receive this error:

    Server error: Contact administrator, see log for full details.
    Failed to retrieve data for empty member item type DealerLoginUser

    When I go to click any of the existing members I receive this error:

    Server error: Contact administrator, see log for full details.
    Failed to retrieve data for member id ac15863825084e1cb1e9e620b3a1a872

    I dug into the logs on Azure and it's giving me a 500 error and this is what I found:

    {"Message":"An error has occurred.","ExceptionMessage":"The given key was not present in the dictionary.","ExceptionType":"System.Collections.Generic.KeyNotFoundException","StackTrace":"   at System.Collections.Generic.Dictionary`2.get_Item(TKey key)\r\n   at Umbraco.Web.PropertyEditors.MultiNodeTreePickerPropertyEditor.MultiNodePickerPreValueEditor.ConvertDbToEditor(IDictionary`2 defaultPreVals, PreValueCollection persistedPreVals)\r\n   at Umbraco.Web.Models.Mapping.ContentPropertyDisplayConverter.ConvertCore(Property originalProp)\r\n   at AutoMapper.TypeConverter`2.Convert(ResolutionContext context)\r\n   at AutoMapper.MappingExpression`2.<>c__DisplayClass15.<ConvertUsing>b__14(ResolutionContext context)\r\n   at AutoMapper.Mappers.TypeMapObjectMapperRegistry.CustomMapperStrategy.Map(ResolutionContext context, IMappingEngineRunner mapper)\r\n   at AutoMapper.Mappers.TypeMapMapper.Map(ResolutionContext context, IMappingEngineRunner mapper)\r\n   at AutoMapper.MappingEngine.AutoMapper.IMappingEngineRunner.Map(ResolutionContext context)"}"

    I see that it has an error with the "MultiNodeTreePicker" which is also referenced here:

    That post has a SQL script that I can run, but I'm not sure if it'll fix my issue? I'm also not sure what the poster there means by:

    Be aware that this will remove all prevalues for specified datatypes. Application pool recycle will be needed afterwards.

    Can anyone please help me?

  • Chris Van Oort 110 posts 370 karma points
    Oct 08, 2014 @ 07:33
    Chris Van Oort

    Update -- so I tried running the SQL script specified in that link that would fix the multinode treepicker. However, it didn't work for me and seemed to drop my members...which was bad. Fortunately backups exist and I got a backup version swapped into place.

    I traced the issue down to a couple of data types that use the multinode treepicker though and don't load properly (these are specified as generic properties for the member type).

    Update 2: This was resolved by changing the properties in the member type from the broken datatypes (which I deleted) to a label / text string. Also the SQL didn't drop my members, deleting my member type and then recreating it to trace down the problem removed all members of that type.

  • Rick Mason 8 posts 91 karma points
    Feb 22, 2022 @ 21:03
    Rick Mason

    8 years later and I got the same error on Umbraco 9.3.0. In my case it was because I had multiple member groups with the same name.

    "Failed to retrieve data for member id" just means "something went wrong with the API call". If you look in DevTools at the response from the API you see the real error, which in my case was "The given key already exists in the dictionary [member group name]".

    This translated to records in the umbracoNode table with the same value for the 'text' column. Deleting the duplicate records fixed it. Luckily this was a test site and I had no members in the groups, so no foreign keys to manage.

Please Sign in or register to post replies

Write your reply to: