Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Peter S 169 posts 587 karma points
    Dec 11, 2014 @ 11:18
    Peter S
    0

    Backend error after 7.2 upgrade

    I just upgraded from 7.1.4 to 7.2 and everything started out working great but then the backend misteriously broke. I have replaced all the files twice and the console tells me the following:

    Uncaught Error: No module: tmh.dynamicLocale angular.min.js:18 (anonymous function)angular.min.js:17 aangular.min.js:17 (anonymous function)angular.min.js:26 (anonymous function)angular.min.js:6 nangular.min.js:25 eangular.min.js:26 (anonymous function)angular.min.js:6 nangular.min.js:25 eangular.min.js:30 ybangular.min.js:16 cangular.min.js:16 xbApplication?umb__rnd=ffffffff9bc63187:39 (anonymous function)jquery-2.0.3.min.js:4 ljquery-2.0.3.min.js:4 c.fireWithjquery-2.0.3.min.js:4 x.extend.readyjquery-2.0.3.min.js:4 S

  • Jan Skovgaard 10938 posts 21806 karma points MVP 4x admin c-trib
    Dec 11, 2014 @ 11:23
    Jan Skovgaard
    0

    Hi Peter

    What steps did you take in order to do your upgrade?

    Are you making use of any 3rd party packages? Any cusotmization of the backend? Etc.

    And did you clear the Umbraco cache after the upgrade was done? Otherwise go to /App_data/TEMP/ClientDependency and delete all files in here and then go to /config/ClientDependency.config and increment the version attribute and finally recycle the app pool.

    /Jan

  • Peter S 169 posts 587 karma points
    Dec 11, 2014 @ 11:33
    Peter S
    0

    I followed the general update notes. I use SEO Checker and it worked fine for the few couple of minutes that the backend acutally worked, before breaking. BTW, it did re-enter the installer once before breaking. I also ran the installer since it was my only option. The Temp-folder has been cleared a few times and the ClientDependency.config value has been altered as well. Still nothing.

    The front-end has a couple of seconds reload time after recycling, as expected, but the backend reloads instantly displaying the same error message in the console.

  • Jan Skovgaard 10938 posts 21806 karma points MVP 4x admin c-trib
    Dec 11, 2014 @ 11:40
    Jan Skovgaard
    0

    Hi Peter

    That's really weird - Does it act the same in other browsers as well?

    I don't suppose there is any addition to the above error to be found in the /App_Data/logs file?

    /Jan

  • Peter S 169 posts 587 karma points
    Dec 11, 2014 @ 11:50
    Peter S
    0

    Yes, the same in all browsers.

    Sorry, no logging from the backend.

  • Jan Skovgaard 10938 posts 21806 karma points MVP 4x admin c-trib
    Dec 11, 2014 @ 11:56
    Jan Skovgaard
    0

    Hi Peter

    That's really really odd...are you doing the upgrade manually or using nuget?

    /Jan

  • Peter S 169 posts 587 karma points
    Dec 11, 2014 @ 12:01
    Peter S
    0

    Manually

    If I delete the log, change the ClientDependency and remove all the files in the TEMP folder this is what the log looks like after only loading the backend.

    https://dl.dropboxusercontent.com/u/20803086/UmbracoTraceLog.txt

  • Jan Skovgaard 10938 posts 21806 karma points MVP 4x admin c-trib
    Dec 11, 2014 @ 12:27
    Jan Skovgaard
    1

    Hi Peter

    Ok, so you see the upgrade screen and the umbracoConfigurationStatus is set to 7.2.0 in the web.config as well?

    Have you merged the /config/ folder files as well? At least the grid editor cropper config file is new and should be added of course - and doing a winmerge on the rest of the files is also recommended if you have not done this already.

    /Jan

  • Jason 109 posts 619 karma points
    Dec 11, 2014 @ 23:04
    Jason
    0

    I ran into this issue also. Upgrade went fine other than the issue about deep inheritance on doc types. But all of a sudden I started getting the upgrade screen if I was logged into the back office or I got a blank page with the URL showing that it was trying to authenticate so that it could do the upgrade again. If figured out that it was because I am still working in Visual Studio and when I built the solution the Nuget package manager, which was set to restore package automaticly, was replacing the new 7.2 DLL's with older umbraco DLL's. I started dev with version 7.1.8 and I did the upgrade manually since there was no Nuget package other than the one for the core DLL's yet. I ran Nuget and updated the Umbraco DLL's and the issue was resolved. Hope that helps.

  • Peter S 169 posts 587 karma points
    Dec 15, 2014 @ 08:54
    Peter S
    0

    Sorry for the delay.

    @Jan: Embarrassing as it is the web.config version still said 7.1.8. I changed it to 7.2.0 and the white page is now gone, replaced by the dark umbraco page with the U logo in the upper left corner. I now reach this no matter if I go to simplydev.com (that is my local devlopment URL) or simplydev.com/umbraco and I'm redirected to the URL below. Any idea why? It's a new dead end.

    http://simplydev.com/umbraco/AuthorizeUpgrade?redir=%2finstall%2f%3fredir%3dtrue%26url%3dhttp%253a%252f%252fsimplydev.com%252f

    @Jason: Not sure if this is the case. Which DLL's do you mean? For example, my Umbraco.Core.dll is version 1.0.5261.28127.

  • Jan Skovgaard 10938 posts 21806 karma points MVP 4x admin c-trib
    Dec 15, 2014 @ 08:58
    Jan Skovgaard
    0

    Hi Peter

    Well that's not embarrassing as it should not be necessary to do this manually it should happen during the upgrade process.

    But I suspect it might be a permission issue since it seems it's not possible for the install/upgrade process to write to the web.config at least and when you change the configurationstatus manually you don't get any further with the upgrade.

    Do you see any error logs in your browser console btw?

    /Jan

  • Peter S 169 posts 587 karma points
    Dec 15, 2014 @ 10:32
    Peter S
    1

    Same as before but without any of the details.

    Uncaught Error: No module: tmh.dynamicLocale

  • Jan Skovgaard 10938 posts 21806 karma points MVP 4x admin c-trib
    Dec 15, 2014 @ 10:39
    Jan Skovgaard
    0

    Ok, have you checked the permission settings as well?

    /Jan

  • Peter S 169 posts 587 karma points
    Dec 15, 2014 @ 10:49
    Peter S
    0

    I've double checked and IIS_IUSRS and NETWORK SERVICE have full control over the entire site folder.

  • Peter S 169 posts 587 karma points
    Dec 15, 2014 @ 11:00
    Peter S
    0

    IE gave me the location of the crash in angular.min.js, Line: 18, Column: 70

  • Peter S 169 posts 587 karma points
    Dec 15, 2014 @ 11:12
    Peter S
    0

    And since I changed the version in web.config the log now says:

    2014-12-15 11:08:48,229 [7] INFO  Umbraco.Core.ApplicationContext - [Thread 39] CurrentVersion different from configStatus: '7.1.4','7.2.0'
    2014-12-15 11:08:48,229 [7] WARN  Umbraco.Web.UmbracoModule - [Thread 39] Umbraco is not configured
    2014-12-15 11:08:48,236 [7] INFO  Umbraco.Core.ApplicationContext - [Thread 32] CurrentVersion different from configStatus: '7.1.4','7.2.0'

  • Jason 109 posts 619 karma points
    Dec 15, 2014 @ 15:50
    Jason
    0

    Peter, the black screen with the url to AuthorizeUpgrade that you provide is exactly what I was gettng. I tried that same thing and manually changed the version number in the web.config and got the same result as you. Ultimately, for me, I found that the DLL's in the bin directory where not the correct version. This was happening when I ran the site from Visual Studio. My Umbraco.Core.dll is 1.0.5451.27165, new than yours.

    Just to clarify, when you did your upgrade did you copy the entire contents of the Umbraco 7.2 bin directory from the ZIP archive to your install location for the site you were upgrading? Do you have any build process running to deploy code to the site that might be reverting DLL's in the bin?

     

    JT

  • Phil 54 posts 139 karma points
    Dec 17, 2014 @ 09:49
    Phil
    0

    All,

    I am experiencing a similar issue - when using localhost, I have no issues with the backend.

    However, after deploying to a test web server on the network, I am getting a completely white screen on the backend, and the following error message in the Chrome console:

    Uncaught Error: No module: tmh.dynamicLocale with the source being DependencyHandler.axd.

    I have upgraded from 7.1.8 to 7.2.0 recently, but experienced no issues until deploying to a test web server.

  • Jason 109 posts 619 karma points
    Dec 17, 2014 @ 18:04
    Jason
    0

    Phil, did you do a manual copy to the web server or did you do a deploy form Visual Studio (VS)? From what I experienced the behavior you are discribing is caused by the Umbraco DLL's in the bin being an older version. If you did the deploy from VS and you had installed Umbraco via Nuget originally then it is possible that the older DLL's are being restore when VS does a deploy. You might try backing up the bin directory on the web server and then coping the bin direcoty from Umbraco 7.2 ZIP archive to the server manully.

  • Joost van den Berg 3 posts 118 karma points
    Dec 17, 2014 @ 20:16
    Joost van den Berg
    0

    All,

    I am experiencing a similar issue, using the nuget upgrade all works now.

  • Phil 54 posts 139 karma points
    Dec 18, 2014 @ 09:23
    Phil
    0

    I deployed from VS, but I did a manual upgrade rather than via NUGET.

    I have attempted a manual copy to the web server, but still have the same blank backend page.

    I have also copied the bin folder directly from the 7.2.0 ZIP but again, the same blank backend page!

    Can anybody shed any light on this?

    Edit: I have redone a manual copy to the server and can access the backend as expected. Seems the issue is caused by VS deploy?

  • Vivek 3 posts 23 karma points
    Dec 18, 2014 @ 14:40
    Vivek
    0

    It was a different issue for me. The dll versions after deployment were all correct. tmhDynamicLocale.js file was present locally but not included in the project. So the absent script file caused the issue in deployed site.

  • Jason 109 posts 619 karma points
    Dec 18, 2014 @ 22:03
    Jason
    0

    Phil, I fixed my VS issues by upgrading/Install the UmbracoCore DLL's with Nuget in VS.

  • Phil 54 posts 139 karma points
    Dec 19, 2014 @ 12:39
    Phil
    0

    Jason,

    I upgraded manually rather than using Nuget - is there a way to resolve issues without nuget that you know of?

  • Peter S 169 posts 587 karma points
    Dec 19, 2014 @ 14:47
    Peter S
    0

    Again, excuse my absence. Had to attend some other issues.

    I too made a NuGet install but a manual upgrade. That could probably be causing this. I'm going to try a NuGet update during the holidays. The problem doing this earlier for me has been that we use a newer version of MySQL and the NuGet upgrade thinks that's a big no-no. I'll have to downgrade it at first.

  • Phil 54 posts 139 karma points
    Dec 19, 2014 @ 15:12
    Phil
    2

    I'm hanging my head in shame - as Vivek stated earlier, the following file was not included in the VS project:

    Umbraco/lib/angular/tmhDynamicLocale.js

    After including and publishing, the blank backend issue was fixed.

  • Jason 109 posts 619 karma points
    Dec 19, 2014 @ 23:48
    Jason
    0

    Peter, try turning off automatic package restore and that should stop Nuget from reverting the DLL's during the build. You will need to copy the DLL's again if you have not already done that. Of couse this all assumes that Umbraco was added using Nuget to begin with. Might want to also double chech that you are not missing Umbraco/lib/angular/tmhDynamicLocale.js in your project and file system.

    Here is how to disable the restore stuff: http://docs.nuget.org/docs/reference/package-restore#Opting_Out

  • philw 99 posts 433 karma points
    Jan 24, 2015 @ 13:50
    philw
    0

    I just had this issue, but in my case in an upgrade from 7.1.3 (?) -> 7.2.1. My cause was the case-sensitivity of Rackspace Cloud file system - the directory cases in the distrubution change randomly (so you have Lib and lib), and this means that the standard "copy these files over those files" upgrade fails. 

    For me the only way to do this then is to upgrade on a test server (I do this anyway) and then delete the target deployment directories, then replace them with copies of the new directories (however capitalized) from the test server.

    The upgrade instructions do mention Rackspace Cloud's honoring of case sensitivity in file names. I will just put this here in case it hits anyone else. And perhaps it would be wise just from a professional perspective to adopt a single consistent naming convention for these things, and then don't change it every release. Just sayin.

     

    Looks like it's the file /Umbraco/Lib/angular/tmhDynamicLocale.js

    I have file permissions 777 set on that. Is the C# trying to read this file? I'm on Rackspace Cloud here, maybe that is the issue.

  • philw 99 posts 433 karma points
    Jan 24, 2015 @ 14:24
    philw
    0

    Hmm, well I took out all the updated directories from the install on the target server, getting rid of "Lib" and the parallel "lib" , as I could not tell which was which. Then I re-deployed from test -> live, just the directories and files which changed in this upgrade. So that should work....

    ... same error.

     

    Maybe it's file permissions - I'll try setting them all to "777" and see if that works. I can't see any 404 errors in the client network monitor though, so it's not like it's trying to pull some file and not getting it. Who needs permission for what, I wonder?

    Update: I got Rackspace to change all the permissions, bounced it to clear the cache, and now it works. So it looks like my issue was case-sensitive directory names and then file permissions. 

  • Pawel Bres 33 posts 144 karma points c-trib
    Jan 28, 2015 @ 18:47
    Pawel Bres
    0

    Hi everyone, same here, I've blank backend and Uncaught Error: No module: tmh.dynamicLocale in console.

    What is strange that I had <add key="umbracoConfigurationStatus" value="7.2.1" /> in my web.config and after "upgrade" I have <add key="umbracoConfigurationStatus" value="7.1.8" />

    Any ideas ?

  • Jason 109 posts 619 karma points
    Jan 28, 2015 @ 21:20
    Jason
    0

    Pawel:

    Did you do the upgrade manually or with nuget (via visual studio)? If you are upgrading manually and then building via visual studio it is possible the nuget package restore is reverting the Umbraco dll's back to 7.1.8. Try upgrading the dll's wiht nuget for the project. Remember to back stuff up first.

    JT

  • Pawel Bres 33 posts 144 karma points c-trib
    Jan 29, 2015 @ 07:28
    Pawel Bres
    0

    Thanks for reply Jason,

    It seems that was some kind of nuget automatic update. I replaced files in bin folder with files from clean umbraco 7.2.1 and it helps. I also turned off automatic nuget packages restore, but the same situation happened once again. Replacing the files helped again but I'm wondering is there any way to prevent this in future.

    Pawel

  • Jason 109 posts 619 karma points
    Jan 29, 2015 @ 23:10
    Jason
    0

    You could try and upgrading the NuGet Umbraco DLL package for your project. NuGet may still be restoring the DLL's to the older version even though auto restore is tured off.

     

    JT

  • Mark 255 posts 610 karma points
    Mar 17, 2015 @ 18:27
    Mark
    0

    I've gone through the manual upgrade process from 7.1.4 to 7.2.1 and I'm getting a 404 error. Requested URL: /umbraco/LocalizedText. It's causing the Save & Publish button to appear without any text.

  • Stephen Davidson 216 posts 391 karma points
    Mar 31, 2015 @ 23:13
    Stephen Davidson
    0

    I am having the same issue as everyone here...upgraded via Nuget from 7.2.2 to 7.2.4 and get the blank backen/corrupted URL.

    I have the missing angular file in the VS project but keep getting the JS error when running locally??

    Did anyone manage to solve this?

    S

     

     

     

  • Mark 255 posts 610 karma points
    Apr 01, 2015 @ 10:46
    Mark
    0

    I cleared web browser cache and also cleared Umbraco cache (cause app pool recycle and bump client dependencyversion). Worked for me, but that was on 7.2.1 to 7.2.2 upgrade

  • Denford 88 posts 172 karma points
    Feb 10, 2018 @ 13:15
    Denford
    0

    Anyone else who might run into this, in my case back-end works fine locally but not on the server upgraded from 7.3.4 to 7.8.1 and was getting the back-end white screen with an error "SCRIPT5022: No module: ngFileUpload" from the dependencyhandler.axd file and so far the only fix that seems to work is having the debug set to true on the server if i set if off back-end goes back to white screen no clue why though :(

  • Aleksander 22 posts 141 karma points
    Apr 13, 2018 @ 09:47
    Aleksander
    0

    I'm getting this issue after deploying via TeamCity and Octopus to our local dev server. This is a solution upgraded from 7.2.2 to 7.9.2,

    Uncaught Error: No module: tmh.dynamicLocale
    

    But the module is clearly in the folder.. I'm abit of a loss of what to do. Any suggestions? Tried to set full permissions in IIS, for IIS_IUSRS and NETWORK SERVICE, if i've done it correctly that is... i'm abit of a IIS rookie.

    Apparently its when i deploy with TC and octopus. hmm

  • Denford 88 posts 172 karma points
    Apr 15, 2018 @ 22:22
    Denford
    0

    Try and delete the module from the server manually then deploy it again, noticed sometimes references an older module or dll and that might need re-deploying with the current 1.

Please Sign in or register to post replies

Write your reply to:

Draft