Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • shinsuke nakayama 109 posts 250 karma points
    Jan 07, 2015 @ 05:59
    shinsuke nakayama
    0

    Umbraco 7.1.6 + contour Upgrade to 7.2.1, Umbraco Form not working

    Hi guys,

    I just upgraded my "Umbraco 7.1.6 + contour" to "Umbraco 7.2.1". I manage to update successfully but now i have an issue with the forms.

    My understanding is that in 7.2.1 and Contour no longer work and we have to use Umbraco Form.

    So I went to the back office and went to the forms section and installed the Umbraco Forms.

    On the screen it says

    "installing... restarting, please hold" and get following error message

    Could not load type 'Umbraco.Forms.Core.Services.RecordService' from assembly 'Umbraco.Forms.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=null'.

    and now when i refresh (doesn't matter where i am), i get a same error message. I rolled back and tried 4 times, didn't work.

    Instead of installing Umbraco Form, i also tried "Umbraco forms migration"

    http://our.umbraco.org/projects/developer-tools/umbraco-forms-migration

    But this didn't work either.

    Any idea?

    Thank you

  • shinsuke nakayama 109 posts 250 karma points
    Jan 07, 2015 @ 06:28
    shinsuke nakayama
    100

    Okay i manage to work this out. After installing Umbraco 7.2.1, you HAVE to uninstall Contour, then you can install Umbraco Forms.

  • Dennis Aaen 4470 posts 18049 karma points admin hq c-trib
    Jan 07, 2015 @ 08:28
    Dennis Aaen
    0

    Hi shinsuke,

    Great to hear that you got this solved. :-)

    But next time you need to upgrade an Umbraco installation to e.g 7.2.1 that has the Contour package installed too, then you should have a look at the Umbraco Forms Migration package from Tim Geyssens http://our.umbraco.org/projects/developer-tools/umbraco-forms-migration

    /Dennis

  • shinsuke nakayama 109 posts 250 karma points
    Jan 08, 2015 @ 00:09
    shinsuke nakayama
    0

    Hi Dennis,

    Thank you for your reply, I used nuget to upgrade my project, so i didn't know about the Umbraco Upgrade that has Contour Package installed. Do you mind sending me a link? I've got few other project i need to upgrade.

    Also for people who's having this issue, you can find reference here

    http://our.umbraco.org/projects/developer-tools/umbraco-forms-migration/computer-says-no/59800-Steps-to-use

    1. Duplicate DB
    2. On the website Umbraco, remove Contour v3
    3. On the website Umbraco, install Umbraco Forms v4
    4. Install Umbraco Froms Migration Tool
    5. Connect migration tool to duplicated database
    6. Delete duplciate DB

    Good Luck :)

    Shinsuke

  • James 7 posts 28 karma points
    Aug 11, 2015 @ 13:05
    James
    0

    I am getting an error when I try using the tool as well:

    Oops something whent wrong

    UMBRACO EXCEPTION (DATALAYER): SQL HELPER EXCEPTION IN EXECUTEREADER

    at umbraco.DataLayer.SqlHelper`1.ExecuteReader(String commandText, IParameter[] parameters) at Umbraco.Forms.Migration.Data.Storage.FormStorage.GetAllForms(Boolean archived) in c:\Users\timgeyssens\Documents\Visual Studio 2013\Projects\Umbraco.Forms.Migration\Umbraco.Forms.Migration\Contour\Data\FormStorage\FormStorage.cs:line 45 at Umbraco.Forms.Migration.MigrationService.Migrate(String connString) in c:\Users\timgeyssens\Documents\Visual Studio 2013\Projects\Umbraco.Forms.Migration\Umbraco.Forms.Migration\MigrationService.cs:line 26 at Umbraco.Forms.Migration.ContourToForms.Button1_Click(Object sender, EventArgs e) in c:\Users\timgeyssens\Documents\Visual Studio 2013\Projects\Umbraco.Forms.Migration\Umbraco.Forms.Migration\ContourToForms.ascx.cs:line 23

Please Sign in or register to post replies

Write your reply to:

Draft