Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Frank Neitzel 5 posts 26 karma points
    Jan 27, 2015 @ 15:51
    Frank Neitzel
    0

    405 (Method Not Allowed) when login attempt

    Hi,

    I'm new to Umbraco.

    I create a new clean Umbraco setup in VS 2013. Create a new sql 2008 r2 db.

    Run it. Configure it with the sql-server. All fine.

    Now publish to a dev-web server. Result: cant login to Umbraco. Error:
    Login failed for user xxxx

    Failed to load resource: the server responded with a status of 405 (Method Not Allowed)

    When running localy (F5) alle works fine.
    I have several db's on the sql-server that all can be accessed - all but Umbraco works fine.

    How can this be?

    BR
    Frank N.

  • Dennis Aaen 4457 posts 17969 karma points admin hq c-trib
    Jan 27, 2015 @ 15:58
    Dennis Aaen
    0

    Hi Frank and welcome to our.

    Perhaps you can try to add the code from this http://our.umbraco.org/forum/getting-started/installing-umbraco/46548-U7-HTTP-405-Error-when-attempting-to-delete-backoffice-content thread to your webconfig and see if it solve it.

    Or try to go to /App_Data/Logs, and see if the log file can give you some more information about why you canĀ“t login to Umbraco backoffice.

    Hope this helps,

    /Dennis

  • Frank Neitzel 5 posts 26 karma points
    Jan 28, 2015 @ 08:57
    Frank Neitzel
    0

    Hi Dennis, Thanks for the reply, but remove webdav from the web-config didn't help.

    I've had a look the log - and here's what I get (the last linies)

    2015-01-28 08:53:58,730 [24] INFO  umbraco.BusinessLogic.Log - [Thread 12] Log scrubbed.  Removed all items older than 2014-11-29 08:53:58

    2015-01-28 08:53:59,293 [24] ERROR Umbraco.Web.Scheduling.ScheduledPublishing - [Thread 7] An error occurred with the scheduled publishing

    System.Net.WebException: The remote server returned an error: (404) Not Found.

       at System.Net.WebClient.UploadDataInternal(Uri address, String method, Byte[] data, WebRequest& request)

       at System.Net.WebClient.UploadString(Uri address, String method, String data)

       at Umbraco.Web.Scheduling.ScheduledPublishing.Run()

    2015-01-28 08:54:58,670 [24] ERROR Umbraco.Web.Scheduling.ScheduledPublishing - [Thread 22] An error occurred with the scheduled publishing

    System.Net.WebException: The remote server returned an error: (404) Not Found.

       at System.Net.WebClient.UploadDataInternal(Uri address, String method, Byte[] data, WebRequest& request)

       at System.Net.WebClient.UploadString(Uri address, String method, String data)

       at Umbraco.Web.Scheduling.ScheduledPublishing.Run()

     

    BR Frank
  • Dennis Aaen 4457 posts 17969 karma points admin hq c-trib
    Jan 28, 2015 @ 09:09
    Dennis Aaen
    0

    Hi Frank,

    You said that you publish it to a dev server. Did you install your copy the database  on your dev-server and setup a user and password for the SQL server. And change the connection string in the web config file, so it point on the database on your dev environment.

    Hope this helps,

    /Dennis

  • Frank Neitzel 5 posts 26 karma points
    Jan 28, 2015 @ 09:28
    Frank Neitzel
    0

    Hi Dennis,

    Yes I did. I'm sure the connection string is ok. (using the sa user)

    I can login/connect fine from my local machine (F5) - but when I publish to the dev server, I cant login.

    I'm using the same dedicated SQL-seerver in both cases. (SQL server 2008 R2)

    Something about Umbraco my IIS dosn't like?

    Running Win 2008 R2 server standard.

    /Frank

  • Dennis Aaen 4457 posts 17969 karma points admin hq c-trib
    Jan 28, 2015 @ 09:37
    Dennis Aaen
    0

    Hi Frank,

    Perhaps it could be a IIS thing, maybe a permission issue. http://our.umbraco.org/wiki/reference/files-and-folders/permissions These permissions should be set before or during the insallation of umbraco. The user with the permissions set are the user used by the Application Pool used by the IIS website (usually Network Service or the IIS_IUSRS group). If in doubt, ask your server admin /

    Hope this helps, else I am empty for ideas of what i could be. Since you can login on your local machine there must be some difference in your dev environment

    /Dennis

  • Frank Neitzel 5 posts 26 karma points
    Jan 28, 2015 @ 13:24
    Frank Neitzel
    0

    When I look at the console, at the login page, I see the 405 error, and when I follow the resource link, I get this error:

    ------------------------------------
    )]}',

     

    {"Message":"The requested resource does not support http method 'GET'."}
     

    How can I enable GET?

    /Frank

  • Dennis Aaen 4457 posts 17969 karma points admin hq c-trib
    Jan 28, 2015 @ 13:34
    Dennis Aaen
    0

    Hi Frank.

    I was thinking if it could be the user that has been locked out of Umbraco backoffice. You have access to the database, then try find the umbracoUser table, in there you please check that value in the column called UserNoConsole is set to false for the user that you are trying to login with. If not that try to change it from true to false and then see if you can login.

    Hope this helps,

    /Dennis

     

  • Frank Neitzel 5 posts 26 karma points
    Jan 28, 2015 @ 15:23
    Frank Neitzel
    1

    Hi again,

    OK, there I fixet i myself... as usual :-)
    The thing was, I have an IIS lowercase rule, that Umbraco didnt like.

    Here's the problem and the solution:
    http://www.wiliam.com.au/wiliam-blog/iis-url-redirects-to-lowercase-and-umbraco-cms

    Thanks anyway for your help Dennis :)

    /Frank 

     

  • andy 22 posts 91 karma points c-trib
    Jan 05, 2021 @ 14:57
    andy
    0

    Those two exclusions fixed the issue for me also, thanks :)

Please Sign in or register to post replies

Write your reply to:

Draft