Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Stephen Davidson 216 posts 392 karma points
    Apr 01, 2015 @ 00:32
    Stephen Davidson
    0

    No module: tmh.dynamicLocale

    After a recent upgrade from 7.2.2 to 7.2.4 (via Nuget) I am getting the following screen and error when running straight from VS. I have tried clearing my cache in Chrome but still get this error. After about 3 hours trying to sort I'm open to suggestion :-)

    I have confirmed the file is there and included in the project.

  • Jan Skovgaard 11264 posts 23594 karma points MVP 9x admin c-trib
    Apr 01, 2015 @ 05:11
    Jan Skovgaard
    0

    Hi Stephen

    Have you also tried increasing the version number in the /config/ClientDependencyConfig.config file and then recycling the app pool? This is busting the backoffice cache and usually that helps.

    Otherwise I think you should try downloading the zipped version of Umbraco 7.2.4 and then copy over /umbraco, /umbraco_client and /bin folders to make sure no files are missing for some weird reason - Not sure why but have seen other people have issues after doing a nuget upgrade where copying over the files manually has worked.

    Hope this helps.

    /Jan

  • Stephen Davidson 216 posts 392 karma points
    Apr 01, 2015 @ 09:18
    Stephen Davidson
    0

    Thanks for the reply..

    Tried increasing the version number...no luck.

    Tried downloading 7.2.4 and copying over the relavent folders...still the same. Driving me nuts.

    Could it be anything to do with being under source control? (TFS online)

  • Dennis Aaen 4495 posts 18201 karma points admin hq c-trib
    Apr 01, 2015 @ 09:32
    Dennis Aaen
    0

    Hi Stephen,

    There is a thread here where some people are experience the same thing as you do with the No module: tmh.dynamicLocale, maybe you could try some of their suggestions. https://our.umbraco.org/forum/umbraco-7/using-umbraco-7/59694-Backend-error-after-72-upgrade?p=1

    Hope this helps,

    /Dennis

  • Jan Skovgaard 11264 posts 23594 karma points MVP 9x admin c-trib
    Apr 01, 2015 @ 09:51
    Jan Skovgaard
    0

    Hi Stephen

    Hmm, not sure it's a source control issue unless someone other than you did the upgrade and after pulling the latest changes for the repo you see this error.

    But since you done the upgrade on your local instance I think that it should simply just work.

    I'm a bit puzzled about the fact that doing the manual approach did not work either though...

    Could you try rebuilding the examine indexes? It's a long shot but worth trying I think.

    /Jan

  • Stephen Davidson 216 posts 392 karma points
    Apr 01, 2015 @ 10:11
    Stephen Davidson
    0

    I should point out that i was a sensible lad and I have a backup before the upgrade which is working perfect but now I'm just detrmined to find out what the issue is!

    @Dennis - Yes I read through that thread and tried all the suggestions there...no luck

    I feel like the upgrade did not work properly and that I need to run through it again, is there a way to go back to 7.2.2 and run it again?

    I'm also wondering if there is a permission issue...I have some issues when manually setting the permission on the network user...error say i dont have access/permission to set persmission on sub folders...i thought that might be to do with the Source control.

    S

  • Jan Skovgaard 11264 posts 23594 karma points MVP 9x admin c-trib
    Apr 01, 2015 @ 10:19
    Jan Skovgaard
    0

    Hi Stephen

    It could perhaps be a permission issue - Don't know if you can try giving the everyone role full access and then do the upgrade once again? (Of course you'll need to revoke permissions for the everyone role afterwards - But just for testing if it's permission related).

    I have not tried doing downgrades so can't advice on that one - But I'm thinking that you should be able to just restore your backup and then try again?

    /Jan

Please Sign in or register to post replies

Write your reply to:

Draft