Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Nathan Woulfe 376 posts 1418 karma points MVP 2x c-trib
    May 21, 2015 @ 05:44
    Nathan Woulfe
    0

    Issues post upgrade 7.1.4 -> 7.2.5

    I've just run a nuget update on a 7.1.4 site, which all ran beautifully smoothly. Like butter.

    But... I can log in to the backoffice, content tree renders nicely, everything is as it should be. Except when I try to publish a node - I get JS errors:

    POST /umbraco/backoffice/UmbracoApi/Content/PostSave 500 (Internal Server Error)
    @ angular.min.js:106 
    @ angular.min.js:102
    @ angular.min.js:100j.promise.then.i 
    @ angular.min.js:79(anonymous function) 
    @ angular.min.js:80$get.e.$eval 
    @ angular.min.js:92$get.e.$digest
    @ angular.min.js:90$get.e.$apply 
    @ angular.min.js:92(anonymous function) 
    @ angular-mobile.js:269x.event.dispatch 
    @ jquery.min.js:5x.event.add.y.handle 
    @ jquery.min.js:5
    
    angular.min.js:63 TypeError: data.indexOf is not a function
            at umbraco.services.js:6876
            at umbraco.services.js:6957
            at angular.min.js:100
            at j.promise.then.o (angular.min.js:80)
            at angular.min.js:81
            at Object.$get.e.$eval (angular.min.js:92)
            at Object.$get.e.$digest (angular.min.js:90)
            at Object.$get.e.$apply (angular.min.js:92)
            at j (angular.min.js:101)
            at r (angular.min.js:104)
    

    There's also a minor issue where no content displays on the front end, but given the backoffice renders fine, I don't think it will be anything substantial. Permissions all look fine, have double checked *.config files, can't see anything obvious in there either...

    Any suggestions as to where I should be looking for a solution?

  • Jan Skovgaard 11244 posts 23439 karma points MVP 6x admin c-trib
    May 21, 2015 @ 06:46
    Jan Skovgaard
    0

    Hi Nathan

    How did you do the upgrade? Was it manually or using nuget? Did you clear the browser cache and bump the backoffice cache as well after the upgrade?

    /Jan

  • Nathan Woulfe 376 posts 1418 karma points MVP 2x c-trib
    May 21, 2015 @ 06:53
    Nathan Woulfe
    0

    Hi Jan

    Upgraded via nuget. Dumped browser cache, deleted umbraco.config to trigger a rebuild of the xml cache, neither helped.

    I'm rolling back to 7.1.4 now, once that's done will try again to see if I missed anything.

    cheers N

  • Sebastiaan Janssen 4851 posts 14450 karma points MVP admin hq
    May 21, 2015 @ 07:23
    Sebastiaan Janssen
    0

    Tour database didn't upgrade. I suspect you altered the umbraco version in web.co fig yourself? After the NuGet update always just run the site and click through the upgrade installer on each environment, never update the version in Web.config manually.

  • Nathan Woulfe 376 posts 1418 karma points MVP 2x c-trib
    May 21, 2015 @ 07:48
    Nathan Woulfe
    0

    Nope, installer ran correctly and made the version changes automagically. I'll keep digging, can't be anything too serious I don't think.

  • Sebastiaan Janssen 4851 posts 14450 karma points MVP admin hq
    May 21, 2015 @ 07:59
    Sebastiaan Janssen
    0

    Ah sorry, I see it's js errors.. not the database then, sorry I didn't read properly!

    Try a different browser or private browser window, make sure all files are copied into your /umbraco folder (winmerge and beyondcompare can compare folders, unzip a regular download of 7.2.5 and compare it to your site.

  • Nathan Woulfe 376 posts 1418 karma points MVP 2x c-trib
    May 21, 2015 @ 08:04
    Nathan Woulfe
    0

    Yeah, that was going to be the next attempt - rollback to 7.1.4 and do the upgrade manually.

  • Sebastiaan Janssen 4851 posts 14450 karma points MVP admin hq
    May 21, 2015 @ 08:35
    Sebastiaan Janssen
    0

    You can't mix & match with NuGet updates though, you HAVE to do them through NuGet else you will get weird results (possibly like this one).

  • Adam Southorn 11 posts 31 karma points
    Jun 01, 2015 @ 13:19
    Adam Southorn
    0

    Did you manage to fix this? This exact error has started randomly occuring for me (haven't upgraded, haven't fiddled with any back office files etc). Am just creating a simple front end gallery, then this morning I started getting those errors when saving in the content section.

    The content still saves, but the publish button doesn't revert from being disabled so I have to refresh to make another change. Umbraco 7.2.5 with no changes to bug,config,umbraco files.

     

  • Sebastiaan Janssen 4851 posts 14450 karma points MVP admin hq
    Jun 01, 2015 @ 15:37
    Sebastiaan Janssen
    0

    @Adam can you set debug to true in your web config, try again and then click on that 500 error to see what the actual problem is? You should get a slightly more detailed error message back.

  • Nathan Woulfe 376 posts 1418 karma points MVP 2x c-trib
    Jun 02, 2015 @ 00:22
    Nathan Woulfe
    0

    Adam, I was in the fortunate position of being able to delete the site and pull a new copy from source control, so didn't spend any real time investigating the issue. Still have the 7.1.4 -> 7.2.5 upgrade on the books, so will probably end up digging into this in the near future.

  • Adam Southorn 11 posts 31 karma points
    Jun 02, 2015 @ 11:33
    Adam Southorn
    0

    With debugging enabled, I get the following (Seems to be failing at v.send):

    console log angular file

    Not an angular expert so struggling to follow the source of the problem. I've tried resetting cache, clearing temp files etc just in case but no luck.

    Nothing being flagged in Vis Studio as I assume like you said before it's just js errors.

  • Adam Southorn 11 posts 31 karma points
    Jun 02, 2015 @ 12:04
    Adam Southorn
    0

    I have uploaded it to a test AWS server and it works fine now?!

    Strange, as other Umbraco 4/6/7 installs have always saved fine for me locally with the same security permissions, in the same location etc.

    Any ideas?

  • jake williamson 152 posts 635 karma points
    Jun 09, 2015 @ 15:04
    jake williamson
    0

    chaps, just ran into this exact problem after running the 'mysql for visual studio' installer on my machine!

    https://www.mysql.com/why-mysql/windows/visualstudio/

    caused a bit of head scratching as the error didn't point at anything mysql related until i tried to save a non content node, then a mysql error showed up in the console before disapearing and showing the error you've described.

    so i'm in a weird trade off now of being able to save nodes in umbraco but not being able to do what i initially set out to do with a mysql database.

    but you never know, this may help someone!

    cheers,

    jake

  • Adam Southorn 11 posts 31 karma points
    Jun 10, 2015 @ 19:22
    Adam Southorn
    0

    Interesting, I had just installed mysql the day before my error occurred. I hadn't thought about that though as I use sql server for all Umbraco related projects. Seems like it must be mysql related; I'll keep an eye on it.

  • jake williamson 152 posts 635 karma points
    Jun 11, 2015 @ 08:34
    jake williamson
    3

    it seems that the mysql installer changes values at the machine level web.config.

    we actually found the solution via this post on the forum:

    https://our.umbraco.org/forum/umbraco-7/using-umbraco-7/57929-MySQL-Connection-error-for-site-that-doesnt-Use-MySQL

    adding this to your site web.config appears to fix it:

    <siteMap>
      <providers>
        <remove name="MySqlSiteMapProvider" />
      </providers>
    </siteMap>
    

    a bit of a pain, we lost hours on this...

    hope that helps!

    cheers,

    jake

  • jake williamson 152 posts 635 karma points
    Jun 11, 2015 @ 09:05
    jake williamson
    0

    damn it! i'm now having to apply this fix to EVERY SINGLE SITE i run on my machine ;(

    far out mysql, you've really done me over this time - killed 4 hours getting this working...

  • Mike Chadwick 18 posts 85 karma points
    Jun 23, 2015 @ 14:20
    Mike Chadwick
    1

    @Jake Williamson - your solution worked. Been on this all day. :-) Nice one, thanks.

Please Sign in or register to post replies

Write your reply to:

Draft