Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Amir Khan 1274 posts 2707 karma points
    Sep 14, 2015 @ 20:42
    Amir Khan
    0

    Set Default Language

    Hi,

    I have two languages setup in the hostnames for a site like follows:

    Domain: domain.com/en Language: en

    Domain: domain.com/es Language: es

    When I go to the front end of the site, the nav by default picks the es version and directs people there. Any idea why? I've tried switching the order of the domains but still the same result.

    Thanks!

    Amir

  • Comment author was deleted

    Sep 15, 2015 @ 11:35

    is your es site the first in the content tree? try sorting the content tree if you want to en site to appear first.

  • Amir Khan 1274 posts 2707 karma points
    Sep 15, 2015 @ 13:44
    Amir Khan
    0

    Hi Tim, its actually 1:1 using Vorto so all of the content is in 1 "site", both domains are set on 1 node. I'm just not sure how Umbraco decides which URL to pick first?

    Thanks!

    Amir

  • Comment author was deleted

    Sep 15, 2015 @ 14:21

    Hmm not sure then haven't used vorto yet, did you restart the app after changing the order of the cultures?

  • Amir Khan 1274 posts 2707 karma points
    Sep 15, 2015 @ 15:50
    Amir Khan
    0

    Yep, I restarted the app. Just for clarity, is it the first domain that takes precedence or the last one added? Would be fantastic if there was a "primary" checkbox or something.

  • Comment author was deleted

    Sep 15, 2015 @ 15:53

    I would say the top one in the list takes precedent but would try both to see what happens.

  • Amir Khan 1274 posts 2707 karma points
    Sep 28, 2015 @ 17:30
    Amir Khan
    0

    Oddly, it doesn't matter which one I put first, it seems to be "stuck" on the Spanish one for some reason. Is it possible that its related to which order they were added to the languages are in the settings section? I can't figure out how to make it default to English!

  • David Gregory 76 posts 202 karma points
    Dec 04, 2015 @ 17:02
    David Gregory
    0

    Hi

    I am having the exact same problem. Did you ever get a fix for this?

  • Amir Khan 1274 posts 2707 karma points
    Dec 04, 2015 @ 17:07
    Amir Khan
    0

    Nope! Its like the 1st language get's "stuck" in last place no matter what.

  • David Gregory 76 posts 202 karma points
    Dec 09, 2015 @ 17:40
    David Gregory
    0

    Amir, I just tried right clicking on the home node, going to culture and hostnames and then changing Culture from inherit to en, which I want as my default lang.

    At first glance this seems to have worked.

  • Rihab 104 posts 388 karma points
    Sep 18, 2018 @ 12:33
    Rihab
    0

    Hi

    I am having the exact same problem. Did you ever get a fix for this?

  • Amir Khan 1274 posts 2707 karma points
    Sep 18, 2018 @ 14:13
    Amir Khan
    1

    I could never "properly" get past that issue with the version I was using so we ended up doing a redirect like this.

    <add name="siteEnglish"
                virtualUrl="^~/$"
                rewriteUrlParameter="ExcludeFromClientQueryString"
                destinationUrl="~/en"
                redirect="Application"
                redirectMode="Permanent"
                ignoreCase="true" />
    
  • Alex Skrypnyk (skrypnyk.dev) 6064 posts 23316 karma points MVP 6x admin c-trib
    Jan 07, 2020 @ 00:14
    Alex Skrypnyk (skrypnyk.dev)
    0

    Hi,

    Maybe somebody has a solution to this topic?

    Thanks, Alex

  • Jeroen Oostwouder 76 posts 192 karma points
    Mar 22, 2022 @ 09:48
    Jeroen Oostwouder
    0

    2022, still no fix I guess.

    I've got the following:

    Homepage (domain.nl/ - NL | domain.nl/en - EN)
        -subpage
        -subpage
        -subpage (support.domain.nl - NL | support.domain.nl/en - EN)
    

    As soon as I go to support.domain.nl, all URL's on the page are /en

    It defaults to the english variant. No matter if I change the order in the cultures&hostnames on the homepage, or change de default culture to inherit, of NL.

Please Sign in or register to post replies

Write your reply to:

Draft