Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Tomasz 22 posts 95 karma points
    Jan 05, 2016 @ 03:58
    Tomasz
    0

    Umbraco as Application inside website

    Hi, I wasn't able to find ANYthing useful on the forum, hopefully not a duplicate.

    I have a site, all developed localhost in VS2015, clean install of Umbraco 7.3.0.

    This has been deployed to dev server (using the same DB as localhost) at lets say "website.com". At a later stage, requirement changed, and the whole site including umbraco needed to be moved under "website.com/blah".

    I just noticed an issue, bad habbits of working in VS all the time, that I can't browse to ANY templates inside the CMS. The dev server has nothing under the root of the site (original location of deployment) and has now "blah" converted to an application (.Net 4.0, IIS 8 / Win Server 2012) and all the files deployed there.

    Browsing in the CMS to the templates and clicking a template gives:

    The resource cannot be found.

    Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

    Requested URL: /umbraco/settings/Views/EditView.aspx

    This all came up, when I had another piece of work I just started, and decided I'll setup the application on my local IIS 10 / Win 10, I have only 1 site, root contains "blah" with files deployed from VS.

    The issue here is that I installed a plugin (Spectrum Color Picker) from the repo, while I was running it via VS (worked fine), but when deployed to my local IIS I am getting multiple /blah/DependencyHanldler.axd errors with the last one being a 404 to the /AppPlugins/... (I am pretty sure all the other errors are due to not being able to get to the JS of the plugin in at /AppPlugins/... as the site sits at /blah/... ).

    Thoughts?

    Btw, for my own amusement I tried to install the plugin on prod (obviously different DB, different server, etc) and I can't even see the Spectrum Color Picker in the Data Types selection.

  • Tomasz 22 posts 95 karma points
    Jan 05, 2016 @ 20:10
    Tomasz
    0

    To add even more to this. Setup a DB on my local SQL and updated connection string to point to that, grabbed a database backup before I attempted to install the plugin, tried installing the plugin on the local/blah/umbraco and noticed that this didn't show the new plugin in the Data Type creation area, also inside the blah IIS folder, a /blah/App_Plugins was created at the time of install... and my plugin is sitting there...

  • Tomasz 22 posts 95 karma points
    Jan 05, 2016 @ 21:41
Please Sign in or register to post replies

Write your reply to:

Draft