Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Dan Roddis 57 posts 240 karma points
    Jan 06, 2016 @ 10:03
    Dan Roddis
    0

    Persistant 417 Missing Token Error

    Hi all,

    Since yesterday myself and our editor team are all experiencing an intermittent 417 missing token error in the back office.

    We're running Umbraco 7.3.4

    We've followed the advice to logout, clear all cookies, cache and local storage and log back in which seems to restore functionality for a while and then we're seeing the issue return.

    I've cleared the App_Data directory and tried cycling the app instance (we're hosted on Azure) but nothing seems to help.

    Everyone is using Chrome although I will suggest they try a different browser in case it's related to a browser update.

    The last release / code change to this site was back in the middle of December and this issue has only started yesterday.

    I've checked the following similar threads and tried the suggestions within them to no avail:

    https://our.umbraco.org/forum/umbraco-7/using-umbraco-7/60627-417-Missing-token-in-the-backoffice

    https://our.umbraco.org/forum/umbraco-7/using-umbraco-7/73687-v734-417-missing-token-when-updating-domainculture

    https://our.umbraco.org/forum/ourumb-dev-forum/bugs/70087-umbraco-backoffice-missing-admin-panel

    Does anyone have any advice?

  • Dan Roddis 57 posts 240 karma points
    Jan 07, 2016 @ 11:28
    Dan Roddis
    0

    Further update: I can see this error shows when either the XSRF-TOKEN is not found in the cookie or the request header (it needs to be in both).

    I can verify the browser is sending both through the debug console and can see the cookie arriving in the IIS logs on Azure (I'm trying to work out how to view custom headers in IIS logs to confirm X-XSRF-TOKEN header is making it).

  • Dan Roddis 57 posts 240 karma points
    Jan 08, 2016 @ 09:42
    Dan Roddis
    100

    It turns out we have another site on a subdomain which was setting what I believe is an old style ASP.NET session cookie (__KBCookie__) on the main domain which seemed to be tripping up the admin panel.

    Whenever visiting that site (which we happened to be porting into Umbraco) it would cause this 417 missing token null error.

    Just in case anyone gets this problem in future - check all the cookies for something like this!

  • Daniel Reagan 19 posts 71 karma points
    Jun 13, 2017 @ 13:07
    Daniel Reagan
    0

    Umbraco 7.2.8 -- Server 2012 sp1

    removing KB4014604 fixed the issue for us

  • Thomas Seyssens 1 post 71 karma points
    May 30, 2018 @ 11:46
    Thomas Seyssens
    0

    We still have the error..

    Hi, we have an Umbraco 7.2 running live for about a year and a half. Since a week and a half it started throwing this error. We checked all the above things like the security update, the subdomeain etc.

    No luck.. Anyone else know a solution for this?

    Kind regards

  • Steve Morgan 1030 posts 3195 karma points c-trib
    Mar 08, 2019 @ 13:56
Please Sign in or register to post replies

Write your reply to:

Draft