Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Rasmus Sebulonsen 14 posts 35 karma points
    Feb 27, 2016 @ 20:12
    Rasmus Sebulonsen
    0

    Ucommerce YSOD

    Hi guys, Im trying to setup an Ucommerce site local, just to find out if it is something i would like to work with.

    My first problen I ran into was when I had installed the Ucommerce package, and hit the Ucommerce menu item i just got the YSOD in the right panel, see the picture below ..

    I am using the regular build in MSSQL server in Windows 10, so I am not using the SQL CE solution .. Any ideers why i get this YSOD?

    Ucommerce YSOD

  • Søren Spelling Lund 1796 posts 2764 karma points
    Feb 29, 2016 @ 09:20
    Søren Spelling Lund
    0

    Looks like your connection string for SQL Server contains something the data layer of uCommerce isn't happy with. Specifically "flush interval". If you remove it, you'll probably be good to go.

    You'll want to run the uCommerce installation one more after after the connection string is fixed to make sure the databases are set up properly.

    Which version of Umbraco are you installing on? The flush stuff didn't use to be part of the default connection string so it looks like something changed and we have to look into to avoid this going forward.

  • Rasmus Sebulonsen 14 posts 35 karma points
    Mar 01, 2016 @ 11:33
    Rasmus Sebulonsen
    0

    ok I made a fresh installation of Umbraco setup with a SQL Server DB, the one where you login with the "sa" user (not the CE ..).

    I deleted the "flush interval" part from the connectionstring, the grey part in the picture below: enter image description here I then installed the uCommerce package, and now I get this error: enter image description here

    Have you seen this error before?

    I am using Umbraco 7.3.4

  • Morten Skjoldager 436 posts 1492 karma points
    Mar 01, 2016 @ 12:05
    Morten Skjoldager
    0

    Hi Rasmus,

    uCommerce does not support SQL CE. You need as minimum a SQL server express to run.

  • Rasmus Sebulonsen 14 posts 35 karma points
    Mar 01, 2016 @ 12:22
    Rasmus Sebulonsen
    0

    Thanks for your reply Morten, but I actuallly tried to be very spcific about that I am NOT using the SQL CE but I AM using the ordinary SQL server (express edition) ..

    But thank you for your answer, maybe you have another suggestion?

  • Søren Spelling Lund 1796 posts 2764 karma points
    Mar 01, 2016 @ 13:27
    Søren Spelling Lund
    0

    I ran through the regular set of installation tests for Umbraco 7.4.1 we have. SQL and Azure options will not add the "Flush Interval" option to the connection string, only SQL CE will do this.

    What might have happened is that SQL CE was used to the first set up and later changed to point to full SQL Server leaving the flush interval option in the connection string.

    If this is the case your best course of action is to change the connection string to not include "Flush Interval".

    Should the site still be running on SQL CE, please make sure that you complete the move to SQL Server before proceed.

  • Rasmus Sebulonsen 14 posts 35 karma points
    Mar 03, 2016 @ 09:59
    Rasmus Sebulonsen
    0

    hmm ok thats weird .. this site has never been running on SQL CE ..

    I tried to uninstall Webmatrix and installed it again, then I made a new Umbraco site running on SQL Server Express logging in with the "sa" user, but the connectionstring still has the "Flush Interval" part .. I Deleted this part from the connectionstring and installed the uCommerce package but with the same outcome as last time, I got the "A network-related or instance-specific error ...." again as the one I posted a screendump of ..

    So I still got this YSOD .. any other ideers?

  • Rasmus Sebulonsen 14 posts 35 karma points
    Mar 03, 2016 @ 10:41
    Rasmus Sebulonsen
    0

    ok I really dont get it, looks like the connectionstring is actually pointing at a SQL CE server even though i set it up to the ordinary SQL Server Express using Webmatrix .. this is how the full connectionstring looks like (after i deleted the "Flush Interval" part ..): enter image description here I guess the providername is telling that it is pointing to a SQL CE server?

    But it has also made some databases in the SQL Server Express I can see in Microsoft SQL Server Management Studio .. : enter image description here

    Could these informations help me to a solution?

  • Alessandro Calzavara 32 posts 144 karma points c-trib
    Mar 03, 2016 @ 11:08
    Alessandro Calzavara
    0

    Manually change the connection string in the web config

    <add name="umbracoDbDSN" connectionString="Server=localhost\SQLEXPRESS;Database=YOURDB;user id=sa;password=YOURPWD" providerName="System.Data.SqlClient" />
    
  • Rasmus Sebulonsen 14 posts 35 karma points
    Mar 03, 2016 @ 13:48
    Rasmus Sebulonsen
    1

    Ok i managed to get it to work on a clean Umbraco version 7.0.2 without using Webmatrix ..... for now :)

    Thank you for your effort to help me out, very much apriciated, I guess there will be comming other problems that hopefully will be more specific .. But thanks for now :)

  • Søren Spelling Lund 1796 posts 2764 karma points
    Mar 04, 2016 @ 00:47
    Søren Spelling Lund
    0

    Awesome to hear that you got it sorted. If you have questions specific to uCommerce I recommend posting at http://eureka.ucommerce.net

Please Sign in or register to post replies

Write your reply to:

Draft