Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Roger Withnell 128 posts 613 karma points
    Mar 04, 2016 @ 17:30
    Roger Withnell

    umbracoApplicationUrl error after upgrade to 7.4.0

    Having upgraded from 7.2.8 to 7.4.0 I get the following error after building the project:

    Parser Error Message: Unrecognized attribute 'umbracoApplicationUrl'. Note that attribute names are case-sensitive.
    Source Error: 
    Line 154:  -->
    Line 155:  <web.routing trySkipIisCustomErrors="false" internalRedirectPreservesTemplate="false" disableAlternativeTemplates="false" disableFindContentByIdPath="false"
    Line 156:   umbracoApplicationUrl="">
    Line 157:  </web.routing>
    Line 158:

    What am I doing wrong?

    Your help would be much appreciated.

    Thanking you in anticipation.


  • Roger Withnell 128 posts 613 karma points
    Mar 04, 2016 @ 17:34
    Roger Withnell

    Forgot to add that I have tried various values for umbracoApplicationUrl including:

    http://localhost:12345/, http://localhost:12345/umbraco and http://localhost:12345/MyPath (using IIS Express) and similar with the local IIS.

  • Proxicode 127 posts 323 karma points
    Jul 13, 2016 @ 04:15

    Were you able to get this sorted? Seeing the same thing after upgrading 7.26 to 7.4.3

  • Roger Withnell 128 posts 613 karma points
    Jul 13, 2016 @ 09:16
    Roger Withnell

    I think my problem was because I had Google.Apis.Calendar.V3 installed on 7.2.8 before I tried to upgrade to 7.4.2.

    I removed Google.Apis.Calendar.V3 and I upgraded successfully. I then installed Google.Apis.Calendar.V3 on 7.4.2 but received different errors, which were conflict errors with several other packages.

    To resolve this I built another app to communicate with google calendars and then accessed this app from my website. This removed the need to install Google.Apis.Calendar.V3 on my Umbraco platform.

    Hope this helps.


  • MrFlo 159 posts 403 karma points
    Apr 20, 2017 @ 09:50

    I had the same kind of error (Unrecognized attribute 'disableAlternativeTemplates'. Note that attribute names are case-sensitive. Umbraco) after updating to a newer version. For me it was remove temp asp files, restart computer, clean & rebuild project and it worked again... With Microsoft you first reflex should be to restart everything before trying to investigate the problem further... :(

Please Sign in or register to post replies

Write your reply to: