Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • mmaty 99 posts 228 karma points
    Oct 23, 2018 @ 14:30
    mmaty
    0

    Getting lost in v8 tests

    Hi everyone,

    is there somebody who successfully started an Umbraco v8 build? I'd like to test the new version, but I'm not able to get it started.

    Currently it asks for the assembly "umbraco", which doesn't make sense, since "umbraco" obviously has been replaced with "Umbraco.Web".

    My steps are: checkout the branch temp-v8

    build in VS 2017

    After building I tried to run Umbraco from the directory ... src\Umbraco.Web.UI\bin

    Any insights are appreciated.

    Mirko

    EDIT: Tried with dev-v8, but with no success. Build fails with the message:

    Your project is not referencing the ".NETFramework,Version=v4.6.1" framework. Add a reference to ".NETFramework,Version=v4.6.1" in the "frameworks" section of your project.json, and then re-run NuGet restore.

    The project IS referencing .NET 4.6.1, don't know, why the error occurs.

  • mmaty 99 posts 228 karma points
    Oct 23, 2018 @ 17:03
    mmaty
    2

    If anybody is interested in testing v8, you might find the right URL to the getting started document useful:

    https://github.com/umbraco/Umbraco-CMS/blob/temp8/.github/V8_GETTING_STARTED.md

    The document mentions, that you should clone only the temp-v8 branch. You should take this advice seriously… ;-)

    So use:

    git clone --single-branch -b temp8 https://github.com/umbraco/Umbraco-CMS
    

    That helped me to get the installer running.

    Cheers Mirko

Please Sign in or register to post replies

Write your reply to:

Draft