Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • jeffrey.schoemaker@perplex.nl 285 posts 1090 karma points MVP 2x c-trib
    6 days ago
    jeffrey.schoemaker@perplex.nl
    0

    Install Umbraco v8 nightly - Build error on Umbraco.Web.UmbracoApplication

    Hi all,

    I saw Niels and Anders announcing in their new year's reception that they're opening up the v8 editor track and we could download the nightly from Our.

    I just tried to do it following the steps on https://our.umbraco.com/download/. Essentially just installing the package via NuGet.

    But if it's installed and hit build / F5, I get an build error:

    enter image description here

    Is the documentation not complete, or should I do something else?

    Kindest regards,

    Jeffrey

  • Richard Eyres 94 posts 545 karma points
    6 days ago
    Richard Eyres
    0

    I too tried it over the weekend and got exactly the same (via nuget).

  • Sebastiaan Janssen 4695 posts 13243 karma points MVP admin hq
    6 days ago
    Sebastiaan Janssen
    0

    For some reason, for some people, files don't get copied during the NuGet install. If you have more info to share as to why that would be awesome since we can't reproduce.

    Some people have been helped with the following info:

    • Use Visual Studio 2017 with the minimum version of 15.7, however, I am not sure if 15.9 is required these days, so it might be necessary to upgrade - EDIT: 15.9 is indeed required!
    • Start an new web application project with the Empty template (not MVC, not anything else, just Empty) and make sure to use .NET version 4.7.2 when creating the solution.

    Does that help at all?

  • Gary 60 posts 326 karma points
    6 days ago
    Gary
    0

    Hi Sebastian,

    FYI: i also came across this issue just now with a new install. VS 15.9 and .NET Version 4.7.2 with a blank Empty Website Project.

    Could not load type Umbraco.Web.UmbracoApplicationon first build.

    Cheers,

    Gary

    EDIT: NuGet Command

     Install-Package UmbracoCms -Pre -Source 
    https://www.myget.org/F/umbracocore/api/v3/index.json
    
  • Sebastiaan Janssen 4695 posts 13243 karma points MVP admin hq
    5 days ago
    Sebastiaan Janssen
    0

    Gary can you zip up the blank solution you created (everything EXCEPT for the packages folder) and drop it somewhere for me to download to see what might have gone wrong?

  • jeffrey.schoemaker@perplex.nl 285 posts 1090 karma points MVP 2x c-trib
    6 days ago
    jeffrey.schoemaker@perplex.nl
    0

    Hi Sebastiaan,

    when I created a new project and set the .NET version to 4.7.2 before creating the project, it worked!

    Thanks for your help! I can finally start testing :) or let my editors test...

    And maybe it is wise to extend the documentation on https://our.umbraco.com/download/ with only this trick :)

    Jeffrey

  • jeffrey.schoemaker@perplex.nl 285 posts 1090 karma points MVP 2x c-trib
    6 days ago
    jeffrey.schoemaker@perplex.nl
    0

    @Sebastiaan: Two more questions.

    1) I've installed Umbraco but not with the default configuration options (because I wanted to use SQL Server instead of SQL CE), but in that case you start your website without a starter kit.

    Is there a way to install the starter kit afterwards? If I go to the "Packages"-section and search for "Starter kit" it doesn't return anything.

    2) Is it possible to install Umbraco Forms to let my editors test this as well, or is this out of scope? And how about the Member-section?

    Kind regards, Jeffrey

  • Sebastiaan Janssen 4695 posts 13243 karma points MVP admin hq
    5 days ago
    Sebastiaan Janssen
    0

    There's no v8 starter kit available at all yet. :)

  • Daniel 10 posts 90 karma points
    5 days ago
    Daniel
    0

    I had exactly the same issue ( the Server Error in "/" application) The problem was indeed - as jeffrey.schoemaker@perplex.nl pointed out - that I did not install on .NET version 4.7.X, but used .NET 4.6. This option remained the same from my previous projects, so I had to change it. Once that was done, I was able to go through the complete set-up.

    So answer to this post:

    Make sure you select .NET version 4.7.2 when creating the solution

    and you should be able to do the Umbraco V8 install.

  • Craig100 933 posts 1999 karma points c-trib
    1 day ago
    Craig100
    0

    Just tried installing this evening. Nuget installed apparently ok but when running up I get

    Error during installation The database failed to upgrade. ERROR: The database configuration failed with the following message: Object reference not set to an instance of an object. Please check log file for additional information (can be found in '/App_Data/Logs/UmbracoTraceLog.txt')

    Error is:-

    2019-01-18 19:50:33,635 [P19700/D5/T12] INFO   Umbraco.Core.Migrations.Install.DatabaseBuilder - Database configuration status: <p>Installation completed!</p>
    2019-01-18 19:50:33,747 [P19700/D5/T12] ERROR  Umbraco.Web.Install.Controllers.InstallApiController - Installation step DatabaseInstall failed.
    System.NullReferenceException: Object reference not set to an instance of an object.
       at Umbraco.Web.Install.Controllers.InstallApiController.<ExecuteStepAsync>d__17.MoveNext()
    2019-01-18 19:50:33,749 [P19700/D5/T12] INFO   Umbraco.Web.Install.Controllers.InstallApiController - Step completed (1743ms) [Timing 8da78d2]
    2019-01-18 19:50:33,750 [P19700/D5/T12] ERROR  Umbraco.Web.Install.Controllers.InstallApiController - An error occurred during installation step DatabaseInstall
    System.NullReferenceException: Object reference not set to an instance of an object.
       at Umbraco.Web.Install.Controllers.InstallApiController.<ExecuteStepAsync>d__17.MoveNext()
    --- End of stack trace from previous location where exception was thrown ---
       at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
       at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task)
       at Umbraco.Web.Install.Controllers.InstallApiController.<PostPerformInstall>d__14.MoveNext()
    2019-01-18 19:52:48,593 [P19700/D5/T11] DEBUG  Umbraco.Core.MainDom - Signaled  (environment)
    2019-01-18 19:52:48,593 [P19700/D5/T11] INFO   Umbraco.Core.MainDom - Stopping (environment)
    2019-01-18 19:52:48,594 [P19700/D5/T11] DEBUG  Umbraco.Core.MainDom - Stopped (environment)
    2019-01-18 19:52:48,594 [P19700/D5/T11] INFO   Umbraco.Core.MainDom - Released (environment)
    2019-01-18 19:52:48,600 [P19700/D5/T11] DEBUG  Umbraco.Core.Components.ComponentCollection - Terminating. (log components when >100ms) [Timing f21d8c0]
    2019-01-18 19:52:48,601 [P19700/D5/T11] DEBUG  Umbraco.Core.Components.ComponentCollection - Terminated. (0ms) [Timing f21d8c0]
    2019-01-18 19:52:48,601 [P19700/D5/T11] INFO   Umbraco.Web.UmbracoApplicationBase - Application shutdown. Details: "BinDirChangeOrDirectoryRename"
    

    It's a shame as I was hoping to start looking over the V8 UI this weekend.

  • Benjamin Carleski 1 post 72 karma points c-trib
    1 day ago
    Benjamin Carleski
    0

    I am getting the same error that Craig100 got, using the NuGet package this morning on a new project, with an empty Web Application targeting .Net t4.7.2. I also noticed that higher up in the log was an additional error, which I've copied below. It may be because it was an empty database at this point, and it hadn't yet created the migrations table, but I'm not sure.

    2019-01-18 09:38:18,221 [P11780/D2/T9] ERROR  Umbraco.Web.Install.InstallHelper - An error occurred in InstallStatus trying to check upgrades
    System.Web.Services.Protocols.SoapException: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Data.SqlClient.SqlException: String or binary data would be truncated.
    The statement has been terminated.
       at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction)
       at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose)
       at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady)
       at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)
       at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async, Int32 timeout, Task& task, Boolean asyncWrite, SqlDataReader ds)
       at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, TaskCompletionSource`1 completion, Int32 timeout, Task& task, Boolean asyncWrite)
       at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(TaskCompletionSource`1 completion, String methodName, Boolean sendToPipe, Int32 timeout, Boolean asyncWrite)
       at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
       at umbracoUpgradeChecker.BusinessLogic.Logger.Install(Guid id, Boolean isUpgrade, String ip, String domain, String userAgent, Int32 major, Int32 minor, Int32 patch, String versionComment, DateTime timestamp, Boolean completed, String dbProvider, String error) in D:\Dev\UpgradeChecker\umbracoUpgradeChecker\BusinessLogic\Logger.cs:line 127
       at umbracoUpgradeChecker.CheckForUpgrade.Install(Guid installId, Boolean isUpgrade, Boolean installCompleted, DateTime timestamp, Int32 versionMajor, Int32 versionMinor, Int32 versionPatch, String versionComment, String error, String userAgent, String dbProvider) in D:\Dev\UpgradeChecker\umbracoUpgradeChecker\CheckForUpgrade.asmx.cs:line 26
       --- End of inner exception stack trace ---
       at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
       at Umbraco.Web.org.umbraco.update.CheckForUpgrade.Install(Guid installId, Boolean isUpgrade, Boolean installCompleted, DateTime timestamp, Int32 versionMajor, Int32 versionMinor, Int32 versionPatch, String versionComment, String error, String userAgent, String dbProvider)
       at Umbraco.Web.Install.InstallHelper.InstallStatus(Boolean isCompleted, String errorMsg)
    2019-01-18 09:38:44,112 [P11780/D2/T14] INFO   Umbraco.Web.Install.Controllers.InstallApiController - Executing installation step: 'Permissions'. [Timing 6b4e883]
    
  • John Bergman 395 posts 935 karma points
    1 day ago
    John Bergman
    0

    For the nuget error, are you using TFVC for version control? (ie, Azure DevOps with the TFS source repository)

  • Sebastiaan Janssen 4695 posts 13243 karma points MVP admin hq
    1 day ago
    Sebastiaan Janssen
    1

    The install error has been fixed and an updated package was automatically released on myget a few hours ago (alpha58).

  • jeffrey.schoemaker@perplex.nl 285 posts 1090 karma points MVP 2x c-trib
    1 day ago
    jeffrey.schoemaker@perplex.nl
    0

    Thanks, Sebas!

    One more thing. If I do a fresh install I get this "error/suggestion". Once I restart everything is okay, but maybe it's interesting for you:

    enter image description here

  • Craig100 933 posts 1999 karma points c-trib
    1 day ago
    Craig100
    0

    Is there somewhere we can put comments on V8 for collation?

    Thnx

Please Sign in or register to post replies

Write your reply to:

Draft