Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Dominic 8 posts 89 karma points
    Feb 27, 2019 @ 10:31
    Dominic
    0

    Incompatible package - Microsoft.Extensions.DependencyInjection.Abstractions 2.0.0

    Hi,

    I am having difficulty installing a new version of Umbraco 8 using VS 2015 and .NET 4.7.2.

    I receive the following error after running Install-Package UmbracoCms in nuget package manager console.

    > Could not install package
    > 'Microsoft.Extensions.DependencyInjection.Abstractions 2.0.0'. You are
    > trying to install this package into a project that targets 
    > '.NETFramework,Version=v4.7.2', but the package does not contain any
    > assembly references or content files that are compatible with that
    > framework.
    

    Does anyone know how I could resolve this?

  • Sebastiaan Janssen 4847 posts 14391 karma points MVP admin hq
    Feb 27, 2019 @ 10:57
    Sebastiaan Janssen
    0

    Hi Dominic, as per the system requirements you'll need at least Visual Studio 2017 (updated to at least version 15.9.6) for Umbraco 8 to install.

    https://our.umbraco.com/documentation/Getting-Started/Setup/Requirements/

  • Dominic 8 posts 89 karma points
    Feb 27, 2019 @ 11:00
    Dominic
    0

    ah, missed that - thanks

  • Marcio Goularte 343 posts 1142 karma points
    Feb 27, 2019 @ 11:32
    Marcio Goularte
    0

    This happened to me. I changed .NET temporarily to 4.7.1 and it ran normally. But I do not recommend it, I did it for testing.

Please Sign in or register to post replies

Write your reply to:

Draft