Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Ismail Mayat 4267 posts 9146 karma points MVP 2x admin c-trib
    Jun 03, 2019 @ 14:39
    Ismail Mayat
    0

    v8 dashboard not showing

    So just in process of creating my first v8 package its update to examine inspector.

    For the dashboard part i have the class:

        [Weight(-10)]
    public class ExamineInspectorDashBoard : IDashboard
    {
        public string Alias => "examineInspector";
        public string[] Sections => new[] { Umbraco.Core.Constants.Applications.Settings };
        public string View => "/App_Plugins/ExamineInspector/dashboard/formsdashboardintro.html";
        public IAccessRule[] AccessRules => Array.Empty<IAccessRule>();
    }
    

    I should see dashboard in settings but do not see it also no errors in the log.

    Any ideas?

  • Ismail Mayat 4267 posts 9146 karma points MVP 2x admin c-trib
    Jun 03, 2019 @ 15:41
    Ismail Mayat
    0

    So one update, at the moment in settings i see no dashboards at all. If i update the weight to -10 then the other dashboards show up but mine does not.

  • Tarik 145 posts 642 karma points
    Jun 03, 2019 @ 18:11
    Tarik
    100

    I was able to get it working Weight(-10) using vs code by both

    public string[] Sections => new[] { Umbraco.Core.Constants.Applications.Settings };
    

    =========== and ===========

    public string[] Sections => new[] {"settings" };
    

    enter image description here

    Are you using other namespaces than the following:

    using System;
    using Umbraco.Core.Composing;
    using Umbraco.Core.Dashboards;
    
  • Ismail Mayat 4267 posts 9146 karma points MVP 2x admin c-trib
    Jun 10, 2019 @ 16:34
    Ismail Mayat
    0

    Tarik,

    Ok that worked. I get the weight bit but the constants settings value is same as literal value.

    Anyhow no matter i have got a bit further thanks for your help

Please Sign in or register to post replies

Write your reply to:

Draft