Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • MuirisOG 382 posts 1283 karma points
    Jul 18, 2019 @ 16:22
    MuirisOG
    0

    Login Fails when trying to upgrade

    I'm trying to upgrade following the steps here

    https://our.umbraco.com/documentation/Getting-Started/Setup/Upgrading/migrating-to-v8

    but after changing the value for UmbracoDbDsn and the version number for Umbraco in the web.config, I can't log in.

    The log entry says

    "Login attempt failed for username admin from IP address 127.0.0.1"

    Any help is appreciated.

    EDIT: I'm on 7.15.0 and trying to get to 8.1.0

    Thanks Muiris

  • Marcin Zajkowski 112 posts 584 karma points MVP 5x c-trib
    Aug 01, 2019 @ 10:00
    Marcin Zajkowski
    103

    Faced the same issue today. Virtual hug.

    We need to move/ensure all the settings values used for UmbracoMembershipProvider and UsersMembershipProvider, especially useLegacyEncoding="true" which is not present in the 8.1.0 web.config by default.

    After copying and pasting the settings values from exisitng app to the new one (for both providers) it worked. Psstt.. or at least moved us to the next error with the DB quota ;)

  • Nurhak Kaya 46 posts 139 karma points MVP
    Jul 24, 2020 @ 12:31
    Nurhak Kaya
    0

    Good answer @Marcin! I have seen this problem with Umbraco version 8.6.3 and after updating UsersMembershipProvider as follows, I could finally login!

    Update: And the following screen is sadly a Timeout error, which is hopefully easy to fix.

    Update 2: In case some other fellow Umbraco Developers see the same problem; Data migration is taking a long time, but I haven't seen the timeout error after updating the connection string as described here.

    Update 3: Same Timeout error after a few hours, after migrating some of the data. Connection Timeout is set to 3600.

    <!-- Membership Provider -->
        <membership defaultProvider="UmbracoMembershipProvider" userIsOnlineTimeWindow="15">
          <providers>
            <clear />
            <add name="UmbracoMembershipProvider" type="Umbraco.Web.Security.Providers.MembersMembershipProvider, Umbraco.Web" minRequiredNonalphanumericCharacters="0" minRequiredPasswordLength="10" useLegacyEncoding="false" enablePasswordRetrieval="false" enablePasswordReset="false" requiresQuestionAndAnswer="false" defaultMemberTypeAlias="Member" passwordFormat="Hashed" allowManuallyChangingPassword="false" />
            <!--<add name="UsersMembershipProvider" type="Umbraco.Web.Security.Providers.UsersMembershipProvider, Umbraco.Web" />-->
            <add name="UsersMembershipProvider" type="Umbraco.Web.Security.Providers.UsersMembershipProvider, Umbraco.Web" minRequiredNonalphanumericCharacters="0" minRequiredPasswordLength="8" useLegacyEncoding="true" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" passwordFormat="Hashed" />
          </providers>
        </membership>
    

    enter image description here

  • nickornotto 394 posts 896 karma points
    Apr 04, 2022 @ 19:04
    nickornotto
    0

    In general yes, this always worked for me when I tried to upgrade to several versions of Umbraco 8.

    Except Umbraco 8.6 - despite the UsersMembershipProvider has ll the attributes that in other versions, the login does not work.

Please Sign in or register to post replies

Write your reply to:

Draft