Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Ginu Jose 5 posts 86 karma points
    Aug 08, 2019 @ 11:00
    Ginu Jose
    0

    Backoffice errors on Umbraco upgrade from 8.0.2 to 8.1.1

    We have just upgraded our 8.0.2 site to 8.1.1 and have encountered following errors

    1) yellow screen Compilation Error as follows

    Compiler Error Message: CS1061: 'ViewDataDictionary<BackOfficeModel>' does not contain a definition for 'GetUmbracoPath' and no accessible extension method 'GetUmbracoPath' accepting a first argument of type 'ViewDataDictionary<BackOfficeModel>' could be found (are you missing a using directive or an assembly reference?)
    
    Line 113:    </umb-login>
    Line 114:
    Line 115:    @Html.BareMinimumServerVariablesScript(Url, Url.Action("ExternalLogin", "BackOffice", new { area = ViewData.GetUmbracoPath() }), Model.Features, Current.Configs.Global())
    Line 116:
    Line 117:    <script>
    
    Source File: F:\Projects\ABCD\umbraco\Views\Default.cshtml    Line: 115 
    

    We have fixed it by changing the code area = ViewData.GetUmbracoPath() to ViewBag.GetUmbracoPath()

    2) then line 120 has compilation error

    Line 120:            @Html.AngularValueExternalLoginInfoScript(ViewData.GetExternalSignInError())
    

    I have copied the code from previous version as follows to solve the error @Html.AngularValueExternalLoginInfoScript((IEnumerable

    2) Now the compilation errors gone but Back office language is not loading - see screenshot enter image description here

  • cheryl carpenter 13 posts 91 karma points
    Aug 08, 2019 @ 14:20
    cheryl carpenter
    0

    I concur, same steps- same back office errors. Glaring. How does this stuff get released?

  • Steve Megson 150 posts 942 karma points MVP c-trib
    Aug 08, 2019 @ 19:38
    Steve Megson
    101

    What does your umbraco\views\web.config look like? In particular the system.web.webPages.razor/pages/namespaces part. I can only think that it's out-of-date and doesn't reference the assembly that contains those new methods.

    The translation errors happen when you're still using the 8.0.2 version of some of the back office javascript. Obviously that shouldn't happen after the upgrade, but it does seem to be a problem for some 8.1 upgrades. There are some steps described here to make sure there's no old javascript in your project or in your browser cache.

  • Ginu Jose 5 posts 86 karma points
    Aug 09, 2019 @ 06:41
    Ginu Jose
    0

    Thanks a lot Steve, the solution you provided solved the issue.

  • Naeem 1 post 71 karma points
    Aug 26, 2020 @ 19:01
    Naeem
    0

    Please update UmbracoCms.Web to the latest.

    Thanks, Naeem Ahmed

Please Sign in or register to post replies

Write your reply to:

Draft