Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Levente Kosa 129 posts 345 karma points
    Sep 15, 2019 @ 17:07
    Levente Kosa
    0

    Both view and content models are PureLive, with same version.

    Hi,

    I'm using a fresh install of the latest Umbraco (8.1.4). I already added a few doctypes, pages etc. After I changed something in on of the doctype and I started to get this error. I already removed all the pages, templates and doctypes and started from the beginning, but I got the same error message. At the moment I only have a Master and Homapage. I read something about Umbraco.ModelsBuilder.ModelsMode setting. I have the default PureLive value.

    Any idea?

  • Shaishav Karnani from digitallymedia.com 348 posts 1630 karma points
    Sep 16, 2019 @ 05:12
    Shaishav Karnani from digitallymedia.com
    0

    Hi Levente,

    I generally don't use PureLive instead found this option better. In this case, we need to go to Back-office and generate Models but than it ensures that when we are done with Properties creation then only it is executed manually. We have tried on v8.1.4 and Model Builder is working fine.

    <add key="Umbraco.ModelsBuilder.Enable" value="true"/>
    <add key="Umbraco.ModelsBuilder.ModelsMode" value="AppData"/>
    <add key="Umbraco.ModelsBuilder.ModelsDirectory" value="~/AppData/UmbracoModels/"/>
    <add key="Umbraco.ModelsBuilder.ModelsNamespace" value="XXXX.Models.UmbracoModels"/>
    

    Reference Link: https://our.umbraco.com/documentation/reference/templating/modelsbuilder/Builder-Modes

    Please let me know your views and how can we assist further.

    Cheers,

    Shaishav

Please Sign in or register to post replies

Write your reply to:

Draft