Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Alex 5 posts 85 karma points
    Sep 16, 2019 @ 00:15
    Alex
    0

    Umbraco 8 : Dynamic Properties - Error with AngularJS

    We are setting up an Umbraco 8 solution and are attempting to use the FAQ Listing package

    https://our.umbraco.com/packages/website-utilities/faq-listing/

    However when we try to use it there is an error thrown (404) on the urls umbraco/tags and umbraco/rte

    When I step through the angular code I can see it is falling over on

    $scope.rteProperties.push(newRteProperty); 
    

    and

    $scope.tagProperties.push(newTagProperty);
    

    I tried a static test with the method

    $scope.rteProperties.push({
                    label: 'My Test',
                    description: 'desc',
                    view: 'rte',
                    value: "TEST",
                    config: {
                        editor: {
                            readonly: true,
                            toolbar: [],
                            stylesheets: [],
                            dimensions: { height: 400 }
                        }
                    }
    });
    

    However the error is the same , is the method of adding dynamic properties to the back office no longer applicable or is there a new way to do this? I cannot find any example or reference to doing this in Umbraco 8

    Any advice is appreciated!enter image description here

  • Nik 1135 posts 4701 karma points MVP 2x c-trib
    Sep 16, 2019 @ 09:26
    Nik
    0

    Hi Alex,

    Looking at the age of the package and when it's git hub repository last had updates made to it I would assume that it is not v8 compatible.

    This is most likely why you are getting lots of errors as it will need to be re-worked to be made v8 compatible.

    Thanks

    Nik

  • Alex 5 posts 85 karma points
    Sep 17, 2019 @ 23:31
    Alex
    0

    Thanks Nik

    Are you aware of any documentation on how to create properties dynamically in v8??

  • Alex 5 posts 85 karma points
    24 days ago
    Alex
    0

    I have been investigating and have found the following http://www.enkelmedia.se/blogg/2013/12/4/umbraco-7-use-the-rich-text-editor-tinymce-in-a-custom-section/

    I know its an umbarco 7 doc from awhile back but it seems to be the clearest on this

    The package appears to be using option 3 - Lazy Loading

    If i try use the hard code approach as shown in option 1 an editor shows up however both the second and 3rd method that use the view : "rte" approach throw this 404 error

    I have not been able to see what the new means of doing this in Umbraco 8

    If anybody can point me to an example of this

Please Sign in or register to post replies

Write your reply to:

Draft