Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Nik 1471 posts 6483 karma points MVP 4x c-trib
    Mar 24, 2021 @ 22:59
    Nik
    0

    Upgrading Alpha 3 -> Alpha 4 resulting in infinite loop.

    Hi,

    I had an Umbraco v9 Alpha 3 build working. I then upgraded the nuget packages to v9 Alpha 4 and fixed namespace changes. The project builds, however it now results in infinite redirect loops https://localhost:5001/install?redir=true&url=https://localhost:5001/umbraco/AuthorizeUpgrade

    This results in a server error:

    HTTP Error 404.15 - Not Found
    The request filtering module is configured to deny a request where the 
    query string is too long.
    
    Most likely causes:
    Request filtering is configured on the Web server to deny the request 
    because the query string is too long.
    
    Things you can try:
    Verify the configuration/system.webServer/security/requestFiltering/[email protected] setting in the applicationhost.config or web.config file.
    

    Any ideas how I get the upgrade to trigger, or if I'm missing something?

    Thanks

    Nik

  • Bjarke Berg 27 posts 228 karma points hq
    Mar 25, 2021 @ 05:50
    Bjarke Berg
    0

    Haven't seen that error when we did new migrations in the dev environments.

    Seems like a IIS error. Are you running IIS/IIS Express in-process or out of process. Have you tried to start it using kestrel directly? And are there anything interesting in the Umbraco Log?

  • Nik 1471 posts 6483 karma points MVP 4x c-trib
    Mar 25, 2021 @ 08:17
    Nik
    0

    Hey Bjarke :-)

    I've tried running it in IIS or via Kestrel from Visual Studio, and I've tried running it via Kestrel via dotnet run. All of which result in the same essential error displayed in slightly different ways.

    I also can't seem to find log files? Has their location moved?

    This is the start up details from doing dotnet run:

    ❯ dotnet run
    [08:11:21 WRN] Register called when MainDom has not been acquired
    [08:11:21 INF] Creating the content store, localContentDbExists? False
    [08:11:21 INF] Creating the media store, localMediaDbExists? False
    [08:11:23 INF] Acquiring.
    [08:11:23 INF] Acquired.
    [08:11:23 WRN] Distributed calls are not available outside the Run runtime level
    [08:11:23 INF] Adding examine event handlers for 3 index providers.
    [08:11:24 INF] Now listening on: https://localhost:5001
    [08:11:24 INF] Now listening on: http://localhost:5000
    [08:11:24 INF] Application started. Press Ctrl+C to shut down.
    [08:11:24 INF] Hosting environment: Development
    [08:11:24 INF] Content root path: ..PATHTO...\Umbracov9\VSBasedAlpha3\VSBasedAlpha3
    [08:11:37 WRN] Umbraco must install or upgrade.
    

    I'm happy to zip up the project and send it in if you need to see it?

    Thanks

    Nik

  • Bjarke Berg 27 posts 228 karma points hq
    Mar 25, 2021 @ 10:02
    Bjarke Berg
    0

    Logs should be in /umbraco/logs, but also in the console when on development environment.

    I guess a zip could be good to have, but I fear I will also need the db

Please Sign in or register to post replies

Write your reply to:

Draft