Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Jonas Udsen 7 posts 53 karma points
    Nov 03, 2021 @ 14:56
    Jonas Udsen

    Problem with WCF


    Has anyone tried to connect to an WCF webservice from Umbraco 9? I'm getting this error

    The type 'ClientBase<>' is defined in an assembly that is not referenced. You must add a reference to assembly 'System.Private.ServiceModel, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'

    But System.Private.ServiceModel is already in the project and is copied to bin\Debug\net5.0.

    If i start an simpel .net 5 project and an the servicereference, then it's working just fine.

    Thanks Jonas

  • Lasse Offt 8 posts 98 karma points
    Nov 03, 2021 @ 16:47
  • Jonas Udsen 7 posts 53 karma points
    Nov 04, 2021 @ 06:42
    Jonas Udsen

    Thanks, but have tried that, and it didn't solved the problem :-(

  • David Scott 16 posts 107 karma points
    Apr 13, 2023 @ 15:37
    David Scott

    Hello! Was this ever resolved? I too am running into the same issue. I've added my WCF service as a connected service and it has its node. I am now trying to consume or instantiate the service in a view macro partial and I'm getting the same error. Any assistance would be greatly appreciated.

Please Sign in or register to post replies

Write your reply to: