Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Stephen 'KINK' Wilde 23 posts 94 karma points
    Dec 17, 2015 @ 14:02
    Stephen 'KINK' Wilde
    0

    Does not contain a definition for 'RenderAction'

    Hello People,

    Got access to my trial of Umbraco as a Service and am a little confused.

    So I log into the portal -> Create a new project -> Clone project locally using sourcetree -> Open up project in visual studio as a website -> Run the project

    This all works fine. It goes ahead and creates the CE database, requests me to restore the content and then runs fine.

    Now when I close visual studio -> re-open visual studio -> re-open the project and re-run it - It now complains about the following.

    Error 568 'System.Web.Mvc.HtmlHelper

    I don't make any changes within visual studio or the website backend. All I am doing is simply running the project, letting it do its thing, close it, re-open it and then try to run it again.

    Any help or suggestions?

    I am also having a problem with database content being duplicated after restoring content, but I will investigate this and try to come up with some replication steps.

  • Stephen 'KINK' Wilde 23 posts 94 karma points
    Dec 17, 2015 @ 14:48
    Stephen 'KINK' Wilde
    0

    If I follow the steps that tell me how to set it up as a solution then everything runs as expected and I no longer encounter the above error.

    The above error is only ever encountered when running the project as a website within visual studio. As I say, if I follow the steps to set the project up as a solution, then it will work every time I close and re-open without any errors.

Please Sign in or register to post replies

Write your reply to:

Draft