Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Steve 472 posts 1216 karma points
    Jan 07, 2016 @ 16:34
    Steve
    0

    Issues with Instagram and Google Analytics

    We started a Instagram campaign that included Google utm tracking queries on Instagram image link advertising. The utm code is set up correctly, but the url links from the Instagram ads are going to random pages in Umbraco, rather than the redirected url with tracking code. Some of the clicks are going to "/" or "/1234.aspx" or some other random number. What's odd is that if you follow the link, it actually goes to a page in Umbraco.

    Is there some case where "http://yourdomain.com/1234.aspx" is related to an actual page in Umbraco?

    It only does this with Instagram, not Facebook or Twitter though.

  • Greg Woods 12 posts 92 karma points
    Oct 29, 2018 @ 05:58
    Greg Woods
    0

    Hi Steve

    Did you resolve this one? We have noticed some pages appearing this way recently as well e.g. 1234.aspx

    Greg

  • Dan Diplo 1457 posts 5619 karma points MVP 3x c-trib
    Oct 29, 2018 @ 09:35
    Dan Diplo
    0

    "Is there some case where "http://yourdomain.com/1234.aspx" is related to an actual page in Umbraco?"

    Yes. Every page in Umbraco has a unique numeric ID - you can see the ID in the URL when you edit a page or via the Info tab in Umbraco (called Properties in old versions). So the 1234.aspx is actually the "real" URL for pages, as Umbraco looks up what content to serve from this ID. The actual "friendly" URLs you see are just aliases to this.

    Why your tracking is picking up on these URLs I'm not sure. But there are a couple of things you could do:

    You could disable Umbraco being able to use 1234.aspx URLs. You can do this by editing umbracoSettings.config and look for thewebRouting entry and change it to read:

    disableFindContentByIdPath="true"

    But this will lead to a 404 for those links.

    A better option, though, might be to add a Canonical Link to your page to tell web indexers what your preferred URL for the page is - see https://yoast.com/rel-canonical/

    You can generate a canonical URL fairly easily in Umbraco with the following code added to the HEAD of your template(s);

    <link rel="canonical" href="@Model.Content.UrlAbsolute()" />
    
Please Sign in or register to post replies

Write your reply to:

Draft